作曲家要求mongodb / mongodb失败

在ubuntu 18.04中,使用php 5.6,php5.6-fpm,nginx,使用ubuntu的mongodb </ p> \ n

  composer需要mongodb / mongodb 
</ code> </ pre>

错误</ p>

 使用版本^ 1.4  for mongodb / mongodb 
./composer.json已更新
使用包信息加载编写器存储库
更新依赖项(包括require-dev)
您的要求无法解析为可安装的软件包集。

Problem 1

  • mongodb / mongodb 1.4.2需要ext-mongodb ^ 1.5.0 - &gt; 请求的PHP扩展mongodb安装了错误的版本(1.4.2)。
  • mongodb / mongodb 1.4.1需要ext-mongodb ^ 1.5.0 - &gt; 请求的PHP扩展mongodb安装了错误的版本(1.4.2)。
  • mongodb / mongodb 1.4.0需要ext-mongodb ^ 1.5.0 - &gt; 请求的PHP扩展mongodb安装了错误的版本(1.4.2)。
  • mongodb / mongodb的安装请求^ 1.4 - &gt; mongodb / mongodb [1.4.0,1.4.1,1.4.2]可以满足。 </ code> </ pre> </ div>

展开原文

原文

In ubuntu 18.04, with php 5.6, php5.6-fpm, nginx, using ubuntu's mongodb

composer require mongodb/mongodb

Error

Using version ^1.4 for mongodb/mongodb
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.


Problem 1
    - mongodb/mongodb 1.4.2 requires ext-mongodb ^1.5.0 -> the requested PHP extension mongodb has the wrong version (1.4.2) installed.
    - mongodb/mongodb 1.4.1 requires ext-mongodb ^1.5.0 -> the requested PHP extension mongodb has the wrong version (1.4.2) installed.
    - mongodb/mongodb 1.4.0 requires ext-mongodb ^1.5.0 -> the requested PHP extension mongodb has the wrong version (1.4.2) installed.
    - Installation request for mongodb/mongodb ^1.4 -> satisfiable by mongodb/mongodb[1.4.0, 1.4.1, 1.4.2].

dtnnpt11795
dtnnpt11795 php.net/manual/en/mongodb.tutorial.php
大约 2 年之前 回复
doutui6241
doutui6241 我不使用pecl包来安装它们。
大约 2 年之前 回复
dongshao9106
dongshao9106 您需要将mongodb的pecl包更新到至少^1.5.0。php.net/manual/en/mongodb.installation.pecl.php
大约 2 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问