Laravel CRON Artisan错误

当我通过cron调用artisan命令时出现错误:</ p>

 <  code> /usr/local/php7.0/bin/php:/usr/local/adds/openssl/lib/libssl.so.1.0.0:没有可用的版本信息(/ usr / local / lib / libcurl需要。  so.4)
/ usr / local / php7.0 / bin / php:/usr/local/adds/openssl/lib/libssl.so.1.0.0:没有可用的版本信息(/ usr / local /需要) lib / libcurl.so.4)
/ usr / local / php7.0 / bin / php:/usr/local/adds/openssl/lib/libcrypto.so.1.0.0:没有可用的版本信息(需要/ usr / local / lib / libcurl.so.4)

[Symfony \ Component \ Debug \ Exception \ FatalThrowableError]
未找到类'Symfony \ Component \ Process \ ExecutableFinder'
</ code> < / pre>

我的cron命令是:</ p>

/usr/local/php7.0/bin/php / home / path_to_project / artisan email:send </ p >

出了什么问题? 当我用php 5.6调用这个命令时,它是一样的。 </ p>
</ div>

展开原文

原文

When I call a artisan command by cron i get error:

/usr/local/php7.0/bin/php: /usr/local/adds/openssl/lib/libssl.so.1.0.0: no version information available (required by /usr/local/lib/libcurl.so.4)
/usr/local/php7.0/bin/php: /usr/local/adds/openssl/lib/libssl.so.1.0.0: no version information available (required by /usr/local/lib/libcurl.so.4)
/usr/local/php7.0/bin/php: /usr/local/adds/openssl/lib/libcrypto.so.1.0.0: no version information available (required by /usr/local/lib/libcurl.so.4)


  [Symfony\Component\Debug\Exception\FatalThrowableError]       
  Class 'Symfony\Component\Process\ExecutableFinder' not found  

My cron command is:

/usr/local/php7.0/bin/php /home/path_to_project/artisan email:send

What's wrong? When I call this command by php 5.6 it's the same.

dpd7195
dpd7195 尝试在根项目目录中运行composerdump-autoload命令,看看是否能解决您的问题。
大约 2 年之前 回复
duanmei2459
duanmei2459 创建一个批处理文件,该文件将导致您的cron命令到cron核心文件。
大约 2 年之前 回复
dongqie4233
dongqie4233 它在cron之外工作吗?您是否安装了所有服务器要求?
大约 2 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐