duanju6788
2017-09-28 21:32
浏览 57
已采纳

CakePHP烘焙PHP版本错误

I am using Hostgator for hosting to start, I have the file location of the website set to public_html\WebsiteName\Public (where public is the directory for the CakePHP.

I am trying to run bin/Cake bake and I receive the following error:

Minimum PHP version: 5.6. You are using: 5.4.45.

I have verified that the all the directories leading up to and including the CakePHP folders are 7.0 or 5.6. When I do a php -v i get version PHP 5.6.30 in all those folders as well.

Is there anything I can do to choose what version cake bake uses? What might I be missing here?

图片转代码服务由CSDN问答提供 功能建议

我使用Hostgator进行托管启动,我将网站的文件位置设置为 public_html \ WebsiteName \ Public (其中public是CakePHP的目录。

我正在尝试运行 bin / Cake bake ,我收到以下错误 :

最低PHP版本:5.6。您正在使用:5.4.45。

我已经验证了导致并包括的所有目录 CakePHP文件夹是7.0或5.6。当我在所有这些文件夹中执行php -vi获取版本PHP 5.6.30时。

我有什么办法可以选择什么版本的蛋糕 烘焙使用?我在这里可能会缺少什么?

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • dongshaoxiong0012 2018-09-28 04:07
    已采纳

    That is your webserver problem. There is nothing to do with cake bake.

    Find a way to configure which php version that you have to use.

    已采纳该答案
    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题