在CentOS上安装时出现php-mcrypt依赖问题(最新服务器版本)

执行 yum install php-mcrypt * </ strong>时出现以下错误。</ p >

 错误:包:php-mcrypt-5.3.28-4.w5.x86_64(webtatic)
需要:php-common = 5.3.28-4.w5
已安装: php-common-5.4.30-1.el7.remi.x86_64(@remi)
php-common = 5.4.30-1.el7.remi
可用:php-common-5.2.17-1.1.w5。 x86_64(webtatic)
php-common = 5.2.17-1.1.w5
可用:php-common-5.3.27-2.w5.x86_64(webtatic)
php-common = 5.3.27-2.w5

可用:php-common-5.3.28-1.w5.x86_64(webtatic)
php-common = 5.3.28-1.w5
可用:php-common-5.3.28-2.w5.x86_64 (webtatic)
php-common = 5.3.28-2.w5
可用:php-common-5.3.28-3.w5.x86_64(webtatic)
php-common = 5.3.28-3.w5 \ n可用:php-common-5.3.28-4.w5.x86_64(webtatic)
php-common = 5.3.28-4。 w5
可用:php-common-5.4.16-21.el7.x86_64(base)
php-common = 5.4.16-21.el7
错误:包:php-mcrypt-5.3.28-4.w5 .x86_64(webtatic)
需要:libltdl.so.3()(64位)
</ code> </ pre>

我是否需要降级我的php-common或者是否有更好的 替代?</ p>

请详细说明您的回复,因为这是我在CentOS机器上设置LAMP的第一次经验。</ p>
</ div>

展开原文

原文

When executing yum install php-mcrypt* I get the following error.

Error: Package: php-mcrypt-5.3.28-4.w5.x86_64 (webtatic)
           Requires: php-common = 5.3.28-4.w5
           Installed: php-common-5.4.30-1.el7.remi.x86_64 (@remi)
               php-common = 5.4.30-1.el7.remi
           Available: php-common-5.2.17-1.1.w5.x86_64 (webtatic)
               php-common = 5.2.17-1.1.w5
           Available: php-common-5.3.27-2.w5.x86_64 (webtatic)
               php-common = 5.3.27-2.w5
           Available: php-common-5.3.28-1.w5.x86_64 (webtatic)
               php-common = 5.3.28-1.w5
           Available: php-common-5.3.28-2.w5.x86_64 (webtatic)
               php-common = 5.3.28-2.w5
           Available: php-common-5.3.28-3.w5.x86_64 (webtatic)
               php-common = 5.3.28-3.w5
           Available: php-common-5.3.28-4.w5.x86_64 (webtatic)
               php-common = 5.3.28-4.w5
           Available: php-common-5.4.16-21.el7.x86_64 (base)
               php-common = 5.4.16-21.el7
Error: Package: php-mcrypt-5.3.28-4.w5.x86_64 (webtatic)
           Requires: libltdl.so.3()(64bit)

Do I need to downgrade my php-common or is there a better alternative?

Please be detailed in your response as this is my first experience setting up LAMP on a CentOS machine.

1个回答



我通过升级到PHP 5.5然后使用以下命令格式安装任何所需的扩展来解决了这个问题。</ p>

  yum --enablerepo = remi,remi-php55重新安装php-mcrypt 
</ code> </ pre>

似乎没有我的安装尝试想玩 很好地使用PHP 5.4.30。</ p>
</ div>

展开原文

原文

I resolved the issue by upgrading to PHP 5.5 and then installing any required extensions by using the following command format.

yum --enablerepo=remi,remi-php55 reinstall php-mcrypt

It seems that none of my installation attempts wanted to play nicely with PHP 5.4.30.

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐