在CentOS-7-x86_64-Minimal-1810安装mysql8.0.16问题

老师好:
最近在学习centos搭建lamp环境,在csdn中找到好多帐子很实
用,也学到不少命令。
现在我的问题是装到mysql这一环节给卡住了,
我的安装环境是:CentOS-7-x86_64-Minimal-1810
根据这个贴子https://blog.csdn.net/qq_38821502/article/details/90053717 安装很顺利,但是到了第10.授予root用户远程访问权限中的4)grant all privileges on . to ‘root’@’%’ identified by ‘tsk007’ with grant option;
这一步我的机子出现错误提示,想问一下这应该怎么解决?

ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '. to ‘root’@’%’ identified by ‘123456789’ with grant option' at line 1

3个回答

提示了这个地方有语法错误,grant privileges 需要指定授权的库和表, 如果是所有库表的话,应该写成

grant all privileges on *.* to ‘root’@’%’ identified by ‘tsk007’ with grant option;

你参考的网站里面没有显示出 * 符号,应该是csdn的markdown语法导致的。你可以看他下面图片里面的sql语句

lhmx557
lhmx557 竟然成功了
10 个月之前 回复
lhmx557
lhmx557 然后我试着用ssh连接,输入grant all privileges on *.* to 'root' @'%';
10 个月之前 回复
lhmx557
lhmx557 感谢老师的回答
10 个月之前 回复
lhmx557
lhmx557 非常感谢你的回答,很细的找出我的一些问题,但按你说的输入后还是报错,我头都晕了
10 个月之前 回复

你这是语法错误啊 你确定是这样写的么 use mysql;
后面有 ;符号

lhmx557
lhmx557 感谢老师的回答
10 个月之前 回复

grant all on . to 'root'@'%' identified by '你自己root密码' with grant option;

lhmx557
lhmx557 感谢老师的回答
10 个月之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐