Yeah, that syntax is typically flagged by most decent IDEs as "Accidental Assignment" (since it's not obvious if you meant =
or ==
). Most will allow you to wrap it in a ()
to silence the error (since then it's apparent you want the result rather than a test):
if (($message_array = @unserialize($e->getMessage()))) {
}
Also, for readability and maintainability, I would suggest a few things there.
First, use braces. Since it's only a special case that lets you not use them, I personally think it's better form to always use them so that it's clear what was meant.
Second, do all asignment outside of the if
clause. It makes it more explicit and easier to tell at a quick glance what you meant. Plus it looks less cluttered.
$message_array = @unserialize($e->getMessage());
if ($message_array) {
...
}
Third, I would suggest avoiding the @
operator. To me it's a sign of code-rot. While I know it's easy to use and easier than properly handling the error, I think it's just a short-cut that will make life harder for you. You can avoid it in a few ways. First, you can check the string before you pass it to unserialize
. Make sure it's non-empty, a string, etc. Secondly, you can install an error handler
to throw exceptions on PHP errors (what I do). That way, you just wrap the unserialize
call in a try {} catch(){}
block. It's nicer since you actually can inspect the error rather than just trusting that the thrown error is what you think it is...