无法安装Laravel收银台

The first error I had was php version wasn't up to date, so when I updated it, I receive this:

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: remove laravel/framework v5.0.34
    - Conclusion: don't install laravel/framework v5.0.34
    - Conclusion: don't install laravel/framework v5.0.33
    - Conclusion: don't install laravel/framework v5.0.32
    - Conclusion: don't install laravel/framework v5.0.31
    - Conclusion: don't install laravel/framework 5.0.30
    - Conclusion: don't install laravel/framework v5.0.29
    - Conclusion: don't install laravel/framework v5.0.28
    - Conclusion: don't install laravel/framework v5.0.27
    - Conclusion: don't install laravel/framework v5.0.26
    - Conclusion: don't install laravel/framework v5.0.25
    - Conclusion: don't install laravel/framework v5.0.24
    - Conclusion: don't install laravel/framework v5.0.23
    - Conclusion: don't install laravel/framework v5.0.22
    - Conclusion: don't install laravel/framework v5.0.21
    - Conclusion: don't install laravel/framework v5.0.20
    - Conclusion: don't install laravel/framework v5.0.19
    - Conclusion: don't install laravel/framework v5.0.18
    - Conclusion: don't install laravel/framework v5.0.17
    - Conclusion: don't install laravel/framework v5.0.16
    - Conclusion: don't install laravel/framework v5.0.15
    - Conclusion: don't install laravel/framework v5.0.14
    - Conclusion: don't install laravel/framework v5.0.13
    - Conclusion: don't install laravel/framework v5.0.12
    - Conclusion: don't install laravel/framework v5.0.11
    - Conclusion: don't install laravel/framework v5.0.10
    - Conclusion: don't install laravel/framework v5.0.9
    - Conclusion: don't install laravel/framework v5.0.8
    - Conclusion: don't install laravel/framework v5.0.7
    - Conclusion: don't install laravel/framework v5.0.6
    - Conclusion: don't install laravel/framework v5.0.5
    - Conclusion: don't install laravel/framework v5.0.4
    - Conclusion: don't install laravel/framework v5.0.3
    - Installation request for laravel/cashier ~6.0 -> satisfiable by laravel/cashier[v6.0.0].
    - Conclusion: don't install laravel/framework v5.0.2
    - Conclusion: don't install laravel/framework v5.0.1
    - laravel/cashier v6.0.0 requires illuminate/database ~5.1 -> satisfiable by illuminate/database[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22, v5.1.25, v5.1.28, v5.1.6, v5.1.8, v5.2.0].
    - don't install illuminate/database v5.1.1|don't install laravel/framework v5.0.0
    - don't install illuminate/database v5.1.13|don't install laravel/framework v5.0.0
    - don't install illuminate/database v5.1.16|don't install laravel/framework v5.0.0
    - don't install illuminate/database v5.1.2|don't install laravel/framework v5.0.0
    - don't install illuminate/database v5.1.20|don't install laravel/framework v5.0.0
    - don't install illuminate/database v5.1.22|don't install laravel/framework v5.0.0
    - don't install illuminate/database v5.1.25|don't install laravel/framework v5.0.0
    - don't install illuminate/database v5.1.28|don't install laravel/framework v5.0.0
    - don't install illuminate/database v5.1.6|don't install laravel/framework v5.0.0
    - don't install illuminate/database v5.1.8|don't install laravel/framework v5.0.0
    - don't install illuminate/database v5.2.0|don't install laravel/framework v5.0.0
    - Installation request for laravel/framework 5.0.* -> satisfiable by laravel/framework[5.0.30, v5.0.0, v5.0.1, v5.0.10, v5.0.11, v5.0.12, v5.0.13, v5.0.14, v5.0.15, v5.0.16, v5.0.17, v5.0.18, v5.0.19, v5.0.2, v5.0.20, v5.0.21, v5.0.22, v5.0.23, v5.0.24, v5.0.25, v5.0.26, v5.0.27, v5.0.28, v5.0.29, v5.0.3, v5.0.31, v5.0.32, v5.0.33, v5.0.34, v5.0.4, v5.0.5, v5.0.6, v5.0.7, v5.0.8, v5.0.9].

Does anyone know what it means and how to fix it so cashier will install successfully?

doufangzhang4454
doufangzhang4454 啊,是的,做到了。谢谢!
4 年多之前 回复
dsgdfh302506
dsgdfh302506 太棒了,你可能想尝试收银员的~5.0分支,似乎6.0是使用5.1版本的照明库而不是5.0版本。
4 年多之前 回复
dongliang1865
dongliang1865 php版本是PHP5.6.16,Laravel是5.0.34
4 年多之前 回复
duancan1900
duancan1900 你有什么版本的PHP,你在哪个版本的laravel等...
4 年多之前 回复

2个回答



如果您在Laravel 5.0上遇到此问题,您可能需要确保获取兼容的Cashier版本。</ p>

Laravel Cashier ~5.0 </ code>应该适用于Laravel 5.0。</ p>
</ div>

展开原文

原文

If you are having this issue on Laravel 5.0 you will probably want to make sure you grab the version of Cashier that is compatible.

Laravel Cashier ~5.0 should work with Laravel 5.0.



虽然通过这种方式解决了我遇到了同样的问题:</ p>

作曲家需要spatie / laravel -medialibrary </ p>
</ div>

展开原文

原文

I was facing the same problem although solved by this way:

composer require spatie/laravel-medialibrary

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问