dongshuo5101
2016-01-29 02:13
浏览 100
已采纳

laravel使用.env但不在config \ database.php中使用config?

I'm learning laravel. I newly created a project and trying to create model, i set up the db config database.php and type php artisan migrate, but there is a error message

C:\xampp\htdocs\l1\blog>php artisan migrate


  [PDOException]
  SQLSTATE[HY000] [1045] Access denied for user 'homestead'@'localhost' (usin
  g password: YES)

I see it is using .env config but not using config in my config.php, why?

图片转代码服务由CSDN问答提供 功能建议

我正在学习laravel。 我新创建了一个项目并尝试创建模型,我设置了db config database.php并输入php artisan migrate,但是有一条错误消息

  C:\ xampp  \ htdocs \ l1 \ blog> php artisan migrate 
 
 
 [PDOException] 
 SQLSTATE [HY000] [1045]拒绝访问用户'homestead'@'localhost'(usin 
g密码:YES)
 <  / code>  
 
 

我看到它使用的是.env配置,但是我的config.php中没有使用config,为什么?

  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • dongqiang2069 2016-01-29 09:43
    已采纳

    You can change the .env file to suit your database config settings as follows

    DB_HOST=localhost
    DB_MAIN=MYDB
    DB_USERNAME=root
    DB_PASSWORD=root
    

    Change the values of those keys according to your database connection. And place them in .env file.

    restart your server once and proceed.

    Other wise you can directly place those values in database.php file by replacing something like env('DB_USERNAME'),env('DB_PASSWORD') with direct values in either single or double quotes as follows

     'main' => [
            'driver'    => 'mysql',
            'host'      =>  '',
            'database'  =>  'mydb',
            'username'  => 'root',
            'password'  => 'root123',
            'charset'   => 'utf8',
            'collation' => 'utf8_unicode_ci',
            'prefix'    => '',
            'strict'    => false,
        ],
    

    The code actually present in database.php file can be something as follows

          'main' => [
            'driver'    => 'mysql',
            'host'      => env('DB_HOST', 'localhost'),
            'database'  => env('DB_MAIN', 'forge'),
            'username'  => env('DB_USERNAME', 'forge'),
            'password'  => env('DB_PASSWORD', ''),
            'charset'   => 'utf8',
            'collation' => 'utf8_unicode_ci',
            'prefix'    => '',
            'strict'    => false,
        ],
    

    You can simply replace these values with above mentioned values.

    已采纳该答案
    打赏 评论

相关推荐 更多相似问题