dongxiejie9387
dongxiejie9387
2013-09-24 15:07
浏览 35
已采纳

当我想使用另一个版本的PHP时,Apache不起作用

My Wamp server works fine with the latest version of PHP. But I need to run it with an older version of PHP and when I switch to that older version, Apache does not start and Wamp icon remains orange.

Apache version: 2.2.22
PHP version that is working: 5.3.13
desired PHP version (not working): 5.2.8

Wamp server version 2.2

Error log:

[Tue Sep 24 17:15:26 2013] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Tue Sep 24 17:15:26 2013] [notice] Child 8356: Exit event signaled. Child process is ending.
[Tue Sep 24 17:15:27 2013] [notice] Child 8356: Released the start mutex
[Tue Sep 24 17:15:28 2013] [notice] Child 8356: All worker threads have exited.
[Tue Sep 24 17:15:28 2013] [notice] Child 8356: Child process is exiting
[Tue Sep 24 17:15:28 2013] [notice] Parent: Child process exited successfully.
[Tue Sep 24 17:15:34 2013] [notice] Apache/2.2.22 (Win64) PHP/5.3.13 configured -- resuming normal operations
[Tue Sep 24 17:15:34 2013] [notice] Server built: May 13 2012 19:41:17
[Tue Sep 24 17:15:34 2013] [notice] Parent: Created child process 10372
httpd.exe: Syntax error on line 127 of C:/wamp/bin/apache/apache2.2.22/conf/httpd.conf: Cannot load C:/wamp/bin/php/php5.2.8/php5apache2_2.dll into server: %1 \xe4r Not a valid Win32-program.  
[Tue Sep 24 17:15:34 2013] [crit] (OS 6)Referensen (handle) är felaktig.  : master_main: create child process failed. Exiting.
  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • douqiang5933
    douqiang5933 2013-09-24 23:04
    已采纳

    Pedram,

    Sarah is correct.

    All the PHP ADDONs provided on the WAMPServer site are compiled to 32bit.

    If you installed WAMPServer 64bit you will have a 64bit Apache, if you then install PHP5.2.8's addon that will be 32bit that will not work.

    If you need to run PHP5.2.8 then you must install WAMPServer 32bit and then add the PHP5.2.8 addon. The 32bit WAMPServer will run just fine on a 64bit Windows, and it is a lot easier to find 32bit PHP & Apache extensions than it is to find 64bit ones.

    EDIT: After Questioner change to 32 bit WAMPServer

    OK Pedram,

    Now the problem is that you have Apache 2.4.4 ( which is compiled with MSCV10 ) and PHP5.2.8 ( which is compiled with MSVC6 )

    That combination will not work.

    You also have to install an Apache that is compiled with MSVC6 so try Apache 2.2.22.

    Can I suggest that you also read the thread on the WampServer forum called Wampserver 2.4 What to do after Installing.

    It seems that the WAMPServer 2.4 was done in a bit of a rush and has quite a few minor issues, most of which only effect you if you are trying to switch between versions of Apache and PHP, which of course is exactly what you are trying to do.

    If you still get problems after reading that, you can contact me on the WampServer forum and I can offer to troubleshoot your situation using TeamViewer.

    点赞 评论

相关推荐