douyong1850
2017-11-06 17:43
浏览 104
已采纳

为什么curl需要以这种方式设置以允许使用fiddler而其余部分不允许?

I tried using curl with netbean and my traffic do not show up on fiddler.

I look things up and I saw

http://docs.telerik.com/fiddler/Configure-Fiddler/Tasks/ConfigurePHPcURL

It says I have to set proxy to

curl_setopt($ch, CURLOPT_PROXY, '127.0.0.1:8888');

I sort of understand.

But my visual studio, my firefox, and everything doesn't have to set proxy.

Why does my netbean curl requires me to do so?

图片转代码服务由CSDN问答提供 功能建议

我尝试使用curl和netbean,我的流量没有显示在fiddler上。

我查看了,我看到了

http://docs.telerik.com/fiddler/Configure-Fiddler/Tasks/ConfigurePHPcURL

它说我必须将代理设置为 \ n

curl_setopt($ ch,CURLOPT_PROXY,'127.0.0.1:8888') ;

nn

我有点理解。

但是 我的视觉工作室,我的Firefox,一切都没有设置代理。

为什么我的netbean curl要求我这样做?

  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • douyun3631 2017-11-06 20:26
    已采纳

    Configure Browsers for Fiddler > Manual Configuration:

    To manually configure any browser to send traffic to Fiddler, set the browser to connect to a proxy server. This setting is usually in the Options or Preferences menu. Use these settings:

    Address: 127.0.0.1 Port: 8888

    So NetBeans requires the same settings for capturing cURL traffic.

    已采纳该答案
    打赏 评论

相关推荐 更多相似问题