douxieqiu0651
2017-10-03 08:00
浏览 26
已采纳

Magento扩展没有出现在后端

What's wrong? ##

Recently I tried out an extension on my test environment of magento 1.9.2 It was a succesful installation with magento connect.

The extension worked perfectly.

so I tried it out on my real environment but the extension / module doesn't work and won't show up in my modules tab ( system - configuration - advanced ). so I can't enable or disable it.

the files have been places in the right folder ( app - code - community ) So far I tried

  1. reinstalling the extension
  2. logging in and out
  3. flushing the cache
  4. re-indexing the website

But sadly it did not seem to work on my real environment.


What extension?

this is about the "Catalog Search Refinement FREE" extension.

The extension has no panel since all this extension does is change the way magento searches for products.


I am new to magento, so I might not know much and I've read a lot but I can't find what I'm doing wrong.

图片转代码服务由CSDN问答提供 功能建议

怎么了? ##

最近我在magento 1.9.2的测试环境中试用了一个扩展程序 这是一个使用magento connect的成功安装。

扩展工作完美。

所以我在我的真实环境中试用了它,但扩展/模块不起作用,不会显示在我的模块选项卡中(系统 - 配置 - 高级) 。 所以我无法启用或禁用它。

文件已放置在正确的文件夹中(应用程序 - 代码 - 社区) 到目前为止我试过了

  1. 重新安装扩展程序
  2. 登录和退出
  3. 刷新缓存
  4. 重新索引网站

    但遗憾的是,它似乎不适用于我的真实环境。


    什么扩展名 ?

    这是关于“Catalog Search Refinement FREE”扩展名。

    扩展程序没有面板,因为所有这些扩展程序都改变了magento的方式 搜索产品。


    我是magento的新手,所以我可能不太了解并且我已经阅读了很多但我找不到我的内容 我做错了。

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • douban5644 2017-10-19 07:49
    已采纳

    So okay I found out Magento wasn't deleting my cache properly, after hours and hours of searching for errors, editing lines of code it was simply running on my cache all the time. Even after flushing the cache and reindexing my website countless times I wondered if my cache was being deleted correctly. Since I kept getting the same advice from other people to flush my cache I wondered if it was being flushed correctly. so I went to var/cache and saw that even after flushing my cache these files remained.

    So I deleted all the folders in var/cache , flushed the magento cache and storage, after that I logged out and in on my Magento back-end and I noticed directly that the extension was working as it should.

    点赞 评论
  • dongyimo1293 2017-10-04 04:44

    Ideally you want to test installing it on a development server which is not your live site, so you can make sure there are no conflicts with your existing system. But in general, here are some steps to make sure that everything goes smoothly:

    1.If it is turned on, disable compilation before installing your extension manually (System -> Tools -> Compilation)

    2.Make sure you are using the Ubuntu "cp" command properly to copy the files into the appropriate directories.

    3.When you have copied all the files, clear the store cache, log out of the admin and log back in.

    If at this stage, you still do not see the module name showing up in System -> Configuration -> Advanced this means that Magento is not picking it up from the app/etc/modules folder.

    Go into {docroot}/app/etc/modules and open up the XML file from the module that you copied in there. Make sure that the XML node for is set to true and also since you're on Ubuntu, run xmllint on the file also to make sure it is valid XML.

    Beyond that any problems that exist may be part of the PHP code.

    Make sure that the file name in app/etc/modules/[Namespace]_[Module].xml match the namespace and module in

    <?xml version="1.0"?>
        <config>
            <modules>
                <[Namespace]_[Module]> <!-- Equal to this -->
                  ...
                </[Namespace]_[Module]>
            </modules>
        </config>
    
    Same goes for the the configuration file in app/code/[codePool]/[Namespace]/[Module]/etc/config.xml and its content
    <?xml version="1.0"?>
    <config>
        <modules>
            <[Namespace]_[Module]>
                <version>1.0.0</version>
            </[Namespace]_[Module]>
        </modules>
    

    Pay special attention to capitals and lowercase characters in files and folders name as well as module configuration and declaration files. In all cases they need to match. Hope it helps.

    点赞 评论

相关推荐 更多相似问题