dongyue0263
2016-09-20 10:23
浏览 77
已采纳

PHP文件没有在firefox中运行

Firefox only asks me to download the file's source. View-source shows me source code.

a2enmod php7.0

Considering conflict php5 for php7.0:
Module php7.0 already enabled

php -v

PHP 7.0.8-0ubuntu0.16.04.2 (cli) ( NTS ) Copyright (c) 1997-2016 The PHP Group Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies with Zend OPcache v7.0.8-0ubuntu0.16.04.2, Copyright (c) 1999-2016, by Zend Technologies

图片转代码服务由CSDN问答提供 功能建议

Firefox只要求我下载文件的来源。 View-source显示源代码。

a2enmod php7.0

 考虑到php7 for php7.0的冲突:
模块已启用php7.0 
    
 
 

php -v

PHP 7.0.8-0ubuntu0.16.04.2(cli)(NTS) 版权所有(c)1997 -2016 PHP Group Zend Engine v3.0.0,版权所有(c)1998-2016 Zend Technologies ,Zend OPcache v7.0.8-0ubuntu0.16.04.2,版权所有(c)1999-2016,作者:Zend Technologies

  • 写回答
  • 好问题 提建议
  • 追加酬金
  • 关注问题
  • 邀请回答

1条回答 默认 最新

  • duanjie2940 2016-09-20 13:46
    最佳回答

    I recommend a full installation in case you intend to develop something.

    Example: Ubuntu 16.04.1 LTS (xenial)

    sudo apt-get install php7.0 php7.0-cli php7.0-common php7.0-odbc php7.0-pgsql php7.0-sqlite3 php7.0-mysql php7.0-fpm php7.0-curl php7.0-intl php7.0-gd php7.0-mysql php7.0-bz2 php7.0-zip php7.0-gmp php7.0-json php7.0-xsl php7.0-tidy php7.0-xmlrp php7.0-readline php7.0-mbstring php7.0-mcrypt php7.0-recode php7.0-pspell php7.0-dev php-gettext libapache2-mod-php7.0
    
    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题