dongzhuo8210 2018-05-15 12:58
浏览 249
已采纳

codeigniter显示stream_socket_client():无法在sendmail上启用加密此错误?

I am trying to send email with code igniter with xampp server on my local machine but its not working. it shows me some errors that i searched alot on net but i am helpless now all solutions that i tried are failed for me.

below are my 3 errors:

Message: stream_socket_client(): SSL: The operation completed successfully.

Message: stream_socket_client(): Failed to enable crypto

Message: stream_socket_client(): unable to connect to ssl://smtp.gmail.com:587 (Unknown error)

this is my php code:

$config = Array(
        'protocol'  => 'smtp',
        'smtp_host' => 'ssl://smtp.gmail.com',
        'smtp_port' => '587',
        'smtp_user' => 'mygmailid@gmail.com',
        'smtp_pass' => 'xxxmypassword',
        'mailtype'  => 'html',
        'starttls'  => true,
        'newline'   => "
"
                    );
        $message = '';
        $this->load->library('email', $config);
        $this->email->set_newline("
");
        $this->email->initialize($config);
        $this->email->from('mygmailid@gmail.com');
        $this->email->to('mygmailid@gmail.com');
        $this->email->subject('Resume from JobsBuddy for your Job posting');
        $this->email->message($message);
      if($this->email->send())
        {
          echo 'Email sent.';
        }
     else
        {
         show_error($this->email->print_debugger());
        }

on print_debugger i get this error too:

The following SMTP error was encountered: 0 Unable to send email using PHP SMTP. Your server might not be configured to send mail using this method.

This is a multi-part message in MIME format. Your email application may not support this format.

please guide me with proper solution.

  • 写回答

1条回答 默认 最新

  • duancashi1362 2018-05-15 13:28
    关注

    You email config should look something like this:

    $config = Array(
      'protocol'  => 'smtp',
      'smtp_host' => 'ssl://smtp.gmail.com',
      'smtp_port' => 465,
      'smtp_user' => 'YOUR_USERNAME',
      'smtp_pass' => 'YOUR_PASSWORD',
      'mailtype'  => 'html',
      'charset'   => 'utf-8',
      'newline'   => "
    ",
      'wordwrap'  => TRUE,
    );
    

    And like Sandeep J Patel said in his comment, you will also need to enable access for less secure apps in your gmail account settings.

    See their help page about that: https://support.google.com/accounts/answer/6010255?hl=en

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

悬赏问题

  • ¥20 判断两个表是否完全相同
  • ¥20 工控机出现散热器转一下停一下这种情况,是什么原因造成的
  • ¥15 双显卡,启动docker容器报错。
  • ¥15 想编写一个期货跨期套利的程序
  • ¥15 一个线程在sleep的时候set一个信号会起作用吗
  • ¥100 需求高精度PT100设计电路和算法
  • ¥15 单片机配网,继电器开关,广播
  • ¥60 Qcustomplot绘制实时动态曲线
  • ¥20 运用matlab画x-y图
  • ¥15 用idea运行项目,运行tomcat报错:断言失败