2017-02-28 19:58
浏览 105

CentOS 6:安装php-gd的事务检查错误

I have a VPS with CentOS 6.8 in which I am trying to install PhP GD. I have tried sudo yum install php-gd, as I installed others libraries. When I do this, I get the following:

Loaded plugins: fastestmirror, refresh-packagekit
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base:
 * epel:
 * extras:
 * ius:
 * remi-php55:
 * remi-safe:
 * updates:
 * webtatic:
Resolving Dependencies
--> Running transaction check
---> Package php-gd.x86_64 0:5.5.38-7.el6.remi will be installed
--> Processing Dependency: gd-last(x86-64) >= 2.1.1 for package: php-gd-5.5.38-7.el6.remi.x86_64
--> Running transaction check
---> Package gd-last.x86_64 0:2.2.4-1.el6.remi will be installed
--> Processing Dependency: for package: gd-last-2.2.4-1.el6.remi.x86_64
--> Running transaction check
---> Package libwebp.x86_64 0:0.4.3-3.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

 Package           Arch             Version                     Repository            Size
 php-gd            x86_64           5.5.38-7.el6.remi           remi-php55            78 k
Installing for dependencies:
 gd-last           x86_64           2.2.4-1.el6.remi            remi-safe            126 k
 libwebp           x86_64           0.4.3-3.el6                 epel                 210 k

Transaction Summary
Install       3 Package(s)

Total size: 415 k
Installed size: 1.3 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test

Transaction Check Error:
  file /usr/lib64/ from install of gd-last-2.2.4-1.el6.remi.x86_64 conflicts with file from package gd-2.1.0-1.el6.x86_64

Error Summary

A list of all the repositories you can see below the line "Loading mirror speeds from cached hostfile"

It the same mistake I get when trying to install: yum install php-tcpdf. As I understood this is a problem in gd-last. But I don't understand how to solve this problem.

Any idea on what can I do to install Php-Gd and solve this?

  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • doulao7572 2017-02-28 20:04

    You have a dependence error try deleting it if u can:

    yum remove gd-2.1.0-1.el6.x86_64

    and then try to install it again.

    打赏 评论

相关推荐 更多相似问题