douchiwan1503
2014-08-04 15:21
浏览 152
已采纳

如何在CentOs中安装php-xml

I am Trying to install php-xml on CentOs 6.5

I type the command yum install php-xml

and I am getting this Error :

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.mirror.nac.net
 * epel: mirrors.einstein.yu.edu
 * extras: mirrors.maine.edu
 * rpmforge: repoforge.mirror.constant.com
 * updates: centos.mirror.constant.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-xml.x86_64 0:5.3.3-27.el6_5 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-27.el6_5 for package: php-xml-5.3.3-27.el6_5.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.24)(64bit) for package: php-xml-5.3.3-27.el6_5.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.22)(64bit) for package: php-xml-5.3.3-27.el6_5.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.18)(64bit) for package: php-xml-5.3.3-27.el6_5.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.13)(64bit) for package: php-xml-5.3.3-27.el6_5.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.11)(64bit) for package: php-xml-5.3.3-27.el6_5.x86_64
--> Processing Dependency: libxslt.so.1()(64bit) for package: php-xml-5.3.3-27.el6_5.x86_64
--> Processing Dependency: libexslt.so.0()(64bit) for package: php-xml-5.3.3-27.el6_5.x86_64
--> Running transaction check
---> Package libxslt.x86_64 0:1.1.26-2.el6_3.1 will be installed
---> Package php-xml.x86_64 0:5.3.3-27.el6_5 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-27.el6_5 for package: php-xml-5.3.3-27.el6_5.x86_64
--> Finished Dependency Resolution
Error: Package: php-xml-5.3.3-27.el6_5.x86_64 (updates)
           Requires: php-common(x86-64) = 5.3.3-27.el6_5
           Installed: php-common-5.4.31-1.el6.remi.x86_64 (@remi)
               php-common(x86-64) = 5.4.31-1.el6.remi
           Available: php-common-5.3.3-26.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-26.el6
           Available: php-common-5.3.3-27.el6_5.x86_64 (updates)
               php-common(x86-64) = 5.3.3-27.el6_5
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I am new to Cent Os and Linux so please Help me. I am Developer and not a System Admin so this is new for me.Please Help

Thanks in Advance

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • douna2917 2016-02-20 08:35
    已采纳

    The followings worked for me , I run this command

    yum --enablerepo remi install php-xml
    

    And restarted the Apache with this command

    sudo service httpd restart
    
    点赞 打赏 评论
  • doutangu4671 2014-08-04 15:27

    As far as I can see you need an older edition of php-common. So I will advice you to downgrade php-common:

    yum downgrade php php-common php-cli
    
    点赞 打赏 评论

相关推荐 更多相似问题