duanjianxiu9400
duanjianxiu9400
2013-09-06 16:05
浏览 38
已采纳

Zend_Http_Client SSL异常

I have Zend Framework 1.12 project, and PHP 5.5.3 and nginx 1.2.7 + php-fpm installed on Ubuntu 10.04 server.

I receieved the following exception

Message: Unable to Connect to ssl://pftradingnet.com:443. Error #179898264: Unable to find the socket transport "ssl" - did you forget to enable it when you configured PHP?

from Zend_Http_Client_Adapter_Socket->connect function.

My configure command is

'./configure' '--enable-opcache' '--prefix=/opt/php' '--with-apxs2=/usr/bin/apxs2' '--with-mysql=mysqlnd' '--with-mysqli=mysqlnd' '--with-pgsql=/usr' '--with-tidy=/usr' '--with-curl=/usr/bin' '--with-openssl-dir=/usr' '--with-zlib-dir=/usr' '--with-xpm-dir=/usr' '--with-pdo-pgsql=/usr' '--with-pdo-mysql=mysqlnd' '--with-xsl=/usr' '--with-ldap' '--with-xmlrpc' '--with-iconv-dir=/usr' '--with-snmp=/usr' '--enable-exif' '--enable-calendar' '--with-bz2=/usr' '--with-mcrypt=/usr' '--with-gd' '--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--with-freetype-dir=/usr' '--enable-mbstring' '--enable-zip' '--with-pear' '--with-libdir=lib' '--with-config-file-path=/opt' '--enable-fpm' '--with-fpm-user=fpm' '--with-fpm-group=fpm' '--enable-debug'

It worked fine previously on php5.3+Apache2, what can be the cause of error?

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • dongxiangchan0743
    dongxiangchan0743 2013-09-06 17:24
    已采纳

    My mistake was that I light-mindedly copy-pasted cofigure command script from here.

    I have recompiled PHP with --with-openssl instead of --with-openssl-dir=/usr and it works well now.

    点赞 评论

相关推荐