douguachi0056
2016-07-15 13:10
浏览 47
已采纳

Laravel会话不存储

I just deployed my code from my local env to my production env with Forge. But now when I submit my login form I get an error: TokenMismatchException in VerifyCsrfToken.php.

When I turn of the CSRF protection. And fill in fake data I do get redirected back but the page doesn't give me any errors. Which should like on my local env. When I do Session::set('test', true) and Session::get('test') (on the same page) I do get a true.

I've done some tests, conclusion: my sessions won't work.

I tried many solutions on many forums, nothing worked. Here is my session config file.

图片转代码服务由CSDN问答提供 功能建议

我刚刚使用Forge将我的代码从我的本地环境部署到我的生产环境。 但是现在当我提交登录表单时,我收到一个错误:VerifyCsrfToken.php中的TokenMismatchException。

当我关闭CSRF保护时。 并填写假数据我会重定向回来,但页面不会给我任何错误。 哪个应该在我当地的环境中。 当我做Session :: set('test',true)和Session :: get('test')(在同一页面上)时,我得到一个真实的。

我是 做了一些测试,结论:我的会话不起作用。

我在很多论坛上尝试了很多解决方案,没有任何效果。 这是我的会话配置文件

  • 写回答
  • 好问题 提建议
  • 追加酬金
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • dpfl37651 2016-07-15 13:46
    已采纳

    In .env the I removed the http:// and the last / from the SESSION_DOMAIN. This did the trick for me.

    So i.e. 127.0.0.1 instead of http://127.0.0.1/

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题