dongyi7901 2016-05-06 21:48
浏览 53
已采纳

apache无法运行任何php [关闭]

I've installed an apache server on my raspberry pi and everything seems to be running fine unless I try to serve php.

/var/www/html/index.html serves fine
/var/www/html/foo/index/index.html serves fines

But if I add index.php, let's say :

<?php echo "hello world"; ?>

I get 403 -Forbbiden by accessing /var/www/html but I can still access /var/www/html/foo/index.html (DirectoryIndex set to .php .html .htm).

And if I run $php index.php : hello world

So, it does can serves .html, it can run .php but it cannot serve .php.

How can I fix this ? I found many solutions but none worked for me.

Note : I access the sites from the LAN. Server OS (uname -a) : Linux raspbian-AH 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv7l GNU/Linux

As stated in the comments, we could easily deduce module is not loaded but I here it is :

pi@raspbian-AH:/etc/apache2/mods-available $ cat php5.conf 
<FilesMatch ".+\.ph(p[345]?|t|tml)$">
    SetHandler application/x-httpd-php
</FilesMatch>
<FilesMatch ".+\.phps$">
    SetHandler application/x-httpd-php-source
    # Deny access to raw php sources by default
    # To re-enable it's recommended to enable access to the files
    # only in specific virtual host or directory
    Require all denied
</FilesMatch>
# Deny access to files without filename (e.g. '.php')
<FilesMatch "^\.ph(p[345]?|t|tml|ps)$">
    Require all denied
</FilesMatch>

# Running PHP scripts in user directories is disabled by default
# 
# To re-enable PHP in user directories comment the following lines
# (from <IfModule ...> to </IfModule>.) Do NOT set it to On as it
# prevents .htaccess files from disabling it.
<IfModule mod_userdir.c>
    <Directory /home/*/public_html>
        php_admin_flag engine Off
    </Directory>
</IfModule>

and the php5.load:

pi@raspbian-AH:/etc/apache2/mods-available $ cat php5.load
LoadModule php5_module /usr/lib/apache2/modules/libphp5.so
  • 写回答

1条回答 默认 最新

  • douqian1835 2016-05-07 00:24
    关注

    Thanks to dan08, I found out my set up was messed up is some way. So rather than to pinpoint the problem I purged everything and install it anew. There wasn't anything to save anyway.

    So the solution was :

    sudo apt-get purge apache2 php5 libapache2-mod-php5
    sudo apt-get install apache2 php5 libapache2-mod-php5
    
    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

悬赏问题

  • ¥15 有内推吗,云计算linux运维方向
  • ¥30 sort cuteSV.vcf by bcftools用IGV可视化出现报错
  • ¥100 SOS!对STK中导出的天体图像进行质心提取有没有人做过啊
  • ¥15 python 欧式距离
  • ¥15 运行qteasy报错
  • ¥15 遗传算法解决有工序顺序约束的大规模FJSP问题
  • ¥15 企业消防水炮塔设计方案
  • ¥20 WORKBENCH网格划分
  • ¥60 急招师兄远程解决下载NPCAP的BUG!
  • ¥15 关于#51单片机#的问题:51单片机LM1602的数据只能显示一个字符,在使用矩形键盘送数据的时候不能显示出来而是在显示初始位置上,达不到密码锁的效果