douzhun4124 2016-03-23 02:25
浏览 118
已采纳

打开.php显示空白页面

There is my nginx error log:

2016/03/23 10:19:33 [error] 21614#0: *2 FastCGI sent in stderr: "PHP message: PHP Warning:  require_once(/home/dwj/phpblog/inc/../vendor/autoload.php): failed to open stream: No such file or directory in /home/dwj/phpblog/inc/blade.php on line 2
PHP message: PHP Fatal error:  require_once(): Failed opening required '/home/dwj/phpblog/inc/../vendor/autoload.php' (include_path='.:/usr/share/php:/usr/share/pear') in /home/dwj/phpblog/inc/blade.php on line 2" while reading response header from upstream, client: 106.187.90.170, server: dwjdwj.cn, request: "GET /index.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "dwjdwj.cn"

And my code is in https://github.com/openxyz/phpblog;

I think the code is well.There must be some wrong in my configure.

  • 写回答

1条回答 默认 最新

  • dongzu0742 2016-03-23 03:00
    关注

    It appears to me that your project uses composer. Which means that you need to install and run composer to pull required files down into your vendor folder before the app will run. As a side effect, that also generates the autoload.php.

    Have you run composer locally to get/generate the files you need?

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

悬赏问题

  • ¥15 这个有点复杂 有没有人看看
  • ¥15 用python如何确定子元素在父元素中的位置
  • ¥15 obj文件滤除异常高程
  • ¥15 用mathematicas或者matlab计算三重积分
  • ¥15 Loop unrolling的runtime计算
  • ¥100 NVMe-oF的Target端,开启attr_offload后,测试失败。
  • ¥100 有偿照片马赛克去掉,保留原始数据
  • ¥15 c# winform http报错,如何解决?
  • ¥15 统计软件及应用-r软件
  • ¥15 爬虫返回的js数据结构如何处理