dpstir0081
2017-10-27 13:48
浏览 83
已采纳

Laravel 5.5中的AdLdap2问题

I receiving an error when i am trying to use LDAP with Laravel 5.5

"Use of undefined constant LDAP_OPT_PROTOCOL_VERSION - assumed 'LDAP_OPT_PROTOCOL_VERSION'"

However, i have enabled the PHP extension of LDAP

$ php --ini |grep ldap

/etc/php.d/ldap.ini,

and

$ cat /etc/php.d/ldap.ini
; Enable ldap extension module
extension=ldap.so

and php information

$ php --info |grep ldap
/etc/php.d/ldap.ini,
Protocols => dict, file, ftp, ftps, gopher, http, https, imap, imaps, ldap, ldaps, pop3, pop3s, rtsp, scp, sftp, smtp, smtps, telnet, tftp
ldap
ldap.max_links => Unlimited => Unlimited

I am using

$ php -v
PHP 7.1.10 (cli) (built: Sep 30 2017 10:30:04) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.1.10, Copyright (c) 1999-2017, by Zend Technologies
  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • dongpaocuan7498 2017-11-08 18:20
    已采纳

    The issue is solved.

    I installed the LDAP libraries and recompiled the PHP with LDAP from scratch.

    ./configure --other-extensions --with-ldap --enable-ldap

    点赞 打赏 评论
  • douqiangbei50208 2018-04-25 15:15

    For ldap on a homestead box (laravel vagrant machine) or other Ubuntu with php-fpm and nginx...

    apt-get install php5.6-ldap
    apt-get install php7.0-ldap
    apt-get install php7.1-ldap
    apt-get install php7.2-ldap
    

    this installs and sets up everything you need.

    Make sure you shutdown -h now and restart your box for php-fpm and nginx to see the updates.

    点赞 打赏 评论

相关推荐 更多相似问题