PHP - 无法在php-fpm上更改memory_limit

It might seem a stupid question, but I'm already trying since one hour to figure it out without success.

As stated in title, I'm actually unable to change memory_limit directive in PHP 7.1.15 but only for php-fpm. In fact if I execute php -i | grep memory_limit in terminal I can see the correct value memory_limit => -1 => -1.

What I tried so far:

  • Setting memory_limit in php.ini
  • Using ini_set('memory_limit', -1); directly in PHP script

I also tried to disable all loaded extensions cause I thought maybe one of them is overwriting that setting, but didn't work.

Also consider that edited php.ini file is the correct one since I was able to change max_execution_time without any problem.

So how this code

ini_set('memory_limit', -1);
echo ini_get('memory_limit');
exit;

can return 128M as output?

查看全部
dongshao8125
dongshao8125
2018/05/30 10:09
  • php
  • 点赞
  • 收藏
  • 回答
    私信
满意答案
查看全部

2个回复