dqde43215
2016-05-16 19:11
浏览 98
已采纳

为Elasticsearch手动安装PHP API库

I downloaded this php api package from github

https://github.com/elastic/elasticsearch-php/tree/2.0

but I am having a hard time installing it. I unfortunately dont have permission to use the composer/auto-loader from where I work so I have to do it manually. Is there a way of doing this?

Thanks for your help.

图片转代码服务由CSDN问答提供 功能建议

我从github下载了这个php api包

https://github.com/elastic/elasticsearch-php/tree/2.0 \ n

但我很难安装它。 遗憾的是我没有权限在我工作的地方使用composer / auto-loader,所以我必须手动完成。 有没有办法做到这一点?

感谢您的帮助。

  • 写回答
  • 好问题 提建议
  • 追加酬金
  • 关注问题
  • 邀请回答

1条回答 默认 最新

  • dongmu1989 2016-05-16 19:31
    最佳回答

    The classes look pretty well formatted PSR-4 so you should be able to just download the directorysrc/Elasticsearch, and make a simple autoloader of your own and register it (assuming you don't already have one setup to serve classes that adhere to PSR-4).

    Here's some options: http://www.php-fig.org/psr/psr-4/examples/

    All the other directories seem to to be extraneous to running of the classes--for unit testing and benchmarking.

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题