2 u011387543 u011387543 于 2016.03.18 11:06 提问

eclipse环境下的opencv使用问题

我的eclipse版本是4.5.2
opencv是3.1
我是按照这个博客中的指导进行的处理
http://blog.sina.com.cn/s/blog_7b4a5b550101ifi7.html
但是我在运行测试程序的时候,总是出现下面的错误
Exception in thread "main" java.lang.UnsatisfiedLinkError: C:\Users\John\AppData\Local\Temp\javacpp62144455200083\jniopencv_core.dll: Can't find dependent libraries
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1938)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1821)
at java.lang.Runtime.load0(Runtime.java:809)
at java.lang.System.load(System.java:1086)
at com.googlecode.javacpp.Loader.loadLibrary(Loader.java:418)
at com.googlecode.javacpp.Loader.load(Loader.java:368)
at com.googlecode.javacpp.Loader.load(Loader.java:315)
at com.googlecode.javacv.cpp.opencv_core.(opencv_core.java:131)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:348)
at com.googlecode.javacpp.Loader.load(Loader.java:334)
at com.googlecode.javacv.cpp.opencv_imgproc.(opencv_imgproc.java:96)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:348)
at com.googlecode.javacpp.Loader.load(Loader.java:334)
at com.googlecode.javacv.cpp.opencv_highgui.(opencv_highgui.java:91)
at test2.Opencv1.smooth(Opencv1.java:11)
at test2.Opencv1.main(Opencv1.java:25)
求指导,急需,跪求!!!
p.s.当我在执行上面的那个博客中的下面那个官网测试代码时是没有问题的,但执行第一段测试程序时就出问题了

1个回答

wangyaninglm
wangyaninglm   Ds   Rxr 2016.03.18 12:23

LIB没有配置正确嘛,不行把LIB拷贝在工程目录下

u011387543
u011387543 不好意思,我好像没有理解,能不能说得再详细一点
接近 2 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!