douluanzhao6689
2012-06-12 14:06
浏览 92
已采纳

在Fedora上安装MediaWiki的问题

I'm trying to install MediaWiki on fedora 17

I've followed the following instructions install guide.

I reached a stage where i'm supposed to configure MediaWiki on localhost/wiki page.

instead I get a page that specifies the files under that directory.

It seems that something is wrong with my php setttings/installation.

If you need me to post additional information please let me know.

Any ideas on how to resolve this issue?


Edit: The following files are visible

[TXT]   api.php 12-Apr-2011 04:07   4.5K     
[DIR]   config/ 12-Jun-2012 12:58   -    
[DIR]   images/ 12-Jun-2012 12:58   -    
[TXT]   index.php   01-Jan-2010 23:09   4.2K     
[TXT]   opensearch_desc.php 21-Mar-2009 18:48   3.0K     
[DIR]   skins/

Thanks now the php pages' source is displayed in it the following message appear

* This is the main web entry point for MediaWiki.
 *
 * If you are reading this in your web browser, your server is probably
 * not configured correctly to run PHP applications!

any ideas how to configure that?

Thanks in advance

图片转代码服务由CSDN问答提供 功能建议

我正在尝试在fedora 17上安装MediaWiki

我已经 按照以下说明安装指南

我到了一个我应该在localhost / wiki页面上配置MediaWiki的阶段。

而是我得到一个指定该目录下的文件的页面。 \ n

我的php设置/安装似乎有问题。

如果您需要我发布更多信息,请告诉我。 < p>有关如何解决此问题的任何想法?


编辑: 以下文件可见

  [TXT] api.php 12-Apr-2011 04:07 4.5K 
 [DIR] config / 12-Jun-2012 12:58  -  
 [DIR] images / 12-Jun-2012 12:58  -  \  n [TXT] index.php 01-Jan-2010 23:09 4.2K 
 [TXT] opensearch_desc.php 21-Mar-2009 18:48 3.0K 
 [DIR]皮肤/ 
   
 
 

现在谢谢php 页面的源显示在其中,显示以下消息

  *这是MediaWiki的主要Web入口点。
 * 
 *如果您在网络中阅读此内容 浏览器,你的服务器可能没有正确配置来运行PHP应用程序!
   
 
 

如何配置它的任何想法? < p>提前致谢

  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • dongyue3795 2012-06-12 14:27
    已采纳

    You can try adding a

    .htaccess
    

    file to the directory you see, with:

    Options -Indexes
    

    in it, to disable directory listing.

    EDIT:

    Take a look at the httpd.conf file in your local Apache folder. You need to modify the DirectoryIndex value to display index.php also:

    DirectoryIndex index.php index.html index.htm 
    

    EDIT 2:

    For running install script, you need to make the 'config' directory writable by the webserver/apache user.

    chmod a+w config 
    

    restart apache with:

    service httpd restart
    

    then reload the page.

    HTH

    已采纳该答案
    打赏 评论

相关推荐 更多相似问题