2016-01-31 03:41



So I did sudo apt-get install php5-mongo and when I do composer require "mongodb/mongodb=~1.0.0" I get this:

  Problem 1
    - Installation request for mongodb/mongodb ~1.0.0 -> satisfiable by mongodb/mongodb[1.0.0].
    - mongodb/mongodb 1.0.0 requires ext-mongodb ^1.1.0 -> the requested PHP extension mongodb is missing from your system.

When I do dpkg -s php5-mongo I get this:

Package: php5-mongo
Status: install ok installed
Priority: optional
Section: php
Installed-Size: 326
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Source: php-mongo
Version: 1.4.5-1build1
Depends: libc6 (>= 2.15), phpapi-20121212
 /etc/php5/mods-available/mongo.ini f2a4848fe0856c5bbaf2afc4aee7a1b9
Description: MongoDB database driver
 This package provides an interface for communicating with the MongoDB database
 in PHP.
Original-Maintainer: Laszlo Boszormenyi (GCS) <gcs@debian.org>
Homepage: http://www.mongodb.org/display/DOCS/PHP+Language+Center

So is the problem my ext-mongodb install is too new? Based on the output of dpkg I'd guess I'm running ext-mongodb 1.4.5 instead of the 1.1.0 required by https://github.com/mongodb/mongo-php-library

edit: echo phpversion('mongo') gets me 1.4.5 as well.

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答


  • dongluzhi5208 dongluzhi5208 5年前

    I just uninstalled the apt-get installed version of php5-mongo and installed it with pecl per http://mongodb.github.io/mongo-php-driver/#installation.

    That was for sure more annoying since I had to manually install all of the dependencies. None-the-less, if apt-get isn't installing anything usable in Ubuntu 14.04 it seems like they ought to fix it..

    点赞 评论 复制链接分享
  • doutang1884 doutang1884 5年前

    I openend a request at Ubuntu Launchpad to get the new php-mongodb driver also for trusty-universe (Ubuntu14). Its available in xenial but built against PHP7 API. https://bugs.launchpad.net/ubuntu/+source/php-mongodb/+bug/1579815

    点赞 评论 复制链接分享