douwengzao5790 2019-06-04 09:38
浏览 127
已采纳

Laravel流明照明/控制台不会更新

I am trying to install Laravel Dusk on my lumen project but I keep getting the following error:

Problem 1
    - Installation request for illuminate/queue (installed at v5.4.36) -> satisfiable by illuminate/queue[v5.4.36].
    - Can only install one of: illuminate/console[5.8.x-dev, 5.4.x-dev].
    - Can only install one of: illuminate/console[5.9.x-dev, 5.4.x-dev].
    - Can only install one of: illuminate/console[v5.8.0, 5.4.x-dev].
    - Can only install one of: illuminate/console[v5.8.11, 5.4.x-dev].
    - Can only install one of: illuminate/console[v5.8.12, 5.4.x-dev].
    - Can only install one of: illuminate/console[v5.8.14, 5.4.x-dev].
    - Can only install one of: illuminate/console[v5.8.15, 5.4.x-dev].
    - Can only install one of: illuminate/console[v5.8.17, 5.4.x-dev].
    - Can only install one of: illuminate/console[v5.8.18, 5.4.x-dev].
    - Can only install one of: illuminate/console[v5.8.19, 5.4.x-dev].
    - Can only install one of: illuminate/console[v5.8.2, 5.4.x-dev].
    - Can only install one of: illuminate/console[v5.8.3, 5.4.x-dev].
    - Can only install one of: illuminate/console[v5.8.4, 5.4.x-dev].
    - Can only install one of: illuminate/console[v5.8.8, 5.4.x-dev].
    - Can only install one of: illuminate/console[v5.8.9, 5.4.x-dev].
    - Conclusion: install illuminate/console 5.4.x-dev
    - Installation request for illuminate/console ^5.8 -> satisfiable by illuminate/console[5.8.x-dev, 5.9.x-dev, v5.8.0, v5.8.11, v5.8.12, v5.8.14, v5.8.15, v5.8.17, v5.8.18, v5.8.19, v5.8.2, v5.8.3, v5.8.4, v5.8.8, v5.8.9].

I have tried:

composer require illuminate/console
composer dump-autoload
composer update
composer install

With no luck. In my composer.json there is no illuminate/console so I can't update it in there.

"require": {
    "php": ">=5.6.4",
    "laravel/lumen-framework": "5.4.*",
    "vlucas/phpdotenv": "~2.2",
    "krisanalfa/lumen-dingo-adapter": "^0.0.3",
    "sorskod/larasponse": "*",
    "league/flysystem": " ~1.0",
    "league/flysystem-aws-s3-v3": "^1.0",
    "maatwebsite/excel": "^2.1",
    "barryvdh/laravel-dompdf": "^0.8.0",
    "illuminate/mail": "5.4"
},
"require-dev": {
    "fzaninotto/faker": "~1.4",
    "phpunit/phpunit": "~5.0",
    "mockery/mockery": "~0.9",
    "flipbox/lumen-generator": "^5.4"
},

However when I look in the composer.lock that gets created I can see it here:

"name": "illuminate/console",
        "version": "v5.4.36",
        "source": {
            "type": "git",
            "url": "https://github.com/illuminate/console.git",
            "reference": "4f0413ffd240d2004c3e9e4cd8f63df249939a15"
        },

Any way I can get this pack age to update? I believe dusk requires 5.7.* at minimum.

  • 写回答

1条回答 默认 最新

  • dstobkpm908182 2019-06-04 11:38
    关注

    I was not able to replicate your issue with the illuminate/console package, but I did manage to install the specified packages in a test project on my local machine.

    Make sure you have the following in your composer.json file:

    {
        "minimum-stability": "dev",
        "prefer-stable": true
    }
    

    Delete your vendor folder:

    cd ~/path/to/project
    rm -rf vendor/
    

    Then run composer update to ignore and generate a new lock file.

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

悬赏问题

  • ¥15 tensorrt 推理 yolov8框出现错误
  • ¥15 用hc 05,做蓝牙控制小车 小车只能说初始遥控方向影响,后续不能更改
  • ¥15 51单片机怎么把每次输入键值保存到数组作为我的确认键的判断条件呢
  • ¥45 easy photo不能使用,求帮助
  • ¥15 c语言字符串单词入门问题报错
  • ¥30 我现在是双非人工智能专业不知道要不要转到软件工程专业
  • ¥15 请问12脉波整流机组的外特性曲线具体是如何推导
  • ¥15 abaqus里的python算法
  • ¥100 如何在思科模拟器中进入CEF模式
  • ¥15 Simulink 仿真如何使用MATLAB function模块获取到仿真过程中某一仿真时刻输入到模块的函数的值?