doutui839638
doutui839638
2014-02-18 17:28
浏览 166
已采纳

SOAP-ERROR:解析WSDL:无法加载 - 但适用于WAMP

This works fine on my WAMP server, but doesn't work on the linux master server!?

try{
    $client = new SoapClient('http://ec.europa.eu/taxation_customs/vies/checkVatService.wsdl', ['trace' => true]);
    $result = $client->checkVat([
        'countryCode' => 'DK',
        'vatNumber' => '47458714'
    ]);
    print_r($result);
}
catch(Exception $e){
    echo $e->getMessage();
}

What am I missing here?! :(

SOAP is enabled

Error

SOAP-ERROR: Parsing WSDL: Couldn't load from 'http://ec.europa.eu/taxation_customs/vies/checkVatService.wsdl' : failed to load external entity "http://ec.europa.eu/taxation_customs/vies/checkVatService.wsdl"/taxation_customs/vies/checkVatService.wsdl"

Call the URL from PHP

Calling the URL from PHP returns error

$wsdl = file_get_contents('http://ec.europa.eu/taxation_customs/vies/checkVatService.wsdl');
echo $wsdl;

Error

Warning:  file_get_contents(http://ec.europa.eu/taxation_customs/vies/checkVatService.wsdl): failed to open stream: HTTP request failed! HTTP/1.0 503 Service Unavailable

Call the URL from command line

Calling the URL from the linux command line HTTP 200 is returned with a XML response

curl http://ec.europa.eu/taxation_customs/vies/checkVatService.wsdl
  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

6条回答 默认 最新

  • dongzai5181
    dongzai5181 2014-02-23 19:02
    已采纳

    For some versions of php, the SoapClient does not send http user agent information. What php versions do you have on the server vs your local WAMP?

    Try to set the user agent explicitly, using a context stream as follows:

    try {
        $opts = array(
            'http' => array(
                'user_agent' => 'PHPSoapClient'
            )
        );
        $context = stream_context_create($opts);
    
        $wsdlUrl = 'http://ec.europa.eu/taxation_customs/vies/checkVatService.wsdl';
        $soapClientOptions = array(
            'stream_context' => $context,
            'cache_wsdl' => WSDL_CACHE_NONE
        );
    
        $client = new SoapClient($wsdlUrl, $soapClientOptions);
    
        $checkVatParameters = array(
            'countryCode' => 'DK',
            'vatNumber' => '47458714'
        );
    
        $result = $client->checkVat($checkVatParameters);
        print_r($result);
    }
    catch(Exception $e) {
        echo $e->getMessage();
    }
    

    Edit

    It actually seems to be some issues with the web service you are using. The combination of HTTP over IPv6, and missing HTTP User Agent string, seems to give the web service problems.

    To verify this, try the following on your linux host:

    curl  -A ''  -6 http://ec.europa.eu/taxation_customs/vies/checkVatService.wsdl
    

    this IPv6 request fails.

    curl  -A 'cURL User Agent'  -6 http://ec.europa.eu/taxation_customs/vies/checkVatService.wsdl
    

    this IPv6 request succeeds.

    curl  -A ''  -4 http://ec.europa.eu/taxation_customs/vies/checkVatService.wsdl
    curl  -A 'cURL User Agent'  -4 http://ec.europa.eu/taxation_customs/vies/checkVatService.wsdl
    

    both these IPv4 request succeeds.

    Interesting case :) I guess your linux host resolves ec.europa.eu to its IPv6 address, and that your version of SoapClient did not add a user agent string by default.

    点赞 评论
  • doujiao7483
    doujiao7483 2014-02-20 21:47

    Try changing

    $client = new SoapClient('http://ec.europa.eu/taxation_customs/vies/checkVatService.wsdl', ['trace' => true]);
    

    to

    $client = new SoapClient('http://ec.europa.eu/taxation_customs/vies/checkVatService.wsdl', ['trace' => true, 'cache_wsdl' => WSDL_CACHE_MEMORY]);
    

    Also (whether that works or not), check to make sure that /tmp is writeable by your web server and that it isn't full.

    点赞 评论
  • dongtiao6362
    dongtiao6362 2014-02-24 15:20

    503 means the functions are working and you're getting a response from the remote server denying you. If you ever tried to cURL google results the same thing happens, because they can detect the user-agent used by file_get_contents and cURL and as a result block those user agents. It's also possible that the server you're accessing from also has it's IP address blackballed for such practices.

    Mainly three common reasons why the commands wouldn't work just like the browser in a remote situation.

    1) The default USER-AGENT has been blocked. 2) Your server's IP block has been blocked. 3) Remote host has a proxy detection.

    点赞 评论
  • duanliang5051
    duanliang5051 2017-01-17 16:13

    This issue can be caused by the libxml entity loader having been disabled.

    Try running libxml_disable_entity_loader(false); before instantiating SoapClient.

    点赞 评论
  • douju6651
    douju6651 2017-12-19 17:36

    It may be helpful for someone, although there is no precise answer to this question.

    My soap url has a non-standard port(9087 for example), and firewall blocked that request and I took each time this error:

    ERROR - 2017-12-19 20:44:11 --> Fatal Error - SOAP-ERROR: Parsing WSDL: Couldn't load from 'http://soalurl.test:9087/orawsv?wsdl' : failed to load external entity "http://soalurl.test:9087/orawsv?wsdl"

    I allowed port in firewall and solved the error!

    点赞 评论
  • dourong2015
    dourong2015 2018-01-27 20:02

    Try this. I hope it helps

    $options = array(
        'cache_wsdl' => 0,
        'trace' => 1,
        'stream_context' => stream_context_create(array(
              'ssl' => array(
                   'verify_peer' => false,
                    'verify_peer_name' => false,
                    'allow_self_signed' => true
              )
        ))
    
    $client = new SoapClient(url, $options);
    
    点赞 评论

相关推荐