不停下脚步的乌龟
2020-01-18 12:45
采纳率: 76.9%
浏览 2.5k
已采纳

关于Mac下python pip版本问题以及pycharm安装python第三方库失败问题

我的电脑是mac 10.15版本
目前有两个python:

  1. 系统自带Python 2.7.16

  2. 自己安装python Python 3.7.3

在终端查询pip版本,结果是2.7的那个:

pip 19.3.1 from /Library/Python/2.7/site-packages/pip (python 2.7)

查询pip3,结果显示错误:

xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

好像问题就是在这里,我在终端用 pip install 安装python第三方库的时候总会有问题,提示pip版本过低,我想更新pip又会失败;或者根本无法安装。

然后我就选择从pycharm上搜索第三方库并安装,奇怪的是有的库可以成功安装,有的库安装失败并提示说pip版本过低,让我尝试从终端安装,可是从终端安装的话又会遇到之前的问题。

请问这个该怎么解决?

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

  • MozziFC 2020-01-20 04:56
    已采纳

    试试看这个指令
    python3 -m pip install 第三方库名

    Mac机子会自带python2,导致安装库时无法识别python3。用指令强制安装一下看看

    已采纳该答案
    评论
    解决 3 无用 2
    打赏 举报
  • zmm1912 2021-09-30 18:09

    太好解决了,在pip后面加个3就都解决了

    评论
    解决 1 无用
    打赏 举报

相关推荐 更多相似问题