python linux centos7 安装tesseract 出现报错 Running autoconf Missing pkg-config. Check the build requirements.

autoconf 已安装,是2.69版
tesseract 的依懒也安装了,leptonica-1.78.0

tesseract 是tesseract-4.1.0 和tesseract5的都 试过,
执行 ./autogen.sh命令:报错
以下是错误提示:

[xxx@xxx tesseract]# ./autogen.sh
Running aclocal
Running /usr/bin/libtoolize
libtoolize: putting auxiliary files in AC_CONFIG_AUX_DIR, `config'.
libtoolize: copying file `config/ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIR, `m4'.
libtoolize: copying file `m4/libtool.m4'
libtoolize: copying file `m4/ltoptions.m4'
libtoolize: copying file `m4/ltsugar.m4'
libtoolize: copying file `m4/ltversion.m4'
libtoolize: copying file `m4/lt~obsolete.m4'
Running autoconf
Missing pkg-config. Check the build requirements.

  Something went wrong, bailing out!


系统上装有宝塔环境
tesseract装这的目和是用python调用,结果一直报错

1个回答

这个是运行autoconf 时缺少了pkg-config这个插件,还有你下的autoconf版本太低,换一个autoconf 2.65版本,打开这个网站https://www.cnblogs.com/congcongdi/p/11304803.html,这篇文章作者跟你有很相似的报错,你可以去参考一下。

qq_32692441
一陀牛屎 我那个 autoconf是2.69版本的,不是2.65
大约 2 个月之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问