maven update project 报错

Could not calculate build plan: Plugin org.apache.maven.plugins:maven-resources-plugin:2.5 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.5
Plugin org.apache.maven.plugins:maven-resources-plugin:2.5 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-resources-plugin:jar:2.5图片说明

3个回答

求大神啊,我调一天了,在挑不出来,估计要滚犊子了。

删除项目下的.settings和.project(如果有的话)文件夹,然后重新导入或者更新项目。

大哥,少jar包好不好?写的那么明显,看看你的仓库中有对应的jar没

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
eclipse创建maven工程时报错
使用的是官方的Eclipse中自带的m2e插件,创建maven项目时就弹出个错误 ![图片说明](https://img-ask.csdn.net/upload/201507/15/1436949464_186734.png) 在pom.xml文件那会显示个红X,提示如下: Multiple annotations found at this line: - Plugin execution not covered by lifecycle configuration: org.apache.maven.plugins:maven-compiler-plugin:3.1:testCompile (execution: default-testCompile, phase: test- compile) - Execution default-resources of goal org.apache.maven.plugins:maven-resources-plugin:2.6:resources failed: Plugin org.apache.maven.plugins:maven-resources-plugin:2.6 or one of its dependencies could not be resolved: The following artifacts could not be resolved: org.apache.maven:maven-plugin-api:jar:2.0.6, org.apache.maven:maven- project:jar:2.0.6, org.apache.maven:maven-profile:jar:2.0.6, org.apache.maven:maven-artifact-manager:jar:2.0.6, org.apache.maven:maven-plugin-registry:jar:2.0.6, org.apache.maven:maven-core:jar:2.0.6, org.apache.maven:maven-plugin-parameter-documenter:jar:2.0.6, org.apache.maven:maven-repository-metadata:jar:2.0.6, org.apache.maven:maven-error-diagnostics:jar:2.0.6, org.apache.maven:maven-plugin-descriptor:jar:2.0.6, org.apache.maven:maven-artifact:jar:2.0.6, org.apache.maven:maven- settings:jar:2.0.6, org.apache.maven:maven-model:jar:2.0.6, org.apache.maven:maven-monitor:jar:2.0.6, org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1: Failure to transfer org.apache.maven:maven-plugin-api:jar:2.0.6 from https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer artifact org.apache.maven:maven-plugin-api:jar:2.0.6 from/to central (https://repo.maven.apache.org/maven2): The operation was cancelled. (org.apache.maven.plugins:maven-resources-plugin:2.6:resources:default-resources:process-resources) org.apache.maven.plugin.PluginExecutionException: Execution default-resources of goal org.apache.maven.plugins:maven-resources-plugin:2.6:resources failed: Plugin org.apache.maven.plugins:maven-resources-plugin:2.6 or one of its dependencies could not be resolved: The following artifacts could not be resolved: org.apache.maven:maven- plugin-api:jar:2.0.6, org.apache.maven:maven-project:jar:2.0.6, org.apache.maven:maven-profile:jar:2.0.6, org.apache.maven:maven-artifact-manager:jar:2.0.6, org.apache.maven:maven-plugin-registry:jar:2.0.6, org.apache.maven:maven-core:jar:2.0.6, org.apache.maven:maven-plugin-parameter-documenter:jar:2.0.6, org.apache.maven:maven-repository-metadata:jar:2.0.6, org.apache.maven:maven-error-diagnostics:jar:2.0.6, org.apache.maven:maven-plugin-descriptor:jar:2.0.6, org.apache.maven:maven-artifact:jar:2.0.6, org.apache.maven:maven-settings:jar:2.0.6, org.apache.maven:maven-model:jar:2.0.6, org.apache.maven:maven-monitor:jar:2.0.6, org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-9-stable-1: Failure to transfer org.apache.maven:maven-plugin-api:jar:2.0.6 from https://repo.maven.apache.org/ maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer artifact org.apache.maven:maven-plugin-api:jar:2.0.6 from/to central (https://repo.maven.apache.org/maven2): The operation was cancelled. at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:106) at org.eclipse.m2e.core.internal.embedder.MavenImpl.execute(MavenImpl.java:331) at org.eclipse.m2e.core.internal.embedder.MavenImpl$11.call(MavenImpl.java:1362) at org.eclipse.m2e.core.internal.embedder.MavenImpl$11.call(MavenImpl.java:1) at org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.executeBare(MavenExecutionContext.java:176) at org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.execute(MavenExecutionContext.java:112) at org.eclipse.m2e.core.internal.embedder.MavenImpl.execute(MavenImpl.java:1360) at org.eclipse.m2e.core.project.configurator.MojoExecutionBuildParticipant.build(MojoExecutionBuildParticipant.java:52) at org.eclipse.m2e.core.internal.builder.MavenBuilderImpl.build(MavenBuilderImpl.java:137) at org.eclipse.m2e.core.internal.builder.MavenBuilder$1.method(MavenBuilder.java:172) at org.eclipse.m2e.core.internal.builder.MavenBuilder$1.method(MavenBuilder.java:1) at org.eclipse.m2e.core.internal.builder.MavenBuilder$BuildMethod$1$1.call(MavenBuilder.java: 115) at org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.executeBare(MavenExecutionContext.java:176) at org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.execute(MavenExecutionContext.java:112) at org.eclipse.m2e.core.internal.builder.MavenBuilder$BuildMethod $1.call(MavenBuilder.java:105) at org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.executeBare(MavenExecutionContext.java:176) at org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.execute(MavenExecutionContext.java:151) at org.eclipse.m2e.core.internal.embedder.MavenExecutionContext.execute(MavenExecutionContext.java:99) at org.eclipse.m2e.core.internal.builder.MavenBuilder $BuildMethod.execute(MavenBuilder.java:86) at org.eclipse.m2e.core.internal.builder.MavenBuilder.build(MavenBuilder.java:200) at org.eclipse.core.internal.events.BuildManager $2.run(BuildManager.java:734) at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42) at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:205) at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:245) at org.eclipse.core.internal.events.BuildManager$1.run(BuildManager.java:300) at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42) at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:303) at org.eclipse.core.internal.events.BuildManager.basicBuildLoop(BuildManager.java:359) at org.eclipse.core.internal.events.BuildManager.build(BuildManager.java:382) at org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBuildJob.java:144) at org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJob.java:235) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55) Caused by: org.apache.maven.plugin.PluginResolutionException: Plugin org.apache.maven.plugins:maven-resources- plugin:2.6 or one of its dependencies could not be resolved: The following artifacts could not be resolved: org.apache.maven:maven-plugin-api:jar:2.0.6, org.apache.maven:maven- project:jar:2.0.6, org.apache.maven:maven-profile:jar:2.0.6, 请问如何解决?谢谢 ----- 本机安装的maven是3.2.2 eclipse是4.5 m2e是1.2 ----- 最后也不知道什么原因,重新下了eclipse就没有问题了
maven引入springcloud报错,求解决方案
maven项目引入springcloud相关jar报错 <parent>标签标错 For artifact {org.springframework.cloud:spring-cloud-starter-consul-discovery:null:jar}: The version cannot be empty. (org.apache.maven.plugins:maven-resources-plugin:3.0.1:testResources:default-testResources:process-test-resources) <dependency>标签报错 Project build error: Non-resolvable import POM: Failure to find org.springframework.cloud:spring-cloud-dependencies:pom:Finchley.M7 in http://maven.aliyun.com/nexus/content/groups/public was cached in the local repository, resolution will not be reattempted until the update interval of window-aliyun has elapsed or updates are forced
maven项目构建报错 难受
18-10-31 上午09时30分50秒: Generating sources /HDTW1/pom.xml 18-10-31 上午09时30分50秒: Build error for /HDTW1/pom.xml; org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-resources-plugin:3.0.2:resources (default-resources) on project HDTW1: Execution default-resources of goal org.apache.maven.plugins:maven-resources-plugin:3.0.2:resources failed: Unable to load the mojo 'resources' (or one of its required components) from the plugin 'org.apache.maven.plugins:maven-resources-plugin:3.0.2' 18-10-31 上午09时30分50秒: Adding source folder /HDTW1/src/main/java 18-10-31 上午09时30分50秒: Adding source folder /HDTW1/src/test/java 18-10-31 上午09时30分50秒: Update completed: 0 sec 18-10-31 上午09时30分50秒: Maven Builder: AUTO_BUILD 这是什么情况啊? 这个JAR包 存在的啊 我都能找到 有没大神告诉我一下咋个处理
maven配置私服打包报错Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.5:compile
直接使用阿里云镜像仓库打包没问题,替换为私服镜像仓库后报错: 就是pom.xml中的plugin报错 ``` <plugin> <groupId>org.apache.maven.plugins</groupId> <artifactId>maven-compiler-plugin</artifactId> <version>3.5</version> <configuration> <source>1.8</source> <target>1.8</target> <encoding>UTF-8</encoding> </configuration> </plugin> ``` 网上找了半天说这个指定的jdk版本的问题,查了一下版本没问题都是1.8 报错内容: [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.5:compile (default-compile) on project mytest-web: Execution default-compile of goal org.apache.maven.plugins:maven-compiler-plugin:3.5:compile failed: Plugin org.apache.maven.plugins:maven-compiler-plugin:3.5 or one of its dependencies could not be resolved: Failed to collect dependencies at org.apache.maven.plugins:maven-compiler-plugin:jar:3.5 -> org.apache.maven:maven-toolchain:jar:2.2.1 -> org.apache.maven:maven-core:jar:2.2.1 -> commons-cli:commons-cli:jar:1.2: Failed to read artifact descriptor for commons-cli:commons-cli:jar:1.2: Failure to find org.apache:apache:pom:4 in http://localhost:8081/nexus/content/groups/public/ was cached in the local repository, resolution will not be reattempted until the update interval of public has elapsed or updates are forced -> [Help 1] org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.5:compile (default-compile) on project mytest-web: Execution default-compile of goal org.apache.maven.plugins:maven-compiler-plugin:3.5:compile failed: Plugin org.apache.maven.plugins:maven-compiler-plugin:3.5 or one of its dependencies could not be resolved: Failed to collect dependencies at org.apache.maven.plugins:maven-compiler-plugin:jar:3.5 -> org.apache.maven:maven-toolchain:jar:2.2.1 -> org.apache.maven:maven-core:jar:2.2.1 -> commons-cli:commons-cli:jar:1.2 at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:213) at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:154) at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:146) at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:117) at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:81) at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51) at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128) at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:309) at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:194) at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:107) at org.apache.maven.cli.MavenCli.execute(MavenCli.java:993) at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:345) at org.apache.maven.cli.MavenCli.main(MavenCli.java:191) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289) at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229) at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415) at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356) Caused by: org.apache.maven.plugin.PluginExecutionException: Execution default-compile of goal org.apache.maven.plugins:maven-compiler-plugin:3.5:compile failed: Plugin org.apache.maven.plugins:maven-compiler-plugin:3.5 or one of its dependencies could not be resolved: Failed to collect dependencies at org.apache.maven.plugins:maven-compiler-plugin:jar:3.5 -> org.apache.maven:maven-toolchain:jar:2.2.1 -> org.apache.maven:maven-core:jar:2.2.1 -> commons-cli:commons-cli:jar:1.2 at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:106) at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:208) ... 20 more Caused by: org.apache.maven.plugin.PluginResolutionException: Plugin org.apache.maven.plugins:maven-compiler-plugin:3.5 or one of its dependencies could not be resolved: Failed to collect dependencies at org.apache.maven.plugins:maven-compiler-plugin:jar:3.5 -> org.apache.maven:maven-toolchain:jar:2.2.1 -> org.apache.maven:maven-core:jar:2.2.1 -> commons-cli:commons-cli:jar:1.2 at org.apache.maven.plugin.internal.DefaultPluginDependenciesResolver.resolveInternal(DefaultPluginDependenciesResolver.java:214) at org.apache.maven.plugin.internal.DefaultPluginDependenciesResolver.resolve(DefaultPluginDependenciesResolver.java:149) at org.apache.maven.plugin.internal.DefaultMavenPluginManager.createPluginRealm(DefaultMavenPluginManager.java:402) at org.apache.maven.plugin.internal.DefaultMavenPluginManager.setupPluginRealm(DefaultMavenPluginManager.java:374) at org.apache.maven.plugin.DefaultBuildPluginManager.getPluginRealm(DefaultBuildPluginManager.java:231) at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:102) ... 21 more Caused by: org.eclipse.aether.collection.DependencyCollectionException: Failed to collect dependencies at org.apache.maven.plugins:maven-compiler-plugin:jar:3.5 -> org.apache.maven:maven-toolchain:jar:2.2.1 -> org.apache.maven:maven-core:jar:2.2.1 -> commons-cli:commons-cli:jar:1.2 at org.eclipse.aether.internal.impl.DefaultDependencyCollector.collectDependencies(DefaultDependencyCollector.java:300) at org.eclipse.aether.internal.impl.DefaultRepositorySystem.collectDependencies(DefaultRepositorySystem.java:325) at org.apache.maven.plugin.internal.DefaultPluginDependenciesResolver.resolveInternal(DefaultPluginDependenciesResolver.java:202) ... 26 more Caused by: org.eclipse.aether.resolution.ArtifactDescriptorException: Failed to read artifact descriptor for commons-cli:commons-cli:jar:1.2 at org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.loadPom(DefaultArtifactDescriptorReader.java:330) at org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.readArtifactDescriptor(DefaultArtifactDescriptorReader.java:199) at org.eclipse.aether.internal.impl.DefaultDependencyCollector.resolveCachedArtifactDescriptor(DefaultDependencyCollector.java:544) at org.eclipse.aether.internal.impl.DefaultDependencyCollector.getArtifactDescriptorResult(DefaultDependencyCollector.java:528) at org.eclipse.aether.internal.impl.DefaultDependencyCollector.processDependency(DefaultDependencyCollector.java:418) at org.eclipse.aether.internal.impl.DefaultDependencyCollector.processDependency(DefaultDependencyCollector.java:372) at org.eclipse.aether.internal.impl.DefaultDependencyCollector.process(DefaultDependencyCollector.java:360) at org.eclipse.aether.internal.impl.DefaultDependencyCollector.doRecurse(DefaultDependencyCollector.java:513) at org.eclipse.aether.internal.impl.DefaultDependencyCollector.processDependency(DefaultDependencyCollector.java:467) at org.eclipse.aether.internal.impl.DefaultDependencyCollector.processDependency(DefaultDependencyCollector.java:372) at org.eclipse.aether.internal.impl.DefaultDependencyCollector.process(DefaultDependencyCollector.java:360) at org.eclipse.aether.internal.impl.DefaultDependencyCollector.doRecurse(DefaultDependencyCollector.java:513) at org.eclipse.aether.internal.impl.DefaultDependencyCollector.processDependency(DefaultDependencyCollector.java:467) at org.eclipse.aether.internal.impl.DefaultDependencyCollector.processDependency(DefaultDependencyCollector.java:372) at org.eclipse.aether.internal.impl.DefaultDependencyCollector.process(DefaultDependencyCollector.java:360) at org.eclipse.aether.internal.impl.DefaultDependencyCollector.collectDependencies(DefaultDependencyCollector.java:263) ... 28 more Caused by: org.apache.maven.model.resolution.UnresolvableModelException: Failure to find org.apache:apache:pom:4 in http://localhost:8081/nexus/content/groups/public/ was cached in the local repository, resolution will not be reattempted until the update interval of public has elapsed or updates are forced at org.apache.maven.repository.internal.DefaultModelResolver.resolveModel(DefaultModelResolver.java:178) at org.apache.maven.repository.internal.DefaultModelResolver.resolveModel(DefaultModelResolver.java:224) at org.apache.maven.model.building.DefaultModelBuilder.readParentExternally(DefaultModelBuilder.java:1051) at org.apache.maven.model.building.DefaultModelBuilder.readParent(DefaultModelBuilder.java:829) at org.apache.maven.model.building.DefaultModelBuilder.build(DefaultModelBuilder.java:331) at org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.loadPom(DefaultArtifactDescriptorReader.java:321) ... 43 more Caused by: org.eclipse.aether.resolution.ArtifactResolutionException: Failure to find org.apache:apache:pom:4 in http://localhost:8081/nexus/content/groups/public/ was cached in the local repository, resolution will not be reattempted until the update interval of public has elapsed or updates are forced at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:453) at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:255) at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:232) at org.apache.maven.repository.internal.DefaultModelResolver.resolveModel(DefaultModelResolver.java:174) ... 48 more Caused by: org.eclipse.aether.transfer.ArtifactNotFoundException: Failure to find org.apache:apache:pom:4 in http://localhost:8081/nexus/content/groups/public/ was cached in the local repository, resolution will not be reattempted until the update interval of public has elapsed or updates are forced at org.eclipse.aether.internal.impl.DefaultUpdateCheckManager.newException(DefaultUpdateCheckManager.java:240) at org.eclipse.aether.internal.impl.DefaultUpdateCheckManager.checkArtifact(DefaultUpdateCheckManager.java:215) at org.eclipse.aether.internal.impl.DefaultArtifactResolver.gatherDownloads(DefaultArtifactResolver.java:594) at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:512) at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:430) ... 51 more [ERROR] [ERROR] Re-run Maven using the -X switch to enable full debug logging. [ERROR] [ERROR] For more information about the errors and possible solutions, please read the following articles: [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException
myeclipse建立maven是pom.xml报错
用MyEclipse10建立maven web工程的时候,POM.XML总是报错,错误信息如下。还请大神们帮帮忙啊~~ 小弟感激涕零!! Multiple annotations found at this line: - No plugin found for prefix 'war' in the current project and in the plugin groups [] available from the repositories [local (C:\Users\Guan Yang\.m2\repository), central (http://repo1.maven.org/maven2)] - Failure to transfer org.apache.maven.plugins:maven-resources-plugin:pom:2.4.3 from http:// repo1.maven.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer artifact org.apache.maven.plugins:maven-resources-plugin:pom:2.4.3 from/to central (http://repo1.maven.org/maven2): null to http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-resources-plugin/2.4.3/maven-resources- plugin-2.4.3.pom
maven更新后war项目报错
我点了update project后,项目就报错了,是怎么回事? ![图片说明](https://img-ask.csdn.net/upload/201805/11/1526006255_114703.png) ![图片说明](https://img-ask.csdn.net/upload/201805/11/1526006266_476125.png) ![图片说明](https://img-ask.csdn.net/upload/201805/11/1526006275_391364.png)
创建Maven项目 pom.xml文件报错
创建maven项目 pom.xml文件提示错误: Failure to transfer org.apache.maven.surefire:surefire:pom:2.10 from http://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer artifact org.apache.maven.surefire:surefire:pom:2.10 from/to central (http://repo.maven.apache.org/maven2): java.net.ConnectException: connection timed out to http://repo.maven.apache.org/maven2/org/apache/maven/surefire/surefire/2.10/surefire-2.10.pom 在网上搜索后给出的解决方法是 打开maven的本地库...\repository\org\apache\maven\plugins\maven-surefire-plugin\2.10会发现:里面少只有一个maven-surefire-plugin-2.10.pom.lastUpdated,而没有maven-surefire-plugin-2.10.jar 解决方法: 1.删除maven-surefire-plugin-2.7.1.pom.lastUpdated文件 2.右键点击project -> Maven - Update Dependencies 但我的本地库有aven-surefire-plugin-2.10.jar以及相关文件 没有maven-surefire-plugin-2.10.pom.lastUpdated文件 怎么还报这样的错误 在网上搜索好长时间 一直没有解决 求大神指点!! 谢谢
update maven项目的同时也会自动改变web的版本,怎样让它不自动改变,或者指定改变成某一个版本。
updata maven project时<br> 有一个项目的 ``` <installed facet="jst.web" version="3.0"/> ``` 自动变成4.0<br> 有一个项目变成3.0<br> 有一个项目变成2.3<br> 但是update 前如果没有改成它要改变的版本(上面所说的),那么updata后就会报错。 <br>错误信息:Cannot change version of project facet Dynamic Web Module to 2.3.<br> 这是update的后报错
以前一直好好的 为什么今天springboot的jar包中,parent标签一直报错,我强制更新 maven很多次了,也没用!!!
以前一直好好的 为什么今天springboot的jar包中,parent标签一直报错,我强制更新 maven很多次了,也没用!!!,因为这个导致我项目很多注解失效! ![图片说明](https://img-ask.csdn.net/upload/201903/16/1552727814_566268.png) 这是parent节点的报错说明: Project configurator "org.springframework.ide.eclipse.boot.properties.editor.maven.EnableJdtAptM2EProjectConfigurator" required by plugin execution "org.apache.maven.plugins:maven-compiler-plugin:3.7.0:testCompile (execution: default-testCompile, phase: test-compile)" is not available. To enable full functionality, install the project configurator and run Maven->Update Project Configuration.
maven项目导入之后pom.xml报错
我项目导入之后,pom.xml有红叉,找不到jar包,但是我本地仓库有这个jar包,不知道为什么找不到,点了clean 又 maven--》update project还是报错 到底怎么回事,求教 ![图片说明](https://img-ask.csdn.net/upload/201612/23/1482479584_964743.png) ![图片说明](https://img-ask.csdn.net/upload/201612/26/1482716996_532677.png) ``` <?xml version="1.0"?> <project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <modelVersion>4.0.0</modelVersion> <parent> <artifactId>parent</artifactId> <groupId>com.auchan</groupId> <version>1.0.0-SNAPSHOT</version> </parent> <groupId>com.auchan.web</groupId> <artifactId>web</artifactId> <packaging>war</packaging> <version>1.0.0-SNAPSHOT</version> <name>${project.artifactId} v${project.version}</name> <dependencies> <dependency> <groupId>junit</groupId> <artifactId>junit</artifactId> </dependency> <!--inner project dependency start --> <dependency> <groupId>com.auchan.service</groupId> <artifactId>service</artifactId> <version>${training.version}</version> <exclusions> <exclusion> <artifactId>commons-fileupload</artifactId> <groupId>commons-fileupload</groupId> </exclusion> <exclusion> <artifactId>log4j</artifactId> <groupId>log4j</groupId> </exclusion> </exclusions> </dependency> <dependency> <groupId>com.auchan.engine</groupId> <artifactId>engine</artifactId> <version>${training.version}</version> </dependency> <!--inner project dependency end --> <dependency> <groupId>org.tuckey</groupId> <artifactId>urlrewrite</artifactId> </dependency> <dependency> <groupId>org.mortbay.jetty</groupId> <artifactId>jetty</artifactId> </dependency> <dependency> <groupId>org.mortbay.jetty</groupId> <artifactId>jetty-util</artifactId> </dependency> <dependency> <groupId>org.mortbay.jetty</groupId> <artifactId>jetty-naming</artifactId> </dependency> <dependency> <groupId>org.mortbay.jetty</groupId> <artifactId>jetty-plus</artifactId> </dependency> <dependency> <groupId>org.mortbay.jetty</groupId> <artifactId>jsp-2.1</artifactId> </dependency> <dependency> <groupId>org.mortbay.jetty</groupId> <artifactId>jsp-api-2.1</artifactId> </dependency> <!--generate validate code denpendency --> <dependency> <groupId>com.googlecode</groupId> <artifactId>kaptcha</artifactId> </dependency> </dependencies> </project> ```
eclipse里maven项目设置了私服也设置了本地仓库,但是install时一直报错
maven项目, install的时候报错,看了下,一直去apache的仓库去找,当然找不到啊。报错如下: Non-resolvable parent POM: Failure to find com.th.supcom:super-parent:pom:1.2.7 in http://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced and 'parent.relativePath' points at wrong local POM @ line 3, column 10 在项目的pom.xml中已配置私服,setting.xml本地仓库配置了地址,但是报错里面还是去的apache.org里去找的,不知道为什么。 pom.xml私服配置 <!-- 配置私服release地址 --> <distributionManagement> <repository> <id>Releases</id> <url>nexus搭的私服url</url> </repository> <snapshotRepository> <id>Snapshots</id> <url>nexus搭的私服url</url> </snapshotRepository> <!-- site地址配置 --> <site> <id>sites-url</id> <url>dav:${sites.url}/${project.artifactId}/${project.version}</url> </site> </distributionManagement>
scala ide for eclipse搭建spark源码阅读环境报错
git bash下载spark源码 sbt eclipse 以existing maven project导入scala ide for eclipse报了scala version、project依赖missing等错误,还剩not found:type EventBatch无法解决 在eclipse里update project,错误会消失,但每次build错误就又会出现,导致一直无法build success。。。。。。 请教大神报错原因及如何解决!!!
applicationContext.xml 解析不到。update project之后又没问题
Myeclipse ,内置的maven建项目,加了spring 框架。 遇到的问题是 Exception in thread "main" org.springframework.beans.factory.BeanDefinitionStoreException: IOException parsing XML document from class path resource [applicationContext.xml]; nested exception is java.io.FileNotFoundException: class path resource [applicationContext.xml] cannot be opened because it does not exist ....(省略) Caused by: java.io.FileNotFoundException: class path resource [applicationContext.xml] cannot be opened because it does not exist 解析不到applicationContext.xml 但感觉没有错,如下 ![图片说明](https://img-ask.csdn.net/upload/201608/12/1470975495_55217.png) ...=new ClassPathXmlApplicationContext("classpath:applicationContext.xml"); 但是我通过Maven4Myeclipse--》update project 之后可以运行了 但是使用 maven命令clean compile 之后,再次运行,又报出上面的错误了。 怎么回事?
maven项目有红色感叹号,pom文件没有显示错误?jar包也没有小红叉
项目为使用spring cloud的框架,但是现在maven项目有红色感叹号,pom文件没有显示错误?jar包也没有小红叉。启动项目报错为找不到主类。 已经尝试过的方法: 删除仓库中所有的.lastupdated文件,然后对项目进行maven clean和maven install,不起作用。 maven->update project 不起作用 请问有什么方法可以解决? ![图片说明](https://img-ask.csdn.net/upload/201611/01/1477961167_794097.png)
maven利用nexus配置私服报如下异常如何解决?
先说下开发环境: 1. apache-maven-3.1.1 2. nexus-2.6.4-02-bundle 3. jdk1.7.0_45 最近开始使用maven构建项目(因为它实在太好用了),不过maven每次构建项目都要依赖中央仓库,这很不合理,所以使用了Nexus搭建了本地仓库,不过本地仓库搭建完成以后运行第一个命令mvn help:system就报了错,利用mvn -e help:system查看报错信息看了半天也没有头绪,下面就是这个报错信息: > [ERROR] Failed to execute goal > org.apache.maven.plugins:maven-help-plugin:2.2:system (default-cli) on > project standalone-pom: Execution default-cli of goal > org.apache.maven.plugins:maven-help-plugin:2.2:system failed: Plugin > org.apache.maven.plugins:maven-help-plugin:2.2 or one of its > dependencies could not be resolved: Failed to collect dependencies at > org.apache.maven.plugins:maven-help-plugin:jar:2.2 -> > org.apache.maven.plugin-tools:maven-plugin-tools-api:jar:2.4.3: Failed > to read artifact descriptor for > org.apache.maven.plugin-tools:maven-plugin-tools-api:jar:2.4.3: > Failure to find org.apache.maven:maven-parent:pom:8 in > http://127.0.0.1:8081/nexus/content/groups/public was cached in the > local repository, resolution will not be reattempted until the update > interval of roger-nexus has elapsed or updates are forced -> [Help > 1]org.apache.maven.lifecycle.LifecycleExecutionException: Failed to > execute goal org.apache.maven.plugins:maven-help-plugin:2.2:system > (default-cli) on project standalone-pom: Execution default-cli of goal > org.apache.maven.plugins:maven-help-plugin:2.2:system failed: Plugin > org.apache.maven.plugins:maven-help-plugin:2.2 or one of its > dependencies could not be resolved: Failed to collect dependencies at > org.apache.maven.plugins:maven-help-plugin:jar:2.2 -> > org.apache.maven.plugin-tools:maven-plugin-tools-api:jar:2.4.3 > at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:224) > at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153) > at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145) > at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84) > at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59) > at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183) > at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161) > at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:317) > at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:152) > at org.apache.maven.cli.MavenCli.execute(MavenCli.java:555) > at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:214) > at org.apache.maven.cli.MavenCli.main(MavenCli.java:158) > at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) > at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) > at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) > at java.lang.reflect.Method.invoke(Method.java:606) > at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289) > at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229) > at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415) > at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356) > Caused by: org.apache.maven.plugin.PluginExecutionException: Execution > default-cli of goal > org.apache.maven.plugins:maven-help-plugin:2.2:system failed: > Pluginorg.apache.maven.plugins:maven-help-plugin:2.2 or one of its > dependencies couldnot be resolved: Failed to collect dependencies at > org.apache.maven.plugins:maven-help-plugin:jar:2.2 -> > org.apache.maven.plugin-tools:maven-plugin-tools-api:jar:2.4.3 > at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:87) > at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:208) > ... 19 more Caused by: org.apache.maven.plugin.PluginResolutionException: Plugin > org.apache.maven.plugins:maven-help-plugin:2.2 or one of its > dependencies could not be resolved: Failed to collect dependencies at > org.apache.maven.plugins:maven-help-plugin:jar:2.2 -> > org.apache.maven.plugin-tools:maven-plugin-tools-api:jar:2.4.3 > at org.apache.maven.plugin.internal.DefaultPluginDependenciesResolver.resolve(DefaultPluginDependenciesResolver.java:204) > at org.apache.maven.plugin.internal.DefaultMavenPluginManager.createPluginRealm(DefaultMavenPluginManager.java:357) > at org.apache.maven.plugin.internal.DefaultMavenPluginManager.setupPluginRealm(DefaultMavenPluginManager.java:325) > at org.apache.maven.plugin.DefaultBuildPluginManager.getPluginRealm(DefaultBuildPluginManager.java:180) > at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:83) > ... 20 more Caused by: org.eclipse.aether.collection.DependencyCollectionException: Failed to > collect dependencies at > org.apache.maven.plugins:maven-help-plugin:jar:2.2 > ->org.apache.maven.plugin-tools:maven-plugin-tools-api:jar:2.4.3 > at org.eclipse.aether.internal.impl.DefaultDependencyCollector.collectDependencies(DefaultDependencyCollector.java:292) > at org.eclipse.aether.internal.impl.DefaultRepositorySystem.collectDependencies(DefaultRepositorySystem.java:317) > at org.apache.maven.plugin.internal.DefaultPluginDependenciesResolver.resolve(DefaultPluginDependenciesResolver.java:192) > ... 24 more Caused by: org.eclipse.aether.resolution.ArtifactDescriptorException: Failed > toread artifact descriptor for > org.apache.maven.plugin-tools:maven-plugin-tools-ap i:jar:2.4.3 > at org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.loadPom(DefaultArtifactDescriptorReader.java:370) > at org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.readArtifactDescriptor(DefaultArtifactDescriptorReader.java:217) > at org.eclipse.aether.internal.impl.DefaultDependencyCollector.process(DefaultDependencyCollector.java:461) > at org.eclipse.aether.internal.impl.DefaultDependencyCollector.collectDependencies(DefaultDependencyCollector.java:261) > ... 26 more Caused by: org.apache.maven.model.resolution.UnresolvableModelException: Failure > to find org.apache.maven:maven-parent:pom:8 in > http://127.0.0.1:8081/nexus/content/groups/public was cached in the > local repository, resolution will not be reattempted until the update > interval of roger-nexus has elapsed or updates are for ced > at org.apache.maven.repository.internal.DefaultModelResolver.resolveModel(DefaultModelResolver.java:126) > at org.apache.maven.model.building.DefaultModelBuilder.readParentExternally(DefaultModelBuilder.java:817) > at org.apache.maven.model.building.DefaultModelBuilder.readParent(DefaultModelBuilder.java:669) > at org.apache.maven.model.building.DefaultModelBuilder.build(DefaultModelBuilder.java:307) > at org.apache.maven.repository.internal.DefaultArtifactDescriptorReader.loadPom(DefaultArtifactDescriptorReader.java:361) > ... 29 more Caused by: org.eclipse.aether.resolution.ArtifactResolutionException: Failure to > find org.apache.maven:maven-parent:pom:8 in > http://127.0.0.1:8081/nexus/content/groups/public was cached in the > local repository, resolution will not be reattempted until the update > interval of roger-nexus has elapsed or updates are forced > at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:459) > at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:262) > at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:239) > at org.apache.maven.repository.internal.DefaultModelResolver.resolveModel(DefaultModelResolver.java:122) > ... 33 more Caused by: org.eclipse.aether.transfer.ArtifactNotFoundException: Failure to find > org.apache.maven:maven-parent:pom:8 in > http://127.0.0.1:8081/nexus/content/groups/public was cached in the > local repository, resolution will not be reattempted until the update > interval of roger-nexus has elapsed or updates are forced > at org.eclipse.aether.internal.impl.DefaultUpdateCheckManager.newException(DefaultUpdateCheckManager.java:232) > at org.eclipse.aether.internal.impl.DefaultUpdateCheckManager.checkArtifact(DefaultUpdateCheckManager.java:206) > at org.eclipse.aether.internal.impl.DefaultArtifactResolver.gatherDownloads(DefaultArtifactResolver.java:599) > at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:518) > at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:436) > ... 36 more [ERROR] [ERROR] Re-run Maven using the -X switch to enable full debug logging. [ERROR] [ERROR] For more information > about the errors and possible solutions, please read the following > articles: [ERROR] [Help 1] > http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException 我搜索了一部分报错信息,参考了Stack Overflow上的一些问题,猜测有可能是有些网站被墙所以无法下载一些.pom文件,不过当我将我的setting.xml中关于nexus的配置注释掉以后mvn help:system完全可以正常运行,所以应该是setting.xml的设置有问题: <?xml version="1.0" encoding="UTF-8"?> <settings xmlns="http://maven.apache.org/SETTINGS/1.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0 http://maven.apache.org/xsd/settings-1.0.0.xsd"> <localRepository>D:/DeveloperKit/maven_repos</localRepository> <pluginGroups> </pluginGroups> <proxies> </proxies> <servers> <server> <id>roger-nexus</id> <username>admin</username> <password>admin123</password> </server> </servers> <mirrors> <mirror> <id>roger-nexus</id> <mirrorOf>*</mirrorOf> <name>Mirror of roger</name> <url>http://127.0.0.1:8081/nexus/content/groups/public</url> </mirror> </mirrors> <profiles> <profile> <id>jdk-1.7</id> <activation> <jdk>1.7</jdk> </activation> <repositories> <repository> <id>jdk17</id> <name>Repository for JDK 1.7 builds</name> <url>http://127.0.0.1:8081/nexus/content/groups/public/</url> <layout>default</layout> <snapshotPolicy>always</snapshotPolicy> </repository> </repositories> </profile> </profiles> <activeProfiles> <activeProfile>jdk-1.7</activeProfile> </activeProfiles> </settings>
maven pom.xml报错 但是在文件中可以找到相对应的jar包,反复的更新也是这样
The project cn.sunline.ipps.business:sunipps-app:1.0.0-SNAPSHOT (D:\work\workspace_cwf_v7\sunipps.app\pom.xml) has 1 error Non-resolvable parent POM: Failure to find cn.sunline.ipps.business:sunipps-parent:pom:1.0.0-SNAPSHOT in http://proxy.clwj.sunline.cn:8081/nexus/content/groups/public/ was cached in the local repository, resolution will not be reattempted until the update interval of rd-nexus has elapsed or updates are forced and 'parent.relativePath' points at wrong local POM @ line 7, column 13 -> [Help 2]
sbt idea build project 报错 invalid sha1: expected=<html> [warn] <head> ?
Error while importing sbt project: [info] Loading settings for project global-plugins from idea.sbt ... [info] Loading global plugins from D:\SBT\sbt\.sbt\plugins [info] Updating ProjectRef(uri("file:/D:/SBT/sbt/.sbt/plugins/"), "global-plugins")... [info] Done updating. [info] Loading project definition from D:\IDEA\sbttest\project [info] Updating ProjectRef(uri("file:/D:/IDEA/sbttest/project/"), "sbttest-build")... [info] Done updating. [info] Loading settings for project root from build.sbt ... [info] Set current project to sbttest (in build file:/D:/IDEA/sbttest/) [info] sbt server started at local:sbt-server-92123181769dae5e81c2 sbt:sbttest> [info] Defining Global / sbtStructureOptions, Global / sbtStructureOutputFile, shellPrompt [info] The new values will be used by no settings or tasks. [info] Reapplying settings... [info] Set current project to sbttest (in build file:/D:/IDEA/sbttest/) [info] Applying State transformations org.jetbrains.sbt.CreateTasks from D:/IDEA/IAD/.IntelliJIdea/config/plugins/Scala/launcher/sbt-structure-1.0.jar [info] Reapplying settings... [info] Set current project to sbttest (in build file:/D:/IDEA/sbttest/) [info] Updating ... [warn] problem while downloading module descriptor: http://mirrors.ibiblio.org/maven2/org/apache/flink/flink-streaming-scala/1.7.0/flink-streaming-scala-1.7.0.pom: invalid sha1: expected=<html> [warn] <head> computed=47abf2c9ebd0dedcc526c0800426f709d8179231 (160357ms) [warn] module not found: org.apache.flink#flink -streaming-scala;1.7.0 [warn] ==== local: tried [warn] D:\SBT\sbt\.ivy2\local\org.apache.flink\flink-streaming-scala\1.7.0\ivys\ivy.xml [warn] ==== comp-maven: tried [warn] http://mvnrepository.com/artifact/org/apache/flink/flink-streaming-scala/1.7.0/flink-streaming-scala-1.7.0.pom [warn] ==== sbt-releases-repo: tried [warn] http://repo.typesafe.com/typesafe/ivy-releases/org.apache.flink/flink-streaming-scala/1.7.0/ivys/ivy.xml [warn] ==== sbt-plugins-repo: tried [warn] http://repo.scala-sbt.org/scalasbt/sbt-plugin-releases/org.apache.flink/flink-streaming-scala/1.7.0/ivys/ivy.xml [warn] ==== ali1: tried [warn] http://maven.aliyun.com/nexus/content/groups/public/org/apache/flink/flink-streaming-scala/1.7.0/flink-streaming-scala-1.7.0.pom [warn] ==== ali2: tried [warn] https://oss.sonatype.org/content/repositories/snapshots/org/apache/flink/flink-streaming-scala/1.7.0/flink-streaming-scala-1.7.0.pom [warn] ==== store_0: tried [warn] https://repository.apache.org/content/repositories/snapshots/org/apache/flink/flink-streaming-scala/1.7.0/flink-streaming-scala-1.7.0.pom [warn] ==== store_1: tried [warn] http://mirrors.ibiblio.org/maven2/org/apache/flink/flink-streaming-scala/1.7.0/flink-streaming-scala-1.7.0.pom [warn] ==== store_2: tried [warn] http://repo2.maven.org/maven2/org/apache/flink/flink-streaming-scala/1.7.0/flink-streaming-scala-1.7.0.pom [warn] ==== maven-central: tried [warn] http://repo1.maven.org/maven2/org/apache/flink/flink-streaming-scala/1.7.0/flink-streaming-scala-1.7.0.pom [warn] ==== Apach : tried [warn] https://repository.apache.org/content/repositories/snapshots/org/apache/flink/flink-streaming-scala/1.7.0/flink-streaming-scala-1.7.0.pom [warn] ==== velvia maven: tried [warn] http://dl.bintray.com/velvia/maven/org/apache/flink/flink-streaming-scala/1.7.0/flink-streaming-scala-1.7.0.pom [warn] ==== ali: tried [warn] https://maven.aliyun.com/repository/public/org/apache/flink/flink-streaming-scala/1.7.0/flink-streaming-scala-1.7.0.pom [warn] :::::::::::::::::::::::::::::::::::::::::::::: [warn] :: UNRESOLVED DEPENDENCIES :: [warn] :::::::::::::::::::::::::::::::::::::::::::::: [warn] :: org.apache.flink#flink-streaming-scala;1.7.0: not found [warn] :::::::::::::::::::::::::::::::::::::::::::::: [warn] [warn] Note: Unresolved dependencies path: [warn] org.apache.flink:flink-streaming-scala:1.7.0 (D:\IDEA\sbttest\build.sbt#L35) [warn] +- sbttest:sbttest_2.11:0.1 [error] sbt.librarymanagement.ResolveException: unresolved dependency: org.apache.flink#flink-streaming-scala;1.7.0: not found [error] at sbt.internal.librarymanagement.IvyActions$.resolveAndRetrieve(IvyActions.scala:332) [error] at sbt.internal.librarymanagement.IvyActions$.$anonfun$updateEither$1(IvyActions.scala:208) [error] at sbt.internal.librarymanagement.IvySbt$Module.$anonfun$withModule$1(Ivy.scala:239) [error] at sbt.internal.librarymanagement.IvySbt.$anonfun$withIvy$1(Ivy.scala:204) [error] at sbt.internal.librarymanagement.IvySbt.sbt$internal$librarymanagement$IvySbt$$action$1(Ivy.scala:70) [error] at sbt.internal.librarymanagement.IvySbt$$anon$3.call(Ivy.scala:77) [error] at xsbt.boot.Locks$GlobalLock.withChannel$1(Locks.scala:95) [error] at xsbt.boot.Locks$GlobalLock.xsbt$boot$Locks$GlobalLock$$withChannelRetries$1(Locks.scala:80) [error] at xsbt.boot.Locks$GlobalLock$$anonfun$withFileLock$1.apply(Locks.scala:99) [error] at xsbt.boot.Using$.withResource(Using.scala:10) [error] at xsbt.boot.Using$.apply(Using.scala:9) [error] at xsbt.boot.Locks$GlobalLock.ignoringDeadlockAvoided(Locks.scala:60) [error] at xsbt.boot.Locks$GlobalLock.withLock(Locks.scala:50) [error] at xsbt.boot.Locks$.apply0(Locks.scala:31) [error] at xsbt.boot.Locks$.apply(Locks.scala:28) [error] at sbt.internal.librarymanagement.IvySbt.withDefaultLogger(Ivy.scala:77) [error] at sbt.internal.librarymanagement.IvySbt.withIvy(Ivy.scala:199) [error] at sbt.internal.librarymanagement.IvySbt.withIvy(Ivy.scala:196) [error] at sbt.internal.librarymanagement.IvySbt$Module.withModule(Ivy.scala:238) [error] at sbt.internal.librarymanagement.IvyActions$.updateEither(IvyActions.scala:193) [error] at sbt.librarymanagement.ivy.IvyDependencyResolution.update(IvyDependencyResolution.scala:20) [error] at sbt.librarymanagement.DependencyResolution.update(DependencyResolution.scala:56) [error] at sbt.internal.LibraryManagement$.resolve$1(LibraryManagement.scala:45) [error] at sbt.internal.LibraryManagement$.$anonfun$cachedUpdate$12(LibraryManagement.scala:93) [error] at sbt.util.Tracked$.$anonfun$lastOutput$1(Tracked.scala:68) [error] at sbt.internal.LibraryManagement$.$anonfun$cachedUpdate$19(LibraryManagement.scala:106) [error] at scala.util.control.Exception$Catch.apply(Exception.scala:224) [error] at sbt.internal.LibraryManagement$.$anonfun$cachedUpdate$11(LibraryManagement.scala:106) [error] at sbt.internal.LibraryManagement$.$anonfun$cachedUpdate$11$adapted(LibraryManagement.scala:89) [error] at sbt.util.Tracked$.$anonfun$inputChanged$1(Tracked.scala:149) [error] at sbt.internal.LibraryManagement$.cachedUpdate(LibraryManagement.scala:120) [error] at sbt.Classpaths$.$anonfun$updateTask$5(Defaults.scala:2556) [error] at scala.Function1.$anonfun$compose$1(Function1.scala:44) [error] at sbt.internal.util.$tilde$greater.$anonfun$$u2219$1(TypeFunctions.scala:40) [error] at sbt.std.Transform$$anon$4.work(System.scala:67) [error] at sbt.Execute.$anonfun$submit$2(Execute.scala:269) [error] at sbt.internal.util.ErrorHandling$.wideConvert(ErrorHandling.scala:16) [error] at sbt.Execute.work(Execute.scala:278) [error] at sbt.Execute.$anonfun$submit$1(Execute.scala:269) [error] at sbt.ConcurrentRestrictions$$anon$4.$anonfun$submitValid$1(ConcurrentRestrictions.scala:178) [error] at sbt.CompletionService$$anon$2.call(CompletionService.scala:37) [error] at java.util.concurrent.FutureTask.run(FutureTask.java:266) [error] at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [error] at java.util.concurrent.FutureTask.run(FutureTask.java:266) [error] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [error] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [error] at java.lang.Thread.run(Thread.java:748) [error] sbt.librarymanagement.ResolveException: unresolved dependency: org.apache.flink#flink-streaming-scala;1.7.0: not found [error] at sbt.internal.librarymanagement.IvyActions$.resolveAndRetrieve(IvyActions.scala:332) [error] at sbt.internal.librarymanagement.IvyActions$.$anonfun$updateEither$1(IvyActions.scala:208) [error] at sbt.internal.librarymanagement.IvySbt$Module.$anonfun$withModule$1(Ivy.scala:239) [error] at sbt.internal.librarymanagement.IvySbt.$anonfun$withIvy$1(Ivy.scala:204) [error] at sbt.internal.librarymanagement.IvySbt.sbt$internal$librarymanagement$IvySbt$$action$1(Ivy.scala:70) [error] at sbt.internal.librarymanagement.IvySbt$$anon$3.call(Ivy.scala:77) [error] at xsbt.boot.Locks$GlobalLock.withChannel$1(Locks.scala:95) [error] at xsbt.boot.Locks$GlobalLock.xsbt$boot$Locks$GlobalLock$$withChannelRetries$1(Locks.scala:80) [error] at xsbt.boot.Locks$GlobalLock$$anonfun$withFileLock$1.apply(Locks.scala:99) [error] at xsbt.boot.Using$.withResource(Using.scala:10) [error] at xsbt.boot.Using$.apply(Using.scala:9) [error] at xsbt.boot.Locks$GlobalLock.ignoringDeadlockAvoided(Locks.scala:60) [error] at xsbt.boot.Locks$GlobalLock.withLock(Locks.scala:50) [error] at xsbt.boot.Locks$.apply0(Locks.scala:31) [error] at xsbt.boot.Locks$.apply(Locks.scala:28) [error] at sbt.internal.librarymanagement.IvySbt.withDefaultLogger(Ivy.scala:77) [error] at sbt.internal.librarymanagement.IvySbt.withIvy(Ivy.scala:199) [error] at sbt.internal.librarymanagement.IvySbt.withIvy(Ivy.scala:196) [error] at sbt.internal.librarymanagement.IvySbt$Module.withModule(Ivy.scala:238) [error] at sbt.internal.librarymanagement.IvyActions$.updateEither(IvyActions.scala:193) [error] at sbt.librarymanagement.ivy.IvyDependencyResolution.update(IvyDependencyResolution.scala:20) [error] at sbt.librarymanagement.DependencyResolution.update(DependencyResolution.scala:56) [error] at sbt.internal.LibraryManagement$.resolve$1(LibraryManagement.scala:45) [error] at sbt.internal.LibraryManagement$.$anonfun$cachedUpdate$12(LibraryManagement.scala:93) [error] at sbt.util.Tracked$.$anonfun$lastOutput$1(Tracked.scala:68) [error] at sbt.internal.LibraryManagement$.$anonfun$cachedUpdate$19(LibraryManagement.scala:106) [error] at scala.util.control.Exception$Catch.apply(Exception.scala:224) [error] at sbt.internal.LibraryManagement$.$anonfun$cachedUpdate$11(LibraryManagement.scala:106) [error] at sbt.internal.LibraryManagement$.$anonfun$cachedUpdate$11$adapted(LibraryManagement.scala:89) [error] at sbt.util.Tracked$.$anonfun$inputChanged$1(Tracked.scala:149) [error] at sbt.internal.LibraryManagement$.cachedUpdate(LibraryManagement.scala:120) [error] at sbt.Classpaths$.$anonfun$updateTask$5(Defaults.scala:2556) [error] at scala.Function1.$anonfun$compose$1(Function1.scala:44) [error] at sbt.internal.util.$tilde$greater.$anonfun$$u2219$1(TypeFunctions.scala:40) [error] at sbt.std.Transform$$anon$4.work(System.scala:67) [error] at sbt.Execute.$anonfun$submit$2(Execute.scala:269) [error] at sbt.internal.util.ErrorHandling$.wideConvert(ErrorHandling.scala:16) [error] at sbt.Execute.work(Execute.scala:278) [error] at sbt.Execute.$anonfun$submit$1(Execute.scala:269) [error] at sbt.ConcurrentRestrictions$$anon$4.$anonfun$submitValid$1(ConcurrentRestrictions.scala:178) [error] at sbt.CompletionService$$anon$2.call(CompletionService.scala:37) [error] at java.util.concurrent.FutureTask.run(FutureTask.java:266) [error] at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [error] at java.util.concurrent.FutureTask.run(FutureTask.java:266) [error] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [error] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [error] at java.lang.Thread.run(Thread.java:748) [error] (update) sbt.librarymanagement.ResolveException: unresolved dependency: org.apache.flink#flink-streaming-scala;1.7.0: not found [error] (ssExtractDependencies) sbt.librarymanagement.ResolveException: unresolved dependency: org.apache.flink#flink-streaming-scala;1.7.0: not found [error] Total time: 178 s, completed 2019-6-19 8:35:29 [info] shutting down server Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=512M; support was removed in 8.0
Maven项目从SVN导出后pom文件报错,而且也没有Maven依赖包名
Project build error: Non-resolvable parent POM: Failure to find com.xinbo.webapp:hip-medical:pom:0.0.1-SNAPSHOT in http://10.1.112.8:8081/nexus/content/repositories/snapshots/ was cached in the local repository, resolution will not be reattempted until the update interval of user_snapshot has elapsed or updates are forced and 'parent.relativePath' points at wrong local POM![图片说明](https://img-ask.csdn.net/upload/201703/28/1490665582_359107.png)
ssm项目部署tomcat问题
自己建立了spring+springmvc+mybatis整合的小项目,用的是maven。目录如下图![项目结构](https://img-ask.csdn.net/upload/201711/09/1510208296_486345.png) maven--update project 操作后就能正常启动tomcat,但是会报java.lang.ClassNotFoundException: org.springframework.web.context.ContextLoaderListener,查了百度,说是tomcat下的项目没有lib,然后照着操作,properties-->add maven dependencies ,操作完查看tomcat下的项目web—Inf下有lib,但是启动tomcat又报错。报错如图![报错图片](https://img-ask.csdn.net/upload/201711/09/1510208538_77234.png)。然后我试着又maven ---> update project ,启动没问题,但是tomcat下的项目目录又没了lib包。 至今找不到问题,求解?另外为什么能tomcat启动了,然后我locatlhost:8080/TestProject/index.jsp 报了404 。无从下手,小白求指导
在中国程序员是青春饭吗?
今年,我也32了 ,为了不给大家误导,咨询了猎头、圈内好友,以及年过35岁的几位老程序员……舍了老脸去揭人家伤疤……希望能给大家以帮助,记得帮我点赞哦。 目录: 你以为的人生 一次又一次的伤害 猎头界的真相 如何应对互联网行业的「中年危机」 一、你以为的人生 刚入行时,拿着傲人的工资,想着好好干,以为我们的人生是这样的: 等真到了那一天,你会发现,你的人生很可能是这样的: ...
我在支付宝花了1分钟,查到了女朋友的开房记录!
在大数据时代下,不管你做什么都会留下蛛丝马迹,只要学会把各种软件运用到极致,捉奸简直轻而易举。今天就来给大家分享一下,什么叫大数据抓出轨。据史料证明,马爸爸年轻时曾被...
程序员请照顾好自己,周末病魔差点一套带走我。
程序员在一个周末的时间,得了重病,差点当场去世,还好及时挽救回来了。
卸载 x 雷某度!GitHub 标星 1.5w+,从此我只用这款全能高速下载工具!
作者 | Rocky0429 来源 | Python空间 大家好,我是 Rocky0429,一个喜欢在网上收集各种资源的蒟蒻… 网上资源眼花缭乱,下载的方式也同样千奇百怪,比如 BT 下载,磁力链接,网盘资源等等等等,下个资源可真不容易,不一样的方式要用不同的下载软件,因此某比较有名的 x 雷和某度网盘成了我经常使用的工具。 作为一个没有钱的穷鬼,某度网盘几十 kb 的下载速度让我...
20道你必须要背会的微服务面试题,面试一定会被问到
写在前面: 在学习springcloud之前大家一定要先了解下,常见的面试题有那块,然后我们带着问题去学习这个微服务技术,那么就会更加理解springcloud技术。如果你已经学了springcloud,那么在准备面试的时候,一定要看看看这些面试题。 文章目录1、什么是微服务?2、微服务之间是如何通讯的?3、springcloud 与dubbo有哪些区别?4、请谈谈对SpringBoot 和S...
为什么猝死的都是程序员,基本上不见产品经理猝死呢?
相信大家时不时听到程序员猝死的消息,但是基本上听不到产品经理猝死的消息,这是为什么呢? 我们先百度搜一下:程序员猝死,出现将近700多万条搜索结果: 搜索一下:产品经理猝死,只有400万条的搜索结果,从搜索结果数量上来看,程序员猝死的搜索结果就比产品经理猝死的搜索结果高了一倍,而且从下图可以看到,首页里面的五条搜索结果,其实只有两条才是符合条件。 所以程序员猝死的概率真的比产品经理大,并不是错...
毕业5年,我问遍了身边的大佬,总结了他们的学习方法
我问了身边10个大佬,总结了他们的学习方法,原来成功都是有迹可循的。
推荐10个堪称神器的学习网站
每天都会收到很多读者的私信,问我:“二哥,有什么推荐的学习网站吗?最近很浮躁,手头的一些网站都看烦了,想看看二哥这里有什么新鲜货。” 今天一早做了个恶梦,梦到被老板辞退了。虽然说在我们公司,只有我辞退老板的份,没有老板辞退我这一说,但是还是被吓得 4 点多都起来了。(主要是因为我掌握着公司所有的核心源码,哈哈哈) 既然 4 点多起来,就得好好利用起来。于是我就挑选了 10 个堪称神器的学习网站,推...
这些软件太强了,Windows必装!尤其程序员!
Windows可谓是大多数人的生产力工具,集娱乐办公于一体,虽然在程序员这个群体中都说苹果是信仰,但是大部分不都是从Windows过来的,而且现在依然有很多的程序员用Windows。 所以,今天我就把我私藏的Windows必装的软件分享给大家,如果有一个你没有用过甚至没有听过,那你就赚了????,这可都是提升你幸福感的高效率生产力工具哦! 走起!???? NO、1 ScreenToGif 屏幕,摄像头和白板...
阿里面试,面试官没想到一个ArrayList,我都能跟他扯半小时
我是真的没想到,面试官会这样问我ArrayList。
曾经优秀的人,怎么就突然不优秀了。
职场上有很多辛酸事,很多合伙人出局的故事,很多技术骨干被裁员的故事。说来模板都类似,曾经是名校毕业,曾经是优秀员工,曾经被领导表扬,曾经业绩突出,然而突然有一天,因为种种原因,被裁员了,...
大学四年因为知道了这32个网站,我成了别人眼中的大神!
依稀记得,毕业那天,我们导员发给我毕业证的时候对我说“你可是咱们系的风云人物啊”,哎呀,别提当时多开心啦????,嗯,我们导员是所有导员中最帅的一个,真的???? 不过,导员说的是实话,很多人都叫我大神的,为啥,因为我知道这32个网站啊,你说强不强????,这次是绝对的干货,看好啦,走起来! PS:每个网站都是学计算机混互联网必须知道的,真的牛杯,我就不过多介绍了,大家自行探索,觉得没用的,尽管留言吐槽吧???? 社...
良心推荐,我珍藏的一些Chrome插件
上次搬家的时候,发了一个朋友圈,附带的照片中不小心暴露了自己的 Chrome 浏览器插件之多,于是就有小伙伴评论说分享一下我觉得还不错的浏览器插件。 我下面就把我日常工作和学习中经常用到的一些 Chrome 浏览器插件分享给大家,随便一个都能提高你的“生活品质”和工作效率。 Markdown Here Markdown Here 可以让你更愉快的写邮件,由于支持 Markdown 直接转电子邮...
看完这篇HTTP,跟面试官扯皮就没问题了
我是一名程序员,我的主要编程语言是 Java,我更是一名 Web 开发人员,所以我必须要了解 HTTP,所以本篇文章就来带你从 HTTP 入门到进阶,看完让你有一种恍然大悟、醍醐灌顶的感觉。 最初在有网络之前,我们的电脑都是单机的,单机系统是孤立的,我还记得 05 年前那会儿家里有个电脑,想打电脑游戏还得两个人在一个电脑上玩儿,及其不方便。我就想为什么家里人不让上网,我的同学 xxx 家里有网,每...
2020 年,大火的 Python 和 JavaScript 是否会被取而代之?
Python 和 JavaScript 是目前最火的两大编程语言,但是2020 年,什么编程语言将会取而代之呢? 作者 |Richard Kenneth Eng 译者 |明明如月,责编 | 郭芮 出品 | CSDN(ID:CSDNnews) 以下为译文: Python 和 JavaScript 是目前最火的两大编程语言。然而,他们不可能永远屹立不倒。最终,必将像其他编程语言一...
史上最全的IDEA快捷键总结
现在Idea成了主流开发工具,这篇博客对其使用的快捷键做了总结,希望对大家的开发工作有所帮助。
阿里程序员写了一个新手都写不出的低级bug,被骂惨了。
这种新手都不会范的错,居然被一个工作好几年的小伙子写出来,差点被当场开除了。
谁是华为扫地僧?
是的,华为也有扫地僧!2020年2月11-12日,“养在深闺人不知”的华为2012实验室扫地僧们,将在华为开发者大会2020(Cloud)上,和大家见面。到时,你可以和扫地僧们,吃一个洋...
AI 没让人类失业,搞 AI 的人先失业了
最近和几个 AI 领域的大佬闲聊 根据他们讲的消息和段子 改编出下面这个故事 如有雷同 都是巧合 1. 老王创业失败,被限制高消费 “这里写我跑路的消息实在太夸张了。” 王葱葱哼笑一下,把消息分享给群里。 阿杰也看了消息,笑了笑。在座几位也都笑了。 王葱葱是个有名的人物,21岁那年以全额奖学金进入 KMU 攻读人工智能博士,累计发表论文 40 余篇,个人技术博客更是成为深度学习领域内风向标。 ...
2020年,冯唐49岁:我给20、30岁IT职场年轻人的建议
点击“技术领导力”关注∆每天早上8:30推送 作者|Mr.K 编辑| Emma 来源|技术领导力(ID:jishulingdaoli) 前天的推文《冯唐:职场人35岁以后,方法论比经验重要》,收到了不少读者的反馈,觉得挺受启发。其实,冯唐写了不少关于职场方面的文章,都挺不错的。可惜大家只记住了“春风十里不如你”、“如何避免成为油腻腻的中年人”等不那么正经的文章。 本文整理了冯...
最全最强!世界大学计算机专业排名总结!
我正在参与CSDN200进20,希望得到您的支持,扫码续投票5次。感谢您! (为表示感谢,您投票后私信我,我把我总结的人工智能手推笔记和思维导图发送给您,感谢!) 目录 泰晤士高等教育世界大学排名 QS 世界大学排名 US News 世界大学排名 世界大学学术排名(Academic Ranking of World Universities) 泰晤士高等教育世界大学排名 中国共...
作为一名大学生,如何在B站上快乐的学习?
B站是个宝,谁用谁知道???? 作为一名大学生,你必须掌握的一项能力就是自学能力,很多看起来很牛X的人,你可以了解下,人家私底下一定是花大量的时间自学的,你可能会说,我也想学习啊,可是嘞,该学习啥嘞,不怕告诉你,互联网时代,最不缺的就是学习资源,最宝贵的是啥? 你可能会说是时间,不,不是时间,而是你的注意力,懂了吧! 那么,你说学习资源多,我咋不知道,那今天我就告诉你一个你必须知道的学习的地方,人称...
那些年,我们信了课本里的那些鬼话
教材永远都是有错误的,从小学到大学,我们不断的学习了很多错误知识。 斑羚飞渡 在我们学习的很多小学课文里,有很多是错误文章,或者说是假课文。像《斑羚飞渡》: 随着镰刀头羊的那声吼叫,整个斑羚群迅速分成两拨,老年斑羚为一拨,年轻斑羚为一拨。 就在这时,我看见,从那拨老斑羚里走出一只公斑羚来。公斑羚朝那拨年轻斑羚示意性地咩了一声,一只半大的斑羚应声走了出来。一老一少走到伤心崖,后退了几步,突...
使用 Python 和百度语音识别生成视频字幕
文章目录从视频中提取音频根据静音对音频分段使用百度语音识别获取 Access Token使用 Raw 数据进行合成生成字幕总结 从视频中提取音频 安装 moviepy pip install moviepy 相关代码: audio_file = work_path + '\\out.wav' video = VideoFileClip(video_file) video.audio.write_...
一个程序在计算机中是如何运行的?超级干货!!!
强烈声明:本文很干,请自备茶水!???? 开门见山,咱不说废话! 你有没有想过,你写的程序,是如何在计算机中运行的吗?比如我们搞Java的,肯定写过这段代码 public class HelloWorld { public static void main(String[] args) { System.out.println("Hello World!"); } ...
【蘑菇街技术部年会】程序员与女神共舞,鼻血再次没止住。(文末内推)
蘑菇街技术部的年会,别开生面,一样全是美女。
那个在阿里养猪的工程师,5年了……
简介: 在阿里,走过1825天,没有趴下,依旧斗志满满,被称为“五年陈”。他们会被授予一枚戒指,过程就叫做“授戒仪式”。今天,咱们听听阿里的那些“五年陈”们的故事。 下一个五年,猪圈见! 我就是那个在养猪场里敲代码的工程师,一年多前我和20位工程师去了四川的猪场,出发前总架构师慷慨激昂的说:同学们,中国的养猪产业将因为我们而改变。但到了猪场,发现根本不是那么回事:要个WIFI,没有;...
为什么程序猿都不愿意去外包?
分享外包的组织架构,盈利模式,亲身经历,以及根据一些外包朋友的反馈,写了这篇文章 ,希望对正在找工作的老铁有所帮助
Java校招入职华为,半年后我跑路了
何来 我,一个双非本科弟弟,有幸在 19 届的秋招中得到前东家华为(以下简称 hw)的赏识,当时秋招签订就业协议,说是入了某 java bg,之后一系列组织架构调整原因等等让人无法理解的神操作,最终毕业前夕,被通知调往其他 bg 做嵌入式开发(纯 C 语言)。 由于已至于校招末尾,之前拿到的其他 offer 又无法再收回,一时感到无力回天,只得默默接受。 毕业后,直接入职开始了嵌入式苦旅,由于从未...
世界上有哪些代码量很少,但很牛逼很经典的算法或项目案例?
点击上方蓝字设为星标下面开始今天的学习~今天分享四个代码量很少,但很牛逼很经典的算法或项目案例。1、no code 项目地址:https://github.com/kelseyhight...
立即提问