Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1
1 2
0 2
0 0
Sample Output
Case 1: 2
Case 2: 1
题意:假设海岸线是一条无限延伸的直线。陆地在海岸线的一侧,而海洋在另一侧。每一个小的岛屿是海洋上的一个点。雷达坐落于海岸线上,只能覆盖d距离,所以如果小岛能够被覆盖到的话,它们之间的距离最多为d。
题目要求计算出能够覆盖给出的所有岛屿的最少雷达数目。
#include <algorithm>
#include <vector>
#include <limits>
#include <string>
using namespace std;
double d;
int n;
int t=0;
bool flag = false;
vector <int> ans;
struct data
{
public:
double start;
double ends;
};
bool compare(data a,data b)
{
return a.ends<b.ends;
}
int main()
{
while(cin>>n>>d&&(n!=0&&d!=0))
{
vector <data> ils (n);
int x,y,i;
i=0;
while(i!=n&&cin>>x>>y)
{
if(y>d)
{
flag = true;
}
data item;
item.start = x - sqrt(d*d-y*y);
item.ends = x + sqrt(d*d-y*y);
ils[i] = item;
++i;
}
sort(ils.begin(),ils.end(),compare);
i=0;
int num = 0;
double range;
while(i<n)
{
range = ils[i].ends;
while(++i<n)
{
if(ils[i].start>range)
break;
}
++num;
}
if(flag)
{
ans.push_back(-1);
}
else
{
ans.push_back(num);
}
n=d=i=num=0;
ils.clear();
flag = false;
}
for(t=0;t!=ans.size();t++)
{
cout<<"case "<<t+1<<": "<<ans[t]<<endl;
}
return 0;
}