2 ys547007 ys547007 于 2016.04.15 18:06 提问

seaborn,'ImportError: DLL load failed: 找不到指定的模块'

pip安装成功

 C:\Users\Administrator>pip install seaborn-0.7.0-py2.py3-none-any.whl
Processing c:\users\administrator\seaborn-0.7.0-py2.py3-none-any.whl
Installing collected packages: seaborn
Successfully installed seaborn-0.7.0

导入包时,报错

 C:\Users\Administrator>python
Python 2.7.11 (v2.7.11:6d1b6a68f775, Dec  5 2015, 20:32:19) [MSC v.1500 32 bit (
Intel)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> import seaborn
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "D:\Python27\lib\site-packages\seaborn\__init__.py", line 1, in <module>
    from .rcmod import *
  File "D:\Python27\lib\site-packages\seaborn\rcmod.py", line 8, in <module>
    from . import palettes
  File "D:\Python27\lib\site-packages\seaborn\palettes.py", line 12, in <module>

    from .utils import desaturate, set_hls_values, get_color_cycle
  File "D:\Python27\lib\site-packages\seaborn\utils.py", line 8, in <module>
    from scipy import stats
  File "D:\Python27\lib\site-packages\scipy\stats\__init__.py", line 338, in <mo
dule>
    from .stats import *
  File "D:\Python27\lib\site-packages\scipy\stats\stats.py", line 180, in <modul
e>
    import scipy.special as special
  File "D:\Python27\lib\site-packages\scipy\special\__init__.py", line 627, in <
module>
    from ._ufuncs import *
ImportError: DLL load failed: 找不到指定的模块。
>>>

python版本2.7
我的系统是win7系统 64位
图片说明

2个回答

CSDNXIAOC
CSDNXIAOC   2016.04.15 18:12

安装cx_Oracle,在python2.7里面import cx_Oracle,提示:

 

import cx_Oracle

Traceback (most recent call last):
  File "", line 1, in
    import cx_Oracle
ImportError: DLL load failed: 找不到指定的模块。......
答案就在这里:ImportError: DLL load failed: 找不到指定的模块。
----------------------你好,人类,我是来自CSDN星球的问答机器人小C,以上是依据我对问题的理解给出的答案,如果解决了你的问题,望采纳。

oyljerry
oyljerry   Ds   Rxr 2016.04.15 19:13

你这个包可能安装有问题 所有dll没有加载成功

ys547007
ys547007 你好,那该怎么样正确安装呢?
大约 2 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!
其他相关推荐
解决-win10系统-python3中import cv2显示"ImportError: DLL load failed: 找不到指定的模块。"
问题描述:使用python的pip工具安装pip install opencv_python一路畅通直至安装成功,import cv2却提示错误找不到指定模块。 问题解决:Visual C++ Redistributable for Visual Studio 2015软件已安装,各种修补之后问题锁定为版本不兼容,针对Python3.5.2 应安装opencv_python-3.2.0-c
import cv2 失败 ImportError:DLL load fail:找不到指定模块
先说说我的环境:windows64位、python3.5  64位。 一开始安装opencv3.2.0是在opencv官网下载的opencv-3.2.0-vc14.exe文件直接安装的,但是安装完成后在jupyter中import opencv2失败,显示这样的错误:ImportError:DLL load fail:找不到指定模块。     尝试将opencv里的cv2.pyd拷贝到pyth
python sklearn sklearn报错解决 ImportError: DLL load failed: 找不到指定的模块
1.问题原因::安装包的来源问题,也可以理解为包版本兼容问题,有的包使用官方出版,有的包使用whl文件安装解决方案:将所有包都统一来源,要么全部使用官方出版的包,要么全部使用whl里面的包,问题就解决了numpy+scipy+scikit-learn组件,使用whl文件安装下载:http://pan.baidu.com/s/1hstDOo8下载统一的跟你python版本和系统位一致的库文件: ht...
ImportError:DLL load failed,找不到指定模块的解决办法
开始学习PIL,写了段生成简单图片的代码。 from PIL import Image,ImageDraw img = Image.new('RGB', (300, 200), (61, 61, 61)) ImageDraw.Draw(img, 'RGB') with open('1.png', 'wb')as f: img.save(f, format = 'png') img....
Python3.6 numpy opencv3.2 安装 及 ImportError: DLL load failed: 找不到指定的模块
1.下载安装Python进入Python官方网站,点击Downloads,选择对应的版本下载即可2.安装pip怎么在windows下安装pip?3.安装numpy4. 安装opencv采坑安装opencv的时候,我是参考这个说明指导去安装的,如下: 但是却遇到了问题: ImportError: DLL load failed: 找不到指定的模块 问题解决多亏这篇问答的帮助: DLL lo
ImportError: DLL load failed: 找不到指定的模块
ImportError: DLL load failed: 找不到指定的模块
通过pip安装Pytorch报错ImportError: DLL load failed: 找不到指定的模块解决办法
1、Window 下通过 pip 安装 Pytorch ,但是输入import torch时报错**   from torch._C import ***ImportError: DLL load failed: 找不到指定的模块。2、解决方法打开 https://anaconda.org/anaconda/intel-openmp/files,下载 win-64/intel-openmp-201...
cx_Oracle ImportError: DLL load failed: 找不到指定的模块 解决
<br />环境:<br />Windows7<br />Python 2.6.2<br />cx_Oracle 5.0.4<br />Oracle Instant Client 10.2.0<br /> <br /> <br />a)常规方法解压Oracle Instant Client文件到指定目录<br />b)设置环境变量<br />c)设置tnsnames.ora<br />d)pl/sql developer可以登录远程Oracle数据库<br /> <br /> <br />安装cx_Orac
SQLAlchemy连接mysql时,所出现的importerror: dll load failed: 找不到指定模块
刚开始学习使用flask来构建web,在连接数据库的时候碰到了这么一个大问题,经过了百度了之后发现很多说法,都尝试了可是无解,mysql-python等都已经在cmd上安装,但是还是出现了这个问题,贴出代码其实也就是很简单的一个creat_all() 但是就是无法解决解决方式:找一下是否存在flask-mysqldb 这个如果没有的话 install 就可以了  ...
sklearn报错解决 ImportError: DLL load failed: 找不到指定的模块
如果遇到错误:ImportError: DLL load failed: 找不到指定的模块出现错误原因:安装包的来源问题,也可以理解为包版本兼容问题,有的包使用官方出版,有的包使用whl文件安装解决方案:将所有包都统一来源,要么全部使用官方出版的包,要么全部使用whl里面的包,问题就解决了numpy+scipy+scikit-learn组件,使用whl文件安装下载:链接:https://pan.b...