骑驴喝凉茶
2016-11-24 07:02
采纳率: 100%
浏览 2.4k
已采纳

flume配置了kakfaChannel后,启动报错!求大神帮忙

是在虚拟机上配置搭建的服务,flume部署在172.235.10.10上,
kafka部署在172.235.10.11上。配置文件如下:
flume:
a1.sources = r1
a1.sinks = k1
a1.channels = c1

a1.sources.r1.type = http
a1.sources.r1.channels = c1
a1.sources.r1.bind = 0.0.0.0
a1.sources.r1.port = 8000

a1.sinks.k1.type = file_roll
a1.sinks.k1.channel=c1
a1.sinks.k1.directory=/usr/log/flume

a1.channels.c1.type = org.apache.flume.channel.kafka.KafkaChannel
a1.channels.c1.capacity = 1000
a1.channels.c1.transactionCapacity = 100
a1.channels.c1.brokerList=172.235.10.11:9002
a1.channels.c1.topic=test2
a1.channels.c1.zookeeperConnect=172.235.10.11:2181

zookeeper是使用了kafka自带的,配置文件没做修改

kafka配置server.properties修改:
host.name=172.235.10.11
zookeeper.connect=172.235.10.11:2181

kafka启动正常,生产者和消费者也是可以通话的

但在启动flume的时候却报这样的一个错误:
Error while getting events from Kafka. This is usually caused by trying to read a non-flume event. Ensure the setting for parseAsFlumeEvent is correct

求大神帮忙

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

3条回答 默认 最新

  • -修- 2016-11-24 08:21
    已采纳

    检查下你的Kafka,配置多个Kafka源以从同一主题读取,试一下。或者去http://blog.csdn.net/high2011/article/details/53282128上看下,不知道有没有帮助,没有勿喷

    点赞 打赏 评论
  • -修- 2016-11-24 08:12

    确保parseasflumeevent设置正确

    点赞 打赏 评论
  • 骑驴喝凉茶 2016-11-24 08:35

    kafka的配置应该是没问题的,server.properties里面我就修改了host.name=172.235.10.11和zookeeper.connect=172.235.10.11:2181
    这两个内容,主题我也有创建,kafka源的话我就配置了一个172.235.10.11。你发的那文章我之前也有搜索到,对我目前的问题好像没什么帮助。不过,还是非常感谢您。

    点赞 打赏 评论

相关推荐