linux安装opencv,执行cmake .报错 10C

CMakeError.log内容:
cc1plus: 警告:命令行选项“-Wmissing-prototypes”对 C/ObjC 是有效的,但对 C++ 无效
cc1plus: 警告:命令行选项“-Wstrict-prototypes”对 C/ObjC 是有效的,但对 C++ 无效
cc1plus: 警告:命令行选项“-Wno-missing-declarations”对 C/ObjC 是有效的,但对 C++ 无效
cc1plus: 错误:无法识别的命令行选项“-Wno-misleading-indentation”
make[1]: *** [CMakeFiles/cmTC_16c2d.dir/src.cxx.o] 错误 1
make[1]: Leaving directory `/home/d5000/fujian/opencv-3.2.0/CMakeFiles/CMakeTmp'
make: *** [cmTC_16c2d/fast] 错误 2

1个回答

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
linux安装opencv,执行cmake .报错 求大神!!
CMakeError.log内容: cc1plus: 警告:命令行选项“-Wmissing-prototypes”对 C/ObjC 是有效的,但对 C++ 无效 cc1plus: 警告:命令行选项“-Wstrict-prototypes”对 C/ObjC 是有效的,但对 C++ 无效 cc1plus: 警告:命令行选项“-Wno-missing-declarations”对 C/ObjC 是
cmake编译opencv报错
错误 CMakeFiles/opencv_example.dir/example.cpp.o:在函数‘main’中: example.cpp:(.text+0x12c):对‘cv::imshow(cv::String const&, cv::_InputArray const&)’未定义的引用 example.cpp:(.text+0x21d):对‘cv::imshow(cv::String
opencv之Cmake的安装(转)
大家可以去官网下载https://cmake.org/ 下面的安装步骤,见这个博主的吧,我就是这样安装的。
菜鸟Linux之旅——安装CMAKE and 编译OpenCV
菜鸟Linux之旅——安装CMAKE and 编译OpenCV 本人Linux新手一枚,学习能力也不强,写博客纯属为了提高自己的学习效率。欢迎大家互相学习,不喜误喷,小女在此谢过了。第一篇技术博客,就先写今天师兄教的——安装CMAKE和编译OpenCV . 安装CMAKE 点击左下角的菜单,选择“终端”,下面这张图我红色框框框出来的的那个图标就是(快捷键ctrl+alt+t 就是!amazing...
解决opencv310 ffmpeg、ippicv_windows_20151201.zip无法下载问题
ffmpeg文件无法下载CMake错误CMake Warning at cmake/OpenCVUtils.cmake:872 (message): Download: Local copy of opencv_ffmpeg.dll has invalid MD5 hash: 3a56b0b26c0d56457a990eb00d87f889 (expected: 89c783eee1c4
CMake出现问题(在安装opencv时)
我按照http://blog.csdn.net/msq19895070/article/details/24477575 这篇博客进行交叉编译opencv,前边安装各种依赖库的时候都没有问题,就是在进行cmake的时候出现rn-- Performing Test HAVE_C_FFUNCTION_SECTIONSrn-- Performing Test HAVE_C_FFUNCTION_SECTIONS - Successrn-- Looking for pthread.hrn-- Looking for pthread.h - not foundrn-- Check if the system is big endianrn-- Searching 16 bit integerrn-- Looking for sys/types.hrn-- Looking for sys/types.h - not foundrn-- Looking for stdint.hrn-- Looking for stdint.h - not foundrn-- Looking for stddef.hrn-- Looking for stddef.h - not foundrn-- Check size of unsigned shortrn-- Check size of unsigned short - failedrn-- Check size of unsigned intrn-- Check size of unsigned int - failedrn-- Check size of unsigned longrn-- Check size of unsigned long - failedrnCMake Error at /usr/share/cmake-2.8/Modules/TestBigEndian.cmake:44 (MESSAGE):rn no suitable type foundrnCall Stack (most recent call first):rn CMakeLists.txt:458 (test_big_endian)rnrn-- Configuring incomplete, errors occurred!rn真是不好解决啊,求大神支招!
安装opencv时cmake的问题
cmake -D CMAKE_BUILD_TYPE=RELEASE -D CMAKE_INSTALL_PREFIX=/usr/local -D INSTALL_PYTHON_EXAMPLES=ON -D INSTALL_C_EXAMPLES=OFF -D INSTALL_C++_EXAMPLES=ON -D OPENCV_EXTRA_MODULES_PATH=~/opencv/opencv-3.2...
Linux 下安装Cmake操作步骤
Linux下安装Cmake,配置环境
linux cmake的下载、安装
使用cmake时,首先要确定linux系统中gcc和gcc-c++的版本,因为如果高版本的cmake是支持高版本的gcc的,所以根据自己需要安装对应版本的cmake。 可以去cmake的官网下载 https://cmake.org/download/ 本人使用的是cmake-3.8.2.tar.gz ,系统的gcc版本为4.4.2. 如果需要cmake-3.8.2.tar.gz,可以去...
linux安装cmake错误
编译cmake时出错,gcc版本够啊rn[img=https://img-bbs.csdn.net/upload/201808/12/1534080282_319010.png][/img]
Linux 安装cmake工具。
安装cmake工具: 使用yum命令安装GCC开发工具包以及开发库。
linux安装cmake出错
linux安装cmake3.4.2,执行./bootstrap后,出现这样的错误rnrn/home/lwz/cmake-3.4.2/Bootstrap.cmk/cmIML/INT.h:829: error: conflicting rnrndeclaration ‘int (* cmIML_INT_intptr_t__VERIFY__)[4]’rnrnrn/home/lwz/cmake-3.4.2/Bootstrap.cmk/cmIML/INT.h:829: error: rnrn‘cmIML_INT_intptr_t__VERIFY__’ has a previous declaration as ‘int (* rnrncmIML_INT_intptr_t__VERIFY__)[8]’rnrnrn/home/lwz/cmake-3.4.2/Bootstrap.cmk/cmIML/INT.h:832: error: conflicting rnrndeclaration ‘int (* cmIML_INT_uintptr_t__VERIFY__)[4]’rnrnrn/home/lwz/cmake-3.4.2/Bootstrap.cmk/cmIML/INT.h:832: error: rnrn‘cmIML_INT_uintptr_t__VERIFY__’ has a previous declaration as ‘int (* rnrncmIML_INT_uintptr_t__VERIFY__)[8]’rnrnrngmake: *** [cmake.o] Error 1rnrnrn---------------------------------------------rnrnrnError when bootstrapping CMake:rnProblem while running gmakernrnrn---------------------------------------------rnrnLog of errors: /home/lwz/cmake-3.4.2/Bootstrap.cmk/cmake_bootstrap.logrnrn大家有没有人知道这是怎么回事啊?rn
安装MySQL时,CMAKE报错
环境必须安装:yum -y install gcc gcc-c++ cmake如果不是缺少管理用户、相应的工具。解决方法:清除缓存文件需要把源码目录中的CMakeCache.txt文件删除,然后再重新CMAKE。...
CMAKE安装VTK时报错
以下是错误提示:   CMake Error at F:/Program Files/CMake 2.8/share/cmake-2.8/Modules/CMakeTestCCompiler.cmake:61 (message):   The C compiler "F:/Program Files/Microsoft Visual Studio   10.0/VC/bin/cl.e
Linux 脚本执行编译cmake
Linux 脚本执行编译Cmake 1、使用cmake外部编译的方式,将编译过程的产生文件和make成果物放在某一个新建文件夹内,这样不影响已有的工程文件,一下三个文件main.cpp CMakeLists.txt domake.sh放在同目录下 main.cpp #include <iostream> int main() { std::cout<<"Hello ...
Linux入门:安装opencv后报错
在CentOS中安装了opencv-python 之后,在使用 import cv2 时报错和相应的解决方法(在CentOS中没有apt-get时,可以使用如下方法)。 错误1: ImportError: libSM.so.6: cannot open shared object file: No such file or directory 解决方法: 提示需要的安装包 yum wh...
在linux下安装cmake(虚拟机的linux)
 1.在网址:http://www.cmake.org/cmake/resources/software.html,找到最新版本的cmake位置。会有两个版本发布:Source Distribution 和 Binary Distribution,我们这里使用后者:已经编译好的可执行版,直接可以拿来用的。(此为第一步骤,打开官网,先不要下载)   2.在linux环境下打开终端(右建最下端)...
Linux的opencv教程之安装与配置+cmake编译
在nanopi m3上测试过,可以运行opencv。 具体可以参考opencv提供的安装文档。需要的软件包GCC 4.4或更高 CMake 2.8.7或更高 Git GTK+2.x或更高,并包含头文件(libgtk2.0-dev) pkg-config Python 2.6或者更高和Numpy1.5或者更高的开发包(python-dev, python-numpy) ffmpeg或者l
linux 安装或更新 cmake
导读 从MySQL5.5版本开始,MySQL源码安装的编译工具由configure开始向cmake过渡    cmake是一个跨平台的安装(编译)工具    安装最新的cmake版本需要我们去官网下载最新的源码包使用命令 查看当前cmake版本cmake --version第一步:首先yum安装gcc gcc-c++ yum install gcc-c++ gcc -y第二步:去 cmake官网 ...
linux安装cmake及其图形界面
搭建平台:deepin15.4安装cmake:sudo apt-get install cmake查看版本:cmake --version我的显示的是:cmake version 3.6.2测试:新建文件夹cmake_demo1 进入cmake_demo1,新建文件main.cpp:#include <iostream> int main() { std::cout<<"Hell
linux安装jdk报错无法执行二进制文件
    今天本来美滋滋的在linux上安装jdk,一顿操作之后一个java -version甩出,结果给我报错,说无法执行二进制文件!What?什么鬼?    好,先检查是不是环境变量没有配置好,检查完了没问题。    这就奇怪了,一般jdk不行都是环境变量的问题啊,于是我直接到jdk的bin目录下执行java命令,也是报错。突然一想,二进制文件,为什么这里面的都是二进制文件,叮~特么不会是我的l...
cuda安装 vs配置 opencv的cmake编译
(更新) D:\opencv\build\install\include D:\opencv\build\install\x64\vc14\lib cuda.lib cudadevrt.lib cudart.lib cudart_static.lib nvcuvid.lib OpenCL.lib opencv_aruco341d.lib opencv_bgsegm341d.lib...
Mac电脑中安装OpenCV配合Cmake
请注意,不要从opencv官网上按照那个openCV for ios 安装。那个是针对ios开发的版本! 好了,现在我们看看要运行OpenCV需要什么。 (1)Xcode  苹果机自带,大家应该都有吧,没有去苹果商店免费下载就行。 (2)CMake CMake官网下载最新mac包,双击即可。 (3)OpenCV OpenCV官网下载,需要编译,编译的时候需要依靠CMake
ubuntu下安装opencv,cmake出错,解决方法
ubuntu opencv安装时,cmake -- Configuring incomplete, errors occurred!CMakeOutput.log
linux执行脚本报错
代码 rn #!/bin/shrnrn# tries to determine arguments to launch AOI-SERVERrnPID=`ps aux | grep cmppserver | grep -v grep | grep -v "start.sh" | awk 'print $2'`rn#echo PID=$PID.rnif [ "" = "$PID" ] ; thenrn echo " CMPPSERVER isn't running."rn exit 1rnelsern kill -9 $PIDrn echo " CMPPSERVER(pid:$PID) be killed."rn exit 0rnfi rnrn报错rn: command not foundrnstop2.sh: line 14: syntax error: unexpected end of file
linux 下了opencv cmake时出错: package "OpenCV" NOT FOUND
出现了如题的错误求大神解决rnrn配置完是3.1.0的opencv版本rnsolo@solo-Inspiron-5547:~/program/opencv$ pkg-config --modversion opencvrn3.1.0rn有这个不知道算不算是配置完全了rnrn[b]CMakeLists.txt文件[/b]rnproject( DisplayImage )rnfind_package( OpenCV REQUIRED )rnadd_executable( DisplayImage DisplayImage )rntarget_link_libraries( DisplayImage $OpenCV_LIBS )rnrn在输入solo@solo-Inspiron-5547:~/program/opencv$ cmake . rnrnCMake Error at CMakeLists.txt:2 (find_package):rn Found package configuration file:rnrn /usr/local/opencv-3.1.0/cmake/OpenCVConfig.cmakernrn but it set OpenCV_FOUND to FALSE so package "OpenCV" is considered to bern NOT FOUND.rnrn应该就是找不到OpenCV在哪里``````````大佬来解答吗rn
编译链接、cmake和编译opencv
编译程序小结前段时间看了下cmake,这里以编译opencv3.1为例作一个简单的小结,顺便总结一下编译连接与库的知识,实践所得,没有系统验证。 编译、连接与库 编译、连接与库首先,编译连接的基本概念我事先是有的但是有些问题没有搞清楚。1.静态链接库和动态连接库的区别首先库就分动态连接库和静态连接库。比如说在程序里调用了一段第三方库的程序, 假如它是静态连接库的话,那在调用这段程序的时候就会把这段第
使用cmake编译opencv
1)选择opencv源代码路径 2)选择opencv下build文件夹 3)点击configure 4)选择自己电脑版本的vs 5)点击finish 等待一段时间后会出现上图的情况,根据需要勾选方框,再点击Generate,当我们点击 Configure 以后需要找到 BUILD_opencv_world 这一个选项,并且勾选它。 编译成功 这个时候我们再打开 build 文件夹就可以看到生...
CMake交叉编译OpenCV
桌面环境:Windows Subsystem for Linux 4.4.0-17134-Microsoft Cmake:Visual Studio Tools for Cmake 1.0 OpenCV版本:3.3.0 工具链版本:gcc6.4.0 g++6.4.0   示例代码: #include &amp;lt;stdio.h&amp;gt; #include &amp;lt;stdlib.h&amp;gt; ...
使用cmake交叉编译opencv
准备: 首先交叉编译需要交叉编译工具链 然后是在目标板上运行的动态链接库1.新建工程工程名为cuseopencv,添加文件cuseopencv.cpp cuseopencv.cpp内容如下#include <iostream> #include <opencv2/opencv.hpp> using namespace std; using namespace cv; int main( int
opencv——cmake files :xfeatures2d
boostdesc_bgm.i; boostdesc_bgm_bi.i; boostdesc_bgm_hd.i; boostdesc_binboost_064.i; boostdesc_binboost_128.i; boostdesc_binboost_256.i; boostdesc_Ibgm.i; vgg_generated_48.i; vgg_generated_64.i; vgg_generated_80.i; vgg_generated_120.i;
Linux环境下的OpenCV安装
ubuntu10.04系统 OpenCV版本为2.4.5
Linux环境下OpenCV的安装
Linux ubuntu环境下OpenCV的安装
OpenCV的安装经验(Linux)
本文总结了使用OpenCV的方法套路,使用此方法安装、导入工程可以灵活地选择自己要安装的版本。
Linux opencv 安装与删除
安装: 1:下载opencv.2.4.13.tar.gz 2:    解压 tar -xzvf opencv.2.4.13.tar.gz  3:    cd  OpenCV-2.4.13 4:    cmake CMakeLists.txt 5:    make install  删除opencv 1:yum remove opencv 2:模糊删除 find  -name
Linux的OpenCV安装及测试
安装及测试请参考: http://opencv.org/ 官网的教程很标准,比二手资料好太多。
linux 安装 opencv 编译错误
各位好:rn 我用的是rh9的版本的linux,装在虚拟机上!在我安装opencv1.0版本的时候,先./configure ,最后显示让我执行make,但是在make到最后阶段时,就出现编译错误了。rn rn 我个人认为是我系统的配置有问题。请各位帮忙说说在安装时候遇到的问题,和解决的办法,谢谢!
OpenCV的Android平台交叉编译(CMake)
1.环境与工具 cmake version 3.7.2GNU Make 4.1android-ndk-r15cOpenCV 3.4.0 2.准备工作 解压缩 android-ndk-r15c-linux-x86_64.zip 到 ~/android-ndk-r15c 解压缩 opencv-3.4.0.zip 到 ~/opencv-3.4.0 3.生成交叉编译工具 进入工具
cmake之管理多版本opencv
我要使用orb-slam2,依赖DBoW2,DBoW2依赖DLib,不就是装软件嘛,谁不会啊~
cmake好的opencv
通过cmake编译完成的mingw编译用的opencv,opencv 3.4.1,文件为dll.a
相关热词 c# 标准差 计算 c#siki第五季 c#入门推荐书 c# 解码海康数据流 c# xml的遍历循环 c# 取 查看源码没有的 c#解决高并发 委托 c#日期转化为字符串 c# 显示问号 c# 字典对象池