qq_37961932
择忆霖心
采纳率96.7%
2017-12-22 08:37 浏览 5.8k

Android Studio3.0依赖问题

5

图片说明
打开那个链接是这样的
图片说明

 Unable to resolve dependency for ':app@release/compileClasspath': Could not resolve com.android.support:appcompat-v7:26.1.0.

Could not resolve com.android.support:appcompat-v7:26.1.0.
Required by:
    project :app
 > Could not resolve com.android.support:appcompat-v7:26.1.0.
    > Could not get resource 'https://jcenter.bintray.com/com/android/support/appcompat-v7/26.1.0/appcompat-v7-26.1.0.pom'.
          > Could not GET 'https://jcenter.bintray.com/com/android/support/appcompat-v7/26.1.0/appcompat-v7-26.1.0.pom'.
                   > Server sent an unsupported extension: type_35
  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

7条回答 默认 最新

  • 已采纳
    qq_21086517 轩辕凌飞 2017-12-22 10:20

    建议使用2.x版本,更稳定,3.0感觉还是不稳

    点赞 评论 复制链接分享
  • qq_39687085 肖思其 2018-01-28 08:14

    http://www.dnzg.cn/chengxusheji/Android/20180127-56943.html
    在这个网站找到了方法

    Android Studio报错Unable to resolve dependency for ':app@release/compileClasspath':无法引用任何外部依赖的解决办法
    Android Studio 在引用外部依赖时,发现一直无法引用外部依赖。刚开始以为是墙的问题,尝试修改Gradle配置,未解决问题。
    最终发现原来是在Android Sudio安装优化配置时,将Gradle设置为了离线工作模式

    解决方法:只需打开File->Settings->Build,Execution,Deployment->Gradle->取消offline work勾选

    点赞 5 评论 复制链接分享
  • qq_30371917 qq_30371917 2017-12-22 08:42

    建议不要使用3.0,目前不稳定,后期问题很多,推荐使用2.3.3

    点赞 评论 复制链接分享
  • m0_37940541 Rowliner 2017-12-22 08:47

    gradle 配置出错了 ,依赖没有问题

    点赞 评论 复制链接分享
  • qq_30679205 码农翻身变农码 2017-12-22 08:56

    推荐2.2,2.3吧,稳定好用,3.0问题多,不习惯,

    点赞 评论 复制链接分享
  • weipoiu weipoiu 2017-12-22 09:01

    3.0的没啥问题啊 我现在用的好好的 你看下你的是不是网络原因 很多资源是被墙的 要自己去单独下好在用的

    点赞 评论 复制链接分享
  • jingjc jingjc 2017-12-22 12:08

    3.0 对应gradle4.1 谷歌的gradle插件3.0.0

    点赞 评论 复制链接分享

相关推荐