maven-compiler-plugin插件版本信息在哪里修改?

mvn编译和测试都遇到这个问题,好像要改maven-compiler-plugin插件版本信息,可是在哪里改啊?
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.1:compile (default-compile) on project MakeFridends: Compilation failure: Compilation failure:
[ERROR] Source option 5 is no longer supported. Use 6 or later.
[ERROR] Target option 1.5 is no longer supported. Use 1.6 or later.

4个回答

maven项目最最主要的目录结构
root
+/src 这里是源码和配置文件
+pom.xml 这个是maven的管理文件 Project Object Model
-----------------------下面是我的配置文件

org.apache.maven.plugins
maven-compiler-plugin
3.5.1

1.8
1.8
UTF-8

xiaonannew
小南xyz 回复qq_39282993: 回复上不能写xml, maven-compiler-plugin的版本是3.5.1
大约 2 年之前 回复
qq_39282993
qq_39282993 3.5.1是什么的版本?我的jdk是10.0.1,所以要把1.8改成10.0.1吗?
大约 2 年之前 回复
xiaokemh
xiaokemh 回复qq_39282993: 你工程一打开就是pom,而且有个东西叫全局搜索你不知道吗?遇见问题搜一下看看错在哪
大约 2 年之前 回复
qq_39282993
qq_39282993 我就是想问这个pom文件在哪里,因为我找不到?不是想问怎么改
大约 2 年之前 回复

一般情况下,这段pom代码应该在你们的pom.xml靠下方的位置
父节点应该是
你仔细看里面有一个plugin就是这个插件
报这个错是因为你的本地开发jdk版本比你pom文件用的高
改成你需要的版本就行了

pom文件就可以修改的。

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐