pip 安装出现错误SSL,然后升级之后,又出现No module named _internal 5C

windows 下,python2.7.5
pip 安装 beautifulsoup4 时
第一次没有成功,报的是 SSL 的错误
然后查了说是需要什么手动升级pip
之后就用这条指令 就出现这个错误了
查了说是,pip 包已经损坏
我在自己解压之后的pip包里面重新执行了python setup.py install, 问题还是没有解决
是要重新下载安装pip 吗?

E:\python2.7.5\Scripts> pip --trusted-host pypi.python.org install  beautifulsoup4
Traceback (most recent call last):
  File "E:\python2.7.5\Scripts\pip-script.py", line 11, in <module>
    load_entry_point('pip==10.0.1', 'console_scripts', 'pip')()
  File "build\bdist.win32\egg\pkg_resources\__init__.py", line 476, in load_entry_point
  File "build\bdist.win32\egg\pkg_resources\__init__.py", line 2700, in load_entry_point
  File "build\bdist.win32\egg\pkg_resources\__init__.py", line 2318, in load
  File "build\bdist.win32\egg\pkg_resources\__init__.py", line 2324, in resolve
ImportError: No module named _internal 

多谢各位了!
喜欢学python ,安装包的问题把自己给难住了

1

2个回答

可能是网络不好,试试看 --trusted-host mirrors.aliyun.com,用阿里云的镜像,或者开了代理再试试看。

0
0
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
TensorFlow安装及注意事项
今天把TensorFlow安装了一下,安装过程中出现了不少问题,特记录如下: 参照这篇博客(真正从零开始,TensorFlow详细安装入门图文教程!)进行安装。 安装TensorFlow时候,指令如下: $ sudo pip install --upgrade https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow-0.9
pip工具更新及解决"No module named pip"问题
pip更新指令:    python -m pip install --upgrade pip输入运行后如果出现错误“no module named pip”,则运行以下指令:    python -m ensurepip    easy_install pip
使用pip安装模块时提示: No module named pip
使用pip安装模块时提示: No module named pip 今天使用pip安装模块提示错误信息: No module named pip windows 解决方法: &amp;gt;&amp;gt;&amp;gt; python -m ensurepip Ignoring indexes: https://pypi.python.org/simple Requirement already sat...
ubuntu安装tensorflow时使用pip安装时出现SSLError[已解决]
SSL error can be solved by bellow steps for sure. Just download the wheel on your own and pip install.Ubuntu/Linux 64-bit, CPU only:$ wget https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow
使用pip安装模块时提示:No module named pip
安装模块提示错误信息: ModuleNotFoundError: No module named 'pip' 解决方法: python -m ensurepip 升级pip版本 python -m pip install --upgrade pip
Windows下使用pip时出现TSL/SSL错误解决方案
刚装的python3.7使用pip安装出现如下错误 pip is configured with locations that require TLS/SSL, however the ssl module in Python is not avail 处理办法: 打开以下目录,并创建pip文件夹 C:\Users\用户\AppData\Roaming 进入pip文件夹,创建pip.ini...
pip 安装 ssl错误
Could not fetch URL https://pypi.python.org/simple/xlrd/: There was a problem confirming the ssl certificate: [SSL: TLSV1_ALERT_PROTOCOL_VERSION] tlsv1 alert protocol version (_ssl.c:661) - skippingC...
python从2.6升级到3.6后安装pip报错SSL模块不存在
python从2.6升级到3.6后安装pip报错SSL模块不存在python get-pip.py 报错:pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.解决办法:网上介绍的一种办法,对3.6.5版本而言,无此参数,无效./configu...
虚拟机内pip安装package或升级报错ssl error
早上在虚拟机内安装python包,执行时报错报错内容SSLError: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:748)看着是权限认证失败,上网查询后得知是机器时间问题,执行同步时间命令后问题解决sudo hwclock -s-s参数表示硬件时间同步系统时间不再报错,安装成功...
linux和mac 上 pip 不支持ssl的问题
报错:pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.新版的pip 默认要求使用https源了,pip 的源可以使用国内的源,下载速度会很快。参考这个 http://mirrors.aliyun.com/help/pypipip.conf...
pip安装第三方包出现ssl错误的解决方法
我的情况是这样的 centos7系统,内置python2.7,python3.4,(后来加上自己又安装了一个python3.6) pip安装第三方包时,用pip2可以安装,没有报错。 pip3安装会报ssl错误。 python3控制台中import ssl报错。 因为个人解决的时候试了很多种方法,所以具体有哪几个步骤才是关键的我也不是很清楚。但总的来看有这些地方。 首先记得安装相关的依...
windows下,安装pycharm后用pip安装第三方包报出ssl错误解决方法
windows下安装pycharm后,使用pip命令出现了问题,提示说找不到ssl模块,出现错误如下: pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available. 针对这个问题网上,很多关于Linux环境下的解决方法。而我用的是Windows...
离线安装安装python36和pip3、Tensorflow
先查看以下两篇博客: 腾讯云安装python36和pip3、Tensorflow yum下载安装包但不安装 上面介绍了在线安装python36和pip3、Tensorflow的方法,离线安装时的方法类似在线安装,但得记录yum和pip包的依赖和记录。 总纲 本文分两条路线走,第一条是通过在线安装下载需要的yum包和pip包,记录yum依赖和pip依赖,第二条路线是离线安装下载好的yum包(pyth...
Windows 7下用 pip 安装 markupsafe 时遇到的错误
前几天写 Python 爬虫,在 Windows 7 上用 pip 安装了很多Python 库。但是安装 jinja2 时遇到了问题。第一次安装 jinja2 失败,第二次显示成功。但是我到Python IDLE 里 import jinja2 时却出现下面的错误:>>> import jinja2 Traceback (most recent call last): File "<pyshel
pip升级后遇到的错误
pip升级到10之后出现错误,解决方法卸载原有的pip  apt-get remove python-pipeasy_install -U pip原理未知,留个坑回头踩
安装opencc出错
安装 python版本的:     pip install opencc-python     安装时会报错:   报错一: ImportError: No module named distribute_setup    解决方法,到 http://www.minitw.com/download/distribute_setup.zip 下载ZIP,解压后将.py文件放置到 电脑的分
python升级引起的pip执行错误
centos6.x默认安装的python为2.6版本,今天换成了3.5版本 这里不再讲如何升级python版本 在安装完新的版本后,之前安装的插件都不能使用了,再用pip进行安装提示已经安装过,但是运行程序依旧在import出报错。 执行升级命令 python -m pip install -U pip 升级成功,但依旧在运行程序时报找不到import的插件 于是用python
Python安装Pip出现的问题
采用Pip安装Python第三方包是比较方便的,下面介绍一下Pip的安装: 1.下载地址:https://pypi.python.org/pypi/pip#downloads 2.解压后,从命令行进入解压目录,运行:python setup.py install 3.在这一步可能会出现“ImportError: No module named setuptools”的错误,是由于pyth
关于python中pip安装出错,找不到ssl的问题
在Ubuntu16.04上安装Python3.6之后,使用pip命令出现了问题,提示找不到ssl模块,出现错误如下: ​ pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available. Could not fetch URL https:****...
继 解决升级python后pip问题 之后frida又出现问题
遇到的问题,上图: 解决方法如下: 1。sudo apt-get install python3.6-gdbm(因为我安装的是python3.6.7,所以用了3.6) 2。查看frida版本,又出现如下错误 3。sudo pip install frida-tools 4。再次查看frida版本,成功出现。 ...
Win10 Python 3.6.1 安装pycrypto 过程中遇到的坑以及各种解决方法
环境: Win 10 Python 3.6.1 pycrypto-2.6.1 最近项目的后台接口使用了 RSA非对称加密,需要对接口传参进行公钥加密。本打算按照以前的方法(python 调用class, 开发人员给的rsa 加密解密相关的java code来修改编译生成class)编译过程中,发现行不通。 于是换方向,直接写python rsa公钥加密解密的脚本以供后面使用。 在先...
实用解决:pip升级以及使用pip安装第三方库报错SSL连接的问题
解决pip升级:版本18.0.1升级到19.0.3的问题: 在安装django的时候,出现了pip版本升级的提示: (因为我的pycharm上显示的pip是19.0.3而CMD安装时,却提示我是18.0.1,然后我按照其提示升级,升级失败;) You are using pip version 18.0.1, however version 19.0.3 is available. You sho...
win7下安装配置theano详解
以我自己实验室电脑装win7系统64位为例。 1.安装anaconda(已内置python,numpy和scipy两个必要库以及一些其他库,自带安装。) 地址:https://www.continuum.io/downloads 选择对应版本即可,按照步骤依次安装,注意安装目录,因为后面配置环境变量会用到,使用默认目录即可,但是注意后面配置环境变量也要对应到安装目录。 Anaconda的一
Python安装模块出错(No module named setuptools)解决方法
Python第三方模块中一般会自带setup.py文件,在Windows环境下,我们只需要在命令行中使用以下命令即可自动化安装   python setup.py install   安装的过程中有可能会出现“ImportError: No module named setuptools”的错误提示,这是因为Windows环境下Python默认是没有安装setuptools这个模块的,这...
pip安装Python库目录问题
今天在win7环境,使用pip安装matplotlib库,界面提示成功,但是使用PyCharm运行相关程序时,提示matplotlib库不存在,为此排查原因。 经排查发现,在使用win+R调用DOS界面时,系统的默认路径为c:\Users\lenovo,使matplotlib库安装在“C:\Users\lenovo\AppData\Roaming\Python\Python36\site-pac...
python pip 安装第三方库 ssl报错解决方案
命令行输入命令 pip --trusted-host pypi.python.org install 安装包的名称
python安装pyquery失败解决方法
安装失败的原因通常是因为lxml安装失败,在windows上可以到这里: http://www.lfd.uci.edu/~gohlke/pythonlibs/  找到对应的版本版本安装 Lxml, a binding for the libxml2 and libxslt libraries. lxml‑3.4.2‑cp26‑none‑win32.whllxml‑3.4.2‑c
centos 安装pip 报错
下载get-pip.py文件后 用python get-pip.py 安装报以下错误: pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available. Collecting xxx Could not fetch URL https
python安装第三方包(库)/导入第三方包(库)报错ImportError:No module named request的解决办法
ImportError:No module named request的解决办法 最开始开发的时候,只安装了python,编辑器用的eclipse(比较讨厌pycharm编辑中文不显示的问题),没有easy_install,没有pip,导入第三方库报错ImportError:No module named request。 步骤:   首先,安装pip,如果已安装,直接跳到第二步; 这里...
安装jumpserver 前,python 依赖环境常见报错yum
1、安装python的时候出现如下的错误   no acceptable C compiler found in $PATHchecking for --enable-universalsdk... nochecking for --with-universal-archs... 32-bitchecking MACHDEP... linuxchecking for --without-gcc.....
superset安装问题总结
superset是一个开源的数据分析系统,可以直接连接服务器上的数据库,画图功能更是很强大。秒杀excel。哈哈。 搭建环境:anaconda 。anaconda下载安装步骤忽略。 安装步骤:打开dos,切换到annconda安装目录下: 新建虚拟环境,避免虚拟环境和系统环境冲突 pip install virtualenv virtualenv venv venv/Scripts/activat...
plotly问题
(1)新建了一个文件plotly.py,运行就会出错。 plotly文件名与plotly重名了,改为plot.py (2)再运行,还会出错,而且以前运行正常的文件也不能在此目录下运行了。 此目录下用ls -a查看,看到一个plotly.pyc的文件,删除此文件就可以了。 (3)运行plot.py,还会提示无法发现graph_objs。不知道是不是因为尝试安装新显卡时,改动了系统的原因,ni
使用 Python 安装 xlutils 出错
// Python 版本:2.7.4 // xlutils 版本:1.6.0 // 系统:Windows 7 64 bit 在 cmd 下执行命令 python setup.py install 出现如下错误: Traceback (most recent call last):   File "setup.py", line 5, in    
安装、升级pip,但是python -m pip install --upgrade pip报错的解决办法。
一般我们在安装或者调用pip库的时候,会告诉你pip版本较低,需要你升级,比如我的本机是如下。 一、 我是直接cd到我pip目录文件下查看版本: E:\Program Files (x86)\python\Scripts&gt;pip show pip Name: pip Version: 10.0.1 Summary: The PyPA recommend...
python3使用pip安装pyautogui过程中遇到的几个问题
最近想要做一个模拟鼠标点击的小程序(具体原因不说了哈:)),就想到使用python,上网搜了一下,很多都使用pyautogui这个库的,于是就想要安装pyautogui,但是过程中遇到了几个坑,写此博记录一下,当然也很高兴可以为看到此博的你解决同样的问题。 先写一下自己的环境:操作系统windows7 64位,python版本python-3.7.0-amd64,安装方式pip。OK,下面就开始...
解决pip安装时出现SSLError的问题
出现这个问题的原因是安装源的证书不受信任,可更改pip的配置文件解决这个问题: 更改配置文件首先要知道配置文件在哪?通过阅读pip的源码: 以下是pip源码 if WINDOWS: bin_py = os.path.join(sys.prefix, 'Scripts') bin_user = os.path.join(user_site, 'Scripts') # buil...
python安装好后,提示找不到ssl模块
1.测试 [root@s011805161450 ~]# python Python 2.7.8 (default, Jun 17 2016, 01:25:39)  [GCC 4.4.7 20120313 (Red Hat 4.4.7-17)] on linux2 Type "help", "copyright", "credits" or "license" for more infor
python3中pip3安装出错,找不到SSL
最近在Ubuntu16.04上安装Python3.6之后,使用pip命令出现了问题,提示说找不到ssl模块,出现错误如下:pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.Could not fetch URL https:*******:
python中使用pip install 命令时报ssl缺失的错误
python中使用pip install 命令时报ssl缺失的错误
python安装问题
问题1: 安装python3.7时,执行命令 sudo make install 时,报以下告警:   The directory '/home/libing/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the ...
文章热词 机器学习教程 Objective-C培训 交互设计视频教程 颜色模型 设计制作学习
相关热词 mysql关联查询两次本表 native底部 react extjs glyph 图标 区块链什么时候出现的 java学习常出现的问题