Myc_CSDN
和Java狼狈为奸
2018-08-30 08:49
采纳率: 61.5%
浏览 9.2k
已采纳

springboot +mybatis,配置了数据源,启动还是报错,百度,千篇一律的答案都不是我要的

已经配置了mybatis,如下:

 <environments default="development">
        <environment id="development">
            <transactionManager type="JDBC"></transactionManager>
            <dataSource type="POOLED">
                <property name="driver" value="com.mysql.jdbc.Driver"/>
                <property name="url" value="jdbc:mysql://127.0.0.1:3306/db_cloudplatform" />
                <property name="username" value="root"/>
                <property name="password" value="myc123456" />
                <!-- 初始化连接大小 -->
                <property name="initialSize" value="10" />
                <!-- 连接池最大数量 -->
                <property name="maxActive" value="60" />
                <!-- 连接池最大空闲 -->
                <property name="maxIdle" value="60" />
                <!-- 连接池最小空闲 -->
                <property name="minIdle" value="2" />
                <!-- 获取连接最大等待时间 -->
                <property name="maxWait" value="6000" />

                <!--<property name="timeBetweenEvictionRunsMillis" value="${timeBetweenEvictionRunsMillis}"/>

                <property name="minEvictableIdleTimeMillis" value="${minEvictableIdleTimeMillis}"/>

                <property name="validationQuery" value="${validationQuery}"/>-->
            </dataSource>
        </environment>
    </environments>

启动一直报错:

 Failed to configure a DataSource: 'url' attribute is not specified and no embedded datasource could be configured.

Reason: Failed to determine a suitable driver class


Action:

Consider the following:
    If you want an embedded database (H2, HSQL or Derby), please put it on the classpath.
    If you have database settings to be loaded from a particular profile you may need to activate it (no profiles are currently active).

望高手指点

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

11条回答 默认 最新

  • niaonao
    niaonao 2018-08-31 05:26
    已采纳
    点赞 评论
  • weixin_42920757
    小小菜鸟2020 2018-08-30 08:54

    http://www.mybatis.org/mybatis-3/zh/configuration.html#environments
    里面有一个提示 如果你正在使用 Spring + MyBatis,则没有必要配置事务管理器, 因为 Spring 模块会使用自带的管理器来覆盖前面的配置。
    直接配置






    试一下

    点赞 评论
  • weixin_42920757
    小小菜鸟2020 2018-08-30 08:57

    上面的没有显示出来

    <dataSource type="org.myproject.C3P0DataSourceFactory">
                                    <property name="driver" value="com.mysql.jdbc.Driver"/>
                    <property name="url" value="jdbc:mysql://127.0.0.1:3306/db_cloudplatform" />
                    <property name="username" value="root"/>
                    <property name="password" value="myc123456" />
    </dataSource>
    
    
    点赞 评论
  • x948130516
    沫离痕 2018-08-30 08:59

    应该把数据源配置进SqlSessionFactoryBean里吧

    点赞 评论
  • zhaomin_g
    _zming 2018-08-30 09:04

    看报错好想是url和驱动不匹配,试试自己手动写个jdbc代码看看能不能获取到连接,

     Class.forName("com.mysql.jdbc.Driver");
            String url = "jdbc:mysql://127.0.0.1:3306/db_cloudplatform";
            DriverManager.getConnection(url, "root", "myc123456");
    
    点赞 评论
  • xcgh
    xcgh 2018-08-30 09:23
    点赞 评论
  • flonny
    精锐小菜鸡 2018-08-31 01:40

    看看是不是xml配置是 : 需要转义
    https://blog.csdn.net/buyaore_wo/article/details/80741159

    点赞 评论
  • tongkaiming
    tongkaiming 2018-08-31 02:23

    数据库版本是什么

    点赞 评论
  • sourcespro
    时间去旅行 2018-08-31 06:40

    直接用这:http://www.mybatis.org/spring-boot-starter/mybatis-spring-boot-autoconfigure/

    org.mybatis.spring.boot
    mybatis-spring-boot-starter
    1.3.2

    点赞 评论
  • TofuCai
    TofuCai 2018-09-01 03:12

    解决方法 1:
    注解这样写:

    @SpringBootApplication(exclude= {DataSourceAutoConfiguration.class})

    解决方案 2:
    1、添加如下依赖

    org.springframework.boot
    spring-boot-starter-web
    <!-- 移除嵌入式tomcat插件 不移除会启动报错 -->


    org.springframework.boot
    spring-boot-starter-tomcat


                2.必须要加否则启动
                <dependency>
            <groupId>javax.servlet</groupId>
            <artifactId>javax.servlet-api</artifactId>
        </dependency>
    

    可以看下这个
    https://blog.csdn.net/liuyinfei_java/article/details/79750146

    点赞 评论
  • Myc_CSDN
    和Java狼狈为奸 2018-09-01 06:15

    谢谢各位,本人将数据源 配置到application.property就可以了

    点赞 评论

相关推荐