两个有序链表序列的合并 (20 分)
已知两个非降序链表序列S1与S2,设计函数构造出S1与S2合并后的新的非降序链表S3。
输入格式:
输入分两行,分别在每行给出由若干个正整数构成的非降序序列,用−1表示序列的结尾(−1不属于这个序列)。数字用空格间隔。
输出格式:
在一行中输出合并后新的非降序链表,数字间用空格分开,结尾不能有多余空格;若新链表为空,输出NULL。
输入样例:
1 3 5 -1
2 4 6 8 10 -1
输出样例:
1 2 3 4 5 6 8 10
这是代码
#include<stdio.h>
#include<stdlib.h>
typedef struct ListNode *node;
struct ListNode {
int num;
node next;
};
node readlist();
node merge(node s1, node s2 );
node apply();
int main()
{
node s1,s2,s3;
s1 = apply();
s2 = apply();
s3 = apply();
s1 = readlist();
s2 = readlist();
s3 = merge(s1,s2);
while(s3!=NULL){
printf("%d ",s3->num);
s3=s3->next;
}
return 0;
}
node apply()
{
node L;
L=(node)malloc(sizeof(struct ListNode));
L=NULL;
return L;
}
node readlist()
{
int n;
node head,p,last;
head=last=NULL;
scanf("%d",&n);
while(n!=-1){
p=(node)malloc(sizeof(struct ListNode));
p->num=n;
p->next=NULL;
if(last!=NULL)
{
last->next=p;
}
else{
head=p;
}
last=p;
scanf("%d",&n);
}
last->next=NULL;
return head;
}
node merge(node s1, node s2 )
{
node s3,Head;
Head=s3;
s1=s1->next;
s2=s2->next;
while(s1!=NULL&&s2!=NULL){
if(s1->num>=s2->num){
s3->next=s2;
s2=s2->next;
}
else{
s3->next=s1;
s1=s1->next;
}
s3=s3->next;
}
if(s1==NULL&&s2==NULL){
return Head;
}
else if(s1!=NULL){
s3->next=s1;
return Head;
}
else if(s2!=NULL){
s3->next=s2;
return Head;
}
}