csdnceshi64
游.程
采纳率33.3%
2015-09-28 10:50

Xcode 7错误:"缺少 iOS 分发的签名身份..."

已采纳

I tried to upload my App to iTunes Connect resp. AppStore and got the following error:

Failed to locate or generate matching signing assets

Xcode attempted to locate or generate matching signing assets and failed to do so because of the following issues.

Missing iOS Distribution signing identity for ... Xcode can request one for you.

Before I setup a new development machine, exported the developer accounts via Xcode 7 from the old to the new machine.

What can I do to fix this?

转载于:https://stackoverflow.com/questions/32821189/xcode-7-error-missing-ios-distribution-signing-identity-for

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

11条回答

  • csdnceshi62 csdnceshi62 5年前

    From Apple -

    Thanks for bringing this to the attention of the community and apologies for the issues you’ve been having. This issue stems from having a copy of the expired WWDR Intermediate certificate in both your System and Login keychains. To resolve the issue, you should first download and install the new WWDR intermediate certificate (by double-clicking on the file). Next, in the Keychain Access application, select the System keychain. Make sure to select “Show Expired Certificates” in the View menu and then delete the expired version of the Apple Worldwide Developer Relations Certificate Authority Intermediate certificate (expired on February 14, 2016). Your certificates should now appear as valid in Keychain Access and be available to Xcode for submissions to the App Store.

    As noted in a comment below, the expired certificate also needs to be removed from the login section, as well:

    To all that cannot get it working despite the instructions... There are two expired WWDR certs. One is in login keychain, and the other one is in the System. You have to delete both of them in order to make things working

    点赞 23 评论 复制链接分享
  • csdnceshi72 谁还没个明天 5年前

    I also faced the same issue today. The following steps fixed my issue.

    1. Download https://developer.apple.com/certificationauthority/AppleWWDRCA.cer
    2. Double-click to install to Keychain.
    3. Then in Keychain, Select View -> "Show Expired Certificates" in Keychain app.
    4. It will list all the expired certifcates.
    5. Delete "Apple Worldwide Developer Relations Certificate Authority certificates" from "login" tab
    6. And also delete it from "System" tab.

    Now you are ready go.

    点赞 30 评论 复制链接分享
  • csdnceshi77 狐狸.fox 5年前

    Don't forget to also install the iOS cert for your Apple Developer Account.

    点赞 10 评论 复制链接分享
  • csdnceshi80 胖鸭 5年前

    I imported the new Apple WWDR Certificate that expires in 2023, but I was still getting problems and my developer certificates were showing the invalid issuer error.

    In keychain access, go to View -> Show Expired Certificates, then in your login keychain highlight the expired WWDR Certificate and delete it. I also had the same expired certificate in my System keychain, so I deleted it from there too.(Important)

    After deleting the expired cert from the login and System keychains, I was able to build for Distribution again.

    点赞 9 评论 复制链接分享
  • csdnceshi76 斗士狗 5年前

    Make Sure that in Project Navigator > Signing > Team , A team name must need be selected.

    enter image description here

    点赞 7 评论 复制链接分享
  • csdnceshi80 胖鸭 5年前

    I removed old AppleWWDRCA, downloaded and installed AppleWWDRCA, but problem remained. I also, checked my distribution and development certificates from Keychain Access, and see below error;

    "This certificate has an invalid issuer."
    

    Then,

    1. I revoked both development and distribution certificates on member center.
    2. Re-created CSR file and add development and distribution certificates from zero, downloaded them, and installed.

    This fixed certificate problem.

    Since old certificates revoked, existing provisioning profiles become invalid. To fix this;

    1. On member center, opened provisioning profiles.
    2. Opened profile detail by clicking "Edit", checked certificate from the list, and clicked "Generate" button.
    3. Downloaded and installed both development and distribution profiles.

    I hope this helps.

    点赞 7 评论 复制链接分享
  • weixin_41568196 撒拉嘿哟木头 4年前

    My answer was different and came along with the message:

    resource fork, Finder information, or similar detritus not allowed
    

    The solution was to do with generated graphics:

    Code Sign Error in macOS Sierra Xcode 8 : resource fork, Finder information, or similar detritus not allowed

    点赞 6 评论 复制链接分享
  • weixin_41568184 叼花硬汉 6年前

    After searching for a while I found out that it is not sufficient to export the developer accounts from Xcode and import these on the new machine, again via Xcode.

    Additionally I needed to copy the Certficate named "Apple World Wide Developer Relations Certificate Authority" from the keychain of the former development machine to the keychain of the new one.

    This solved the problem for me.

    点赞 4 评论 复制链接分享
  • weixin_41568127 ?yb? 5年前

    The below process will solve the problem,

    1: Open KeyChain access, and Delete "Apple world wide Developer relations certification authority" (Which expires on 14th Feb 2016) from both "Login" and "System" sections. If you can't find it, use “Show Expired Certificates” in the 'View' menu.

    enter image description here

    2: Now download https://developer.apple.com/certificationauthority/AppleWWDRCA.cer and double click the certificate to add it to Keychain access > certificates (which expires on 8th Feb 2023). Now the valid status of the certificates should turn green like below.

    enter image description here

    Once check the status.

    点赞 4 评论 复制链接分享
  • csdnceshi66 必承其重 | 欲带皇冠 5年前

    Apple has made following changes so download new certificate developer.apple.com

    renewed certificate and place it as below screen shots .In the keychain as below screen shots click on system and then certificate. Delete the expired certificate . Then drag and drop the AppleWWDRCA.cer that you downloaded from above link

    Apple Worldwide Developer Relations Intermediate Certificate Expiration

    To help protect customers and developers, we require that all third party apps, passes for Apple Wallet, Safari Extensions, Safari Push Notifications, and App Store purchase receipts are signed by a trusted certificate authority. The Apple Worldwide Developer Relations Certificate Authority issues the certificates you use to sign your software for Apple devices, allowing our systems to confirm that your software is delivered to users as intended and has not been modified.

    The Apple Worldwide Developer Relations Certification Intermediate Certificate expires soon and we've issued a renewed certificate that must be included when signing all new Apple Wallet Passes, push packages for Safari Push Notifications, and Safari Extensions starting February 14, 2016.

    While most developers and users will not be affected by the certificate change, we recommend that all developers download and install the renewed certificate on their development systems and servers as a best practice. All apps will remain available on the App Store for iOS, Mac, and Apple TV.

    Since different methods can be used for validating receipts and delivering remote notifications, we recommend that you test your services to ensure no implementation-specific issues exist. Your apps may experience receipt verification failure if the receipt checking code makes incorrect assumptions about the certificate. Make sure that your code adheres to the Receipt Validation Programming Guide and resolve all receipt validation issues before February 14, 2016.

    enter image description here

    点赞 4 评论 复制链接分享
  • csdnceshi64 游.程 5年前

    I kept running into the issue and saw that all my certs were invalidated -- oh no!

    It turns out I never deleted the expired cert. It was not showing up for me, until I selected from Keychain Access application:

    View->Show Expired Certificates

    then

    System->All Items

    will finally display that gnarly expired cert. Delete that and retry from XCode will pick up the new valid certs.

    Just make sure you search "All Items" in the Keychain Access app. The invalidated certs are a result of pointing to the expired certificate that has not been deleted yet.

    点赞 1 评论 复制链接分享

相关推荐