Frodo(180版 2018-12-01 08:18 采纳率: 100%
浏览 2320
已采纳

C语言字符串的排序问题如何解决?

题目描述

输入n个字符串(每个字符串长度不超过100个字符),按从小到达排序输出。
输入描述

第一行输入一个正整数n,下面n行输入n个字符串。
输出描述

按字符串从小到大输出n行(n个字符串)
样例输入

4

C Program

Data Structure and Algorithms

Operating System

C++ Object Oriented Program
样例输出

C Program

C++ Object Oriented Program

Data Structure and Algorithms

Operating System

  • 写回答

1条回答 默认 最新

  • threenewbee 2018-12-02 13:59
    关注
     #include "stdio.h"
    #include "stdlib.h"
    #include "string.h"
    
    int cmp(const void * a, const void * b)
    {
        return strcmp(*((const char **)a), *((const char **)b));
    }
    
    int main()
    {
        int n;
        scanf("%d", &n);
        char ** str = (char **)malloc(sizeof(char *) * n);
        for (int i = 0; i < n; i++)
        {
            str[i] = (char *)malloc(sizeof(char) * 100);
            fflush(stdin);
            scanf("%[^\n]", str[i]);
        }
        qsort(str, n, sizeof(char **), cmp);
        for (int i = 0; i < n; i++)
        {
            printf("%s\n", str[i]);
        }
        return 0;
    }
    

    图片说明

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

悬赏问题

  • ¥15 SPSS分类模型实训题步骤
  • ¥15 求解决扩散模型代码问题
  • ¥15 工创大赛太阳能电动车项目零基础要学什么
  • ¥20 limma多组间分析最终p值只有一个
  • ¥15 nopCommerce开发问题
  • ¥15 torch.multiprocessing.spawn.ProcessExitedException: process 1 terminated with signal SIGKILL
  • ¥15 QuartusⅡ15.0编译项目后,output_files中的.jdi、.sld、.sof不更新怎么解决
  • ¥15 pycharm输出和导师的一样,但是标红
  • ¥15 想问问富文本拿到的html怎么转成docx的
  • ¥15 我看了您的文章,遇到了个问题。