TheGawain 2018-12-01 17:08 采纳率: 50%
浏览 395

hdoj 1002,c语言,测试数据通过,但是wa

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

 #include<stdio.h>

int main()
{
    int n;
    scanf("%d",&n);
    long long i=0,a[20],b[20];
    for(i=0;i<n;i++)
    {
        scanf("%lld %lld",&a[i],&b[i]);
    }
    for(i=0;i<n;i++)
    {
        printf("Case %d:\n%lld + %lld = %lld\n",i+1,a[i],b[i],a[i]+b[i]);
        if(i!=n-1)
            printf("\n");
    }
    return 0;
} 

大一刚开始接触c语言

  • 写回答

1条回答 默认 最新

  • 02Irving11 2019-07-12 15:42
    关注

    这个考你的并不是怎么用long long,而是高精度算法,开long long 会溢出的(题中说了数字位数不超过1000位,早就超long long 范围了)
    这里居然还能遇到我文球迷欢迎追问,求采纳

    评论

报告相同问题?

悬赏问题

  • ¥15 素材场景中光线烘焙后灯光失效
  • ¥15 请教一下各位,为什么我这个没有实现模拟点击
  • ¥15 执行 virtuoso 命令后,界面没有,cadence 启动不起来
  • ¥50 comfyui下连接animatediff节点生成视频质量非常差的原因
  • ¥20 有关区间dp的问题求解
  • ¥15 多电路系统共用电源的串扰问题
  • ¥15 slam rangenet++配置
  • ¥15 有没有研究水声通信方面的帮我改俩matlab代码
  • ¥15 ubuntu子系统密码忘记
  • ¥15 保护模式-系统加载-段寄存器