this_is_user
路过的一般网友
2021-04-02 12:39
采纳率: 100%
浏览 69

importerror:vision libcudart.so.10.0 not found问题

在复现densefusion的代码时,因为自己下的是cuda11.2,因此想修改一下源码中的cuda10,改之前的报错:

ImportError: /usr/local/cuda-11.2/lib64/libcudart.so.10.0: version `libcudart.so.10.0' not found
(required by /home/wu/PycharmProjects/pythonProject/lib/knn/knn_pytorch.cpython-35m-x86_64-linux-gnu.so)

因为问题出在knn_pytorch.cpython-35m-x86_64-linux-gnu.so里,所以我把里面的所有libcudart.so.10.0改为11.0,更新之后的报错变为version `libcudart.so.11.0' not found,想问下是不是还有其他地方需要改的?

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • wjinjie
    AI 菌 2021-04-03 23:22
    已采纳

    出现这种问题,可能是你版本过高的问题。如果从源码处更改,可能需要详细知道其机理。如果代码官方没有该出明确说明可以兼容cu11.2,建议你改用cuda10.x

    点赞 评论

相关推荐