qq_43478490
凹-----凸
2021-05-07 09:12
采纳率: 75%
浏览 350

cuda安装失败(使用pip install cuda)

pip install cuda只装了一个0.0.1版本的,好像用不了

并且上面提示这么一个错误。

 

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

4条回答 默认 最新

  • ling620
    冰__蓝 2021-05-07 09:24
    已采纳

    你是要安装cuda工具包吗?不能直接使用pip安装,你需要到这个地址:https://developer.nvidia.com/cuda-toolkit-archive 上面找到对应版本(如使用的系统、框架等等)的文件,选择的好工具包下面会有对应的安装命名,直接按照安装命令安装即可。如下所示:

    点赞 评论
  • qq_34124780
    爱晚乏客游 2021-05-07 09:47

    cuda建议用手动安装的方式,包括显卡驱动,cuda和cudnn这三个,这样其他python的虚拟环境就不需要重新安装。如果你非要用命令行安装,也不能使用pip的方式,试试看conda install cuda=版本号 cudatoolkit=版本号,这两个版本好要对应上,不是一样的数字的

    点赞 评论
  • csdn_codechina
    CODE CHINA 2021-05-07 10:43

    看你用的是windows系统,一般在安装系统的时候,就已经安装Nvidia driver了(一般版本都是较新的),所以我这里默认你的驱动没问题,那么需要解决的就是cuda版本问题

    这里我推荐用Anaconda(首先要求你安装这个软件),然后执行下面的指令创建新的虚拟环境

    conda create -n pytorch python=3.6

    接下来看下面这个截图,我默认你安装的pytorch1.8

    我们可以看到需要cuda10.2,可以通过下面指令安装

    conda install cudatoolkit==10.2.89 cudnn

    最后再运行下面指令安装pytorch

    pip install pytorch torchvision
    点赞 评论
  • qq_43478490
    凹-----凸 2021-05-07 19:58

    谢谢大家了

    点赞 评论

相关推荐