彑氷 2021-07-06 19:11 采纳率: 83.3%
浏览 232
已结题

tensorflow2.0版本用1.0代码报错

weights_regularizer = tf.contrib.layers.l2_regularizer(cfg.FLAGS.weight_decay)

AttributeError: module 'tensorflow.compat.v1' has no attribute 'contrib'

l2_regularizer改怎么用,请尽量给出代码

  • 写回答

2条回答 默认 最新

  • CSDN专家-黄老师 2021-07-06 19:13
    关注

    tensorflow2.0将1.0的很多功能优化或去掉了,建议降低tensorflow版本

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

问题事件

  • 系统已结题 1月22日
  • 已采纳回答 1月14日

悬赏问题

  • ¥20 R语言单细胞测序 对seurat对象进行标准化时出现问题
  • ¥15 Anaconda navigator updateor一直更新
  • ¥15 请问如何在matlab里使用raven工具?
  • ¥100 关于ios手游充值到一定金额,再点充值提示公众号的问题。
  • ¥15 求一个stm32串口控制程序
  • ¥20 Windows 驱动开发版本疑问相关
  • ¥15 MAC 未能打开磁盘映像
  • ¥15 fastcap使用,二维导体输入问题
  • ¥15 hosts修改后不能访问
  • ¥15 关于化学反应速率C++编译问题/FLUENT