aiyzb. 2022-08-16 17:46 采纳率: 66.7%
浏览 86
已结题

部署前端安装NPM指定版本

部署JetLinks前端时NPM打包时报错
aiyzb@aiyzb-SY-KL-H310CM-VH-V2-0:~/jetlinks-ui-antd$ npm install

npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: jetlinks@1.2.0
npm ERR! Found: antd@3.26.20
npm ERR! node_modules/antd
npm ERR! antd@"^3.26.18" from the root project
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer antd@"4.x" from @ant-design/pro-layout@4.11.4
npm ERR! node_modules/@ant-design/pro-layout
npm ERR! @ant-design/pro-layout@"^4.11.4" from the root project
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR!
npm ERR! See /home/aiyzb/.npm/eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/aiyzb/.npm/_logs/2022-08-16T03_37_56_169Z-debug-0.log
aiyzb@aiyzb-SY-KL-H310CM-VH-V2-0:~/jetlinks-ui-antd$

我搜了一些说是NPM版本过高造成的,我就卸载NPM 。试着下载7.X版本的NPM,

aiyzb@aiyzb-SY-KL-H310CM-VH-V2-0:~$ sudo apt install npm7.24.1
正在读取软件包列表
正在分析软件包的依赖关系树
正在读取状态信息 完成
E: 无法定位软件包 npm7.24.1
E: 无法按照 glob ‘npm7.24.1’ 找到任何软件包

是不是命令不对阿,系统是Ubuntu 22.04.1 LTS
  • 写回答

1条回答 默认 最新

  • 杰 c 2022-08-16 17:52
    关注

    npm install --legacy-peer-deps

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

问题事件

  • 系统已结题 8月24日
  • 已采纳回答 8月16日
  • 创建了问题 8月16日

悬赏问题

  • ¥65 LineageOs-21.0系统编译问题
  • ¥30 关于#c++#的问题,请各位专家解答!
  • ¥15 App的会员连续扣费
  • ¥15 不同数据类型的特征融合应该怎么做
  • ¥15 用proteus软件设计一个基于8086微处理器的简易温度计
  • ¥15 用联想小新14Pro
  • ¥15 multisim中关于74ls192n和DSWPK开关仿真图分析(减法计数器)
  • ¥15 w3wp,exe 中发生未处理的 Microsoft ,NETFramework 异常。
  • ¥20 C51单片机程序及仿真(加减器)
  • ¥15 AQWA | 水动力分析 二阶波浪力