人间清醒梦里静 2022-11-01 00:06 采纳率: 100%
浏览 26
已结题

请教:为什么我的maven窗口中显示jackson-databind 2.9.8的包引入的其他依赖包是2.11.3的

想请教的问题

为什么jackson-databind 2.9.8的jar包中,引入的其他依赖包是2.11.3的?

现场环境

首先,电脑本地仓库中根目录下\com\fasterxml\jackson\core目录下内容清空,
然后,项目的pom.xml中引入jackson-databind,如下,使用2.9.8版本

  <dependency>
        <groupId>com.fasterxml.jackson.core</groupId>
        <artifactId>jackson-databind</artifactId>
        <version>2.9.8</version>
</dependency>

接着,在Maven窗口中查看子依赖如下图

img

  • 写回答

2条回答 默认 最新

  • 小码农叔叔 Java领域优质创作者 2022-11-01 08:45
    关注

    检查你的工程结构是不是那种父子工程结构的,然后在父级pom里面统一定义了依赖的版本号,然后再检查下其他模块里面是否引入了这个包,但是版本不一样,如果有,保存版本号一致

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

问题事件

  • 系统已结题 11月9日
  • 已采纳回答 11月1日
  • 创建了问题 11月1日

悬赏问题

  • ¥20 基于决策树的数字信号处理,2ask 2psk 2fsk的代码,检查下报错的原因
  • ¥20 python作业求过程
  • ¥15 wincc已组态的变量过多
  • ¥60 如图:直线与椭圆X轴平行,求直线与椭圆任意一点的相切坐标计算公式
  • ¥50 如何用python使用opencv里的cv::cudacodec::VideoWriter函数对视频进行GPU硬编码
  • ¥100 c#solidworks 二次开发 工程图自动标边线法兰 等折弯尺寸怎么标
  • ¥15 halcon DrawRegion 提示错误
  • ¥15 FastAPI Uvicorn启动显示404
  • ¥15 centos7.9脚本,怎么排除特定的访问记录
  • ¥15 关于#Django#的问题:我的静态文件呢?