如何更改Drupal CKEditor模块w / CKFinder的最大上传大小?

All uploads made through CKEditor in CKFinder return the message "Invalid file. The file size is too big." when they exceed a certain size, even though I have defined the maximum size to 10MB every place I can think of.

/sites/all/modules/ckeditor/ckfinder/config.php
Every resource type has their maxSize var set to 15728640 bytes. e.g.

$config['ResourceType'][] = Array(
        'name' => 'Files',              // Single quotes not allowed
        'url' => $baseUrl . 'files',
        'directory' => $baseDir . 'files',
        'maxSize' => '10M',
        'allowedExtensions' => '7z,aiff,asf,avi,bmp,csv,doc,docx,fla,flv,gif,gz,gzip,jpeg,jpg,mid,mov,mp3,mp4,mpc,mpeg,mpg,ods,odt,pdf,png,ppt,pptx,pxd,qt,ram,rar,rm,rmi,rmvb,rtf,sdc,sitd,swf,sxc,sxw,tar,tgz,tif,tiff,txt,vsd,wav,wma,wmv,xls,xlsx,zip',
        'deniedExtensions' => '');

I found a maxSize var in /sites/all/modules/ckeditor/ckfinder/plugins/fileeditor/plugin.js as well which I have modified, no luck.

phpinfo() shows the following relevant settings:
post_max_size: 20M
upload_max_filesize: 10M

Both of which should be fine for 10MB uploads.

What else can I change to fix this?!

查看全部
dsxay48646
dsxay48646
2011/03/25 20:29
  • drupal
  • upload
  • ckfinder
  • php
  • ckeditor
  • 点赞
  • 收藏
  • 回答
    私信
满意答案
查看全部

2个回复