做一道C++题目
07:有趣的跳跃
查看提交统计提问
总时间限制: 1000ms 内存限制: 65536kB
描述
一个长度为n(n>0)的序列中存在“有趣的跳跃”当前仅当相邻元素的差的绝对值经过排序后正好是从1到(n-1)。例如,1 4 2 3存在“有趣的跳跃”,因为差的绝对值分别为3,2,1。当然,任何只包含单个元素的序列一定存在“有趣的跳跃”。你需要写一个程序判定给定序列是否存在“有趣的跳跃”。
输入
一行,第一个数是n(0 < n < 3000),为序列长度,接下来有n个整数,依次为序列中各元素,各元素的绝对值均不超过1,000,000,000。
输出
一行,若该序列存在“有趣的跳跃”,输出"Jolly",否则输出"Not jolly"。
样例输入
4 1 4 2 3
样例输出
Jolly
我的答案:
#include<bits/stdc++.h>
using namespace std;
int abs(int a){
if(a>=0) return a;
if(a<0) return -a;
}
int main(){
int n,temp=0;
int a[3000],b[3000],c[3000];
cin>>n;
if(n==1){
int ab;
cin>>ab;
cout<<"Jolly";
}
else {
int b;
cin>>b;
a[0]=b;
for(int i=1;i<n;i++){
int ab;
cin>>ab;
a[i]=ab;
b[i]=abs(a[i]-a[i-1]);
c[b[i]]=1;
}
for(int i=1;i<=n-1;i++){
if(c[i]!=1){
temp++;
cout"Not jolly";
break;
}
if(temp==0) cout<<"Jolly";
}
}
}
程序编译后报错
不知道问题出在哪,请帮忙指正