douhuang5331 2017-09-28 13:14
浏览 63

phpunit 5.6.4在php 5.6中无法通过composer进行doctrine的依赖

I have a problem composer install dependencies. We use php which is version 5.6.24. When installing phpunit 5.6.4, we install doctrine needs php^7. This is our partial composer.lock after require and install phpunit.

"packages-dev": [
        "name": "doctrine/instantiator",
        "version": "1.1.0",
        "source": {
            "type": "git",
            "url": "",
            "reference": "185b8868aa9bf7159f5f953ed5afb2d7fcdc3bda"
        "dist": {
            "type": "zip",
            "url": "",
            "reference": "185b8868aa9bf7159f5f953ed5afb2d7fcdc3bda",
            "shasum": ""
        "require": {
            "php": "^7.1"

Why does it cause and How do we fix this dependency from php 7 to 5? As I thought, It is possible of using phpunit 5.6.4 in php 5 as show. (We use cakephp 2.10.3 depending on sebastian/exporter 1.2. So we can use only under 5.6.4 phpunit version.)

and we use docker ,so we install library following command .

docker run --rm -it -v $(pwd):/app composer:1.4.1 require --dev phpunit/phpunit:"5.6.4" --ignore-platform-reqs --update-with-dependencies 
  • 写回答

1条回答 默认 最新

  • dousi7919 2017-10-02 05:02

    This problem is caused by incompatible of doctrine version (see and phpdocumentor/reflection-docblock and as it show. I can override invalid versions to use command composer

    require (or --dev) package:$correct_version

    Of course , as well as docker environment.

    Composer file can have ambiguous dependencies' match setting like ^、〜 operator, therefore dependencies will be broken if library installed to be required by dependencies change requirements which has updated incompatible before. So we need implicitly definitions of their correct version in composer.json. Thanks to @TonyChiboucas's comment add your own requirement definition. It becomes a clue to resolve my problem.

    本回答被题主选为最佳回答 , 对您是否有帮助呢?



  • ¥15 delta降尺度计算的一些细节,有偿
  • ¥15 Arduino红外遥控代码有问题
  • ¥15 数值计算离散正交多项式
  • ¥30 数值计算均差系数编程
  • ¥15 redis-full-check比较 两个集群的数据出错
  • ¥15 Matlab编程问题
  • ¥15 训练的多模态特征融合模型准确度很低怎么办
  • ¥15 kylin启动报错log4j类冲突
  • ¥15 超声波模块测距控制点灯,灯的闪烁很不稳定,经过调试发现测的距离偏大
  • ¥15 import arcpy出现importing _arcgisscripting 找不到相关程序